forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Fixes: gentoo#5429 Package-Manager: Portage-2.3.7, Repoman-2.3.2 Signed-off-by: Robin H. Johnson <[email protected]>
- Loading branch information
1 parent
7a54c6d
commit 8e47a75
Showing
4 changed files
with
215 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,32 @@ | ||
diff --git a/src/Makefile b/src/Makefile | ||
index 86e0b3fe..c7db0ee9 100644 | ||
--- a/src/Makefile | ||
+++ b/src/Makefile | ||
@@ -29,14 +29,7 @@ INSTALL_BIN=$(PREFIX)/bin | ||
INSTALL=install | ||
|
||
# Default allocator defaults to Jemalloc if it's not an ARM | ||
-MALLOC=libc | ||
-ifneq ($(uname_M),armv6l) | ||
-ifneq ($(uname_M),armv7l) | ||
-ifeq ($(uname_S),Linux) | ||
- MALLOC=jemalloc | ||
-endif | ||
-endif | ||
-endif | ||
+MALLOC?=jemalloc | ||
|
||
# To get ARM stack traces if Redis crashes we need a special C flag. | ||
ifneq (,$(findstring armv,$(uname_M))) | ||
@@ -120,9 +113,8 @@ ifeq ($(MALLOC),tcmalloc_minimal) | ||
endif | ||
|
||
ifeq ($(MALLOC),jemalloc) | ||
- DEPENDENCY_TARGETS+= jemalloc | ||
- FINAL_CFLAGS+= -DUSE_JEMALLOC -I../deps/jemalloc/include | ||
- FINAL_LIBS+= ../deps/jemalloc/lib/libjemalloc.a | ||
+ FINAL_CFLAGS+= -DUSE_JEMALLOC -DJEMALLOC_NO_DEMANGLE | ||
+ FINAL_LIBS+= -ljemalloc -ldl | ||
endif | ||
|
||
REDIS_CC=$(QUIET_CC)$(CC) $(FINAL_CFLAGS) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,60 @@ | ||
diff --git a/deps/lua/src/lua_cjson.c b/deps/lua/src/lua_cjson.c | ||
index c26c0d7b..fa50c410 100644 | ||
--- a/deps/lua/src/lua_cjson.c | ||
+++ b/deps/lua/src/lua_cjson.c | ||
@@ -46,7 +46,7 @@ | ||
#include "strbuf.h" | ||
#include "fpconv.h" | ||
|
||
-#include "../../../src/solarisfixes.h" | ||
+#include "solarisfixes.h" | ||
|
||
#ifndef CJSON_MODNAME | ||
#define CJSON_MODNAME "cjson" | ||
diff --git a/src/Makefile b/src/Makefile | ||
index 86e0b3fe..09630321 100644 | ||
--- a/src/Makefile | ||
+++ b/src/Makefile | ||
@@ -16,7 +16,7 @@ release_hdr := $(shell sh -c './mkreleasehdr.sh') | ||
uname_S := $(shell sh -c 'uname -s 2>/dev/null || echo not') | ||
uname_M := $(shell sh -c 'uname -m 2>/dev/null || echo not') | ||
OPTIMIZATION?=-O2 | ||
-DEPENDENCY_TARGETS=hiredis linenoise lua | ||
+DEPENDENCY_TARGETS=hiredis linenoise | ||
NODEPS:=clean distclean | ||
|
||
# Default settings | ||
@@ -66,6 +66,7 @@ endif | ||
FINAL_CFLAGS=$(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) $(REDIS_CFLAGS) | ||
FINAL_LDFLAGS=$(LDFLAGS) $(REDIS_LDFLAGS) $(DEBUG) | ||
FINAL_LIBS=-lm | ||
+FINAL_LIBS+=@LUA_LIBS@ | ||
DEBUG=-g -ggdb | ||
|
||
ifeq ($(uname_S),SunOS) | ||
@@ -107,7 +108,7 @@ endif | ||
endif | ||
endif | ||
# Include paths to dependencies | ||
-FINAL_CFLAGS+= -I../deps/hiredis -I../deps/linenoise -I../deps/lua/src | ||
+FINAL_CFLAGS+= -I../deps/hiredis -I../deps/linenoise @LUA_CFLAGS@ | ||
|
||
ifeq ($(MALLOC),tcmalloc) | ||
FINAL_CFLAGS+= -DUSE_TCMALLOC | ||
@@ -145,6 +146,7 @@ endif | ||
REDIS_SERVER_NAME=redis-server | ||
REDIS_SENTINEL_NAME=redis-sentinel | ||
REDIS_SERVER_OBJ=adlist.o quicklist.o ae.o anet.o dict.o server.o sds.o zmalloc.o lzf_c.o lzf_d.o pqsort.o zipmap.o sha1.o ziplist.o release.o networking.o util.o object.o db.o replication.o rdb.o t_string.o t_list.o t_set.o t_zset.o t_hash.o config.o aof.o pubsub.o multi.o debug.o sort.o intset.o syncio.o cluster.o crc16.o endianconv.o slowlog.o scripting.o bio.o rio.o rand.o memtest.o crc64.o bitops.o sentinel.o notify.o setproctitle.o blocked.o hyperloglog.o latency.o sparkline.o redis-check-rdb.o redis-check-aof.o geo.o lazyfree.o module.o evict.o expire.o geohash.o geohash_helper.o childinfo.o defrag.o siphash.o rax.o | ||
+REDIS_SERVER_OBJ+=fpconv.o strbuf.o lua_bit.o lua_cjson.o lua_cmsgpack.o lua_struct.o | ||
REDIS_CLI_NAME=redis-cli | ||
REDIS_CLI_OBJ=anet.o adlist.o redis-cli.o zmalloc.o release.o anet.o ae.o crc64.o | ||
REDIS_BENCHMARK_NAME=redis-benchmark | ||
@@ -196,7 +198,7 @@ endif | ||
|
||
# redis-server | ||
$(REDIS_SERVER_NAME): $(REDIS_SERVER_OBJ) | ||
- $(REDIS_LD) -o $@ $^ ../deps/hiredis/libhiredis.a ../deps/lua/src/liblua.a $(FINAL_LIBS) | ||
+ $(REDIS_LD) -o $@ $^ ../deps/hiredis/libhiredis.a $(FINAL_LIBS) | ||
|
||
# redis-sentinel | ||
$(REDIS_SENTINEL_NAME): $(REDIS_SERVER_NAME) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,122 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit autotools eutils flag-o-matic systemd toolchain-funcs user | ||
|
||
DESCRIPTION="A persistent caching system, key-value and data structures database" | ||
HOMEPAGE="http://redis.io/" | ||
SRC_URI="http://download.redis.io/releases/${P}.tar.gz" | ||
|
||
LICENSE="BSD" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris" | ||
IUSE="+jemalloc tcmalloc luajit test" | ||
SLOT="0" | ||
|
||
RDEPEND="luajit? ( dev-lang/luajit:2 ) | ||
!luajit? ( >=dev-lang/lua-5.1:* ) | ||
tcmalloc? ( dev-util/google-perftools ) | ||
jemalloc? ( >=dev-libs/jemalloc-3.2 )" | ||
DEPEND="virtual/pkgconfig | ||
>=sys-devel/autoconf-2.63 | ||
test? ( dev-lang/tcl:0= ) | ||
${RDEPEND}" | ||
REQUIRED_USE="?? ( tcmalloc jemalloc )" | ||
|
||
S="${WORKDIR}/${PN}-${PV/_/-}" | ||
|
||
pkg_setup() { | ||
enewgroup redis 75 | ||
enewuser redis 75 -1 /var/lib/redis redis | ||
} | ||
|
||
src_prepare() { | ||
epatch \ | ||
"${FILESDIR}"/${PN}-4.0.1-shared.patch \ | ||
"${FILESDIR}"/${PN}-3.2.3-config.patch \ | ||
"${FILESDIR}"/${PN}-4.0.1-sharedlua.patch | ||
eapply_user | ||
|
||
# Copy lua modules into build dir | ||
cp "${S}"/deps/lua/src/{fpconv,lua_bit,lua_cjson,lua_cmsgpack,lua_struct,strbuf}.c "${S}"/src || die | ||
cp "${S}"/deps/lua/src/{fpconv,strbuf}.h "${S}"/src || die | ||
# Append cflag for lua_cjson | ||
# https://github.com/antirez/redis/commit/4fdcd213#diff-3ba529ae517f6b57803af0502f52a40bL61 | ||
append-cflags "-DENABLE_CJSON_GLOBAL" | ||
|
||
# now we will rewrite present Makefiles | ||
local makefiles="" | ||
for MKF in $(find -name 'Makefile' | cut -b 3-); do | ||
mv "${MKF}" "${MKF}.in" | ||
sed -i -e 's:$(CC):@CC@:g' \ | ||
-e 's:$(CFLAGS):@AM_CFLAGS@:g' \ | ||
-e 's: $(DEBUG)::g' \ | ||
-e 's:$(OBJARCH)::g' \ | ||
-e 's:ARCH:TARCH:g' \ | ||
-e '/^CCOPT=/s:$: $(LDFLAGS):g' \ | ||
"${MKF}.in" \ | ||
|| die "Sed failed for ${MKF}" | ||
makefiles+=" ${MKF}" | ||
done | ||
# autodetection of compiler and settings; generates the modified Makefiles | ||
cp "${FILESDIR}"/configure.ac-3.2 configure.ac | ||
sed -i \ | ||
-e "/^AC_INIT/s|, [0-9].+, |, $PV, |" \ | ||
-e "s:AC_CONFIG_FILES(\[Makefile\]):AC_CONFIG_FILES([${makefiles}]):g" \ | ||
-e "/PKG_CHECK_MODULES.*\<LUA\>/s,lua5.1,lua,g" \ | ||
configure.ac || die "Sed failed for configure.ac" | ||
eautoreconf | ||
} | ||
|
||
src_configure() { | ||
econf \ | ||
$(use_with luajit) | ||
|
||
# Linenoise can't be built with -std=c99, see https://bugs.gentoo.org/451164 | ||
# also, don't define ANSI/c99 for lua twice | ||
sed -i -e "s:-std=c99::g" deps/linenoise/Makefile deps/Makefile || die | ||
} | ||
|
||
src_compile() { | ||
tc-export CC AR RANLIB | ||
|
||
local myconf="" | ||
|
||
if use tcmalloc ; then | ||
myconf="${myconf} USE_TCMALLOC=yes" | ||
elif use jemalloc ; then | ||
myconf="${myconf} JEMALLOC_SHARED=yes" | ||
else | ||
myconf="${myconf} MALLOC=yes" | ||
fi | ||
|
||
emake ${myconf} V=1 CC="${CC}" AR="${AR} rcu" RANLIB="${RANLIB}" | ||
} | ||
|
||
src_install() { | ||
insinto /etc/ | ||
doins redis.conf sentinel.conf | ||
use prefix || fowners redis:redis /etc/{redis,sentinel}.conf | ||
fperms 0644 /etc/{redis,sentinel}.conf | ||
|
||
newconfd "${FILESDIR}/redis.confd" redis | ||
newinitd "${FILESDIR}/redis.initd-4" redis | ||
|
||
systemd_newunit "${FILESDIR}/redis.service-2" redis.service | ||
systemd_newtmpfilesd "${FILESDIR}/redis.tmpfiles" redis.conf | ||
|
||
dodoc 00-RELEASENOTES BUGS CONTRIBUTING MANIFESTO README.md | ||
|
||
dobin src/redis-cli | ||
dosbin src/redis-benchmark src/redis-server src/redis-check-aof src/redis-check-rdb | ||
fperms 0750 /usr/sbin/redis-benchmark | ||
dosym /usr/sbin/redis-server /usr/sbin/redis-sentinel | ||
|
||
if use prefix; then | ||
diropts -m0750 | ||
else | ||
diropts -m0750 -o redis -g redis | ||
fi | ||
keepdir /var/{log,lib}/redis | ||
} |