Skip to content

Commit

Permalink
app-office/calcurse: python 3.12 support
Browse files Browse the repository at this point in the history
Also remove unused eclass inherit.

Closes: https://bugs.gentoo.org/929344
Signed-off-by: Hanno Böck <[email protected]>
  • Loading branch information
hannob committed Jun 6, 2024
1 parent 744dc5a commit 8e8bf3d
Showing 1 changed file with 56 additions and 0 deletions.
56 changes: 56 additions & 0 deletions app-office/calcurse/calcurse-4.8.1-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{10..12} )

inherit python-single-r1

DESCRIPTION="A text-based calendar and scheduling application"
HOMEPAGE="https://calcurse.org/"
SRC_URI="https://calcurse.org/files/${P}.tar.gz"

LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 x86"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
IUSE="caldav doc"

RDEPEND="
sys-libs/ncurses:0=
sys-libs/timezone-data
${PYTHON_DEPS}
caldav? (
$(python_gen_cond_dep '
dev-python/httplib2[${PYTHON_USEDEP}]
dev-python/pyparsing[${PYTHON_USEDEP}]
')
)
"

DEPEND="
${RDEPEND}
"

BDEPEND="virtual/pkgconfig"

src_configure() {
local myconf=(
$(use_enable doc docs)
--without-asciidoc # do not use AsciiDoc to regenerate docs
)
ECONF_SOURCE="${S}" econf "${myconf[@]}"
}

src_compile() {
default
if use caldav; then
python_fix_shebang contrib/caldav/calcurse-caldav
fi
}

src_install() {
docompress -x /usr/share/doc # decompress text files
default
}

0 comments on commit 8e8bf3d

Please sign in to comment.