Skip to content

Commit

Permalink
dev-python/urwidtrees: Add python3_7 + EAPI7
Browse files Browse the repository at this point in the history
Signed-off-by: Guillaume Seren <[email protected]>
Closes: gentoo#11515
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
GuillaumeSeren authored and mgorny committed Jul 5, 2019
1 parent fd1a78c commit 8e9679e
Showing 1 changed file with 45 additions and 0 deletions.
45 changes: 45 additions & 0 deletions dev-python/urwidtrees/urwidtrees-1.0.2-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )

inherit distutils-r1

DESCRIPTION="Tree widgets for urwid"
HOMEPAGE="https://github.com/pazz/urwidtrees"
SRC_URI="https://github.com/pazz/urwidtrees/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc"

DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
RDEPEND=">=dev-python/urwid-1.1.0[${PYTHON_USEDEP}]"

src_prepare() {
find -name '*.py' -exec \
sed -i -e '1i# -*- coding: utf-8 -*-' {} + || die

distutils-r1_src_prepare

local md
for md in *.md; do
mv "${md}" "${md%.md}" || die
done
}

src_compile() {
distutils-r1_src_compile

use doc && emake -C docs html
}

src_install() {
distutils-r1_src_install

if use doc; then
dodoc -r docs/build/html/.
fi
}

0 comments on commit 8e9679e

Please sign in to comment.