Skip to content

Commit

Permalink
app-leechcraft/lc-monocle: fix deps, update XDG db
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Georg Rudoy <[email protected]>
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
0xd34df00d authored and juippis committed May 6, 2020
1 parent 051ca2e commit 8eb2a39
Showing 1 changed file with 25 additions and 14 deletions.
39 changes: 25 additions & 14 deletions app-leechcraft/lc-monocle/lc-monocle-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
EAPI=7

inherit leechcraft
inherit xdg-utils leechcraft

DESCRIPTION="Monocle, the modular document viewer for LeechCraft"

Expand All @@ -13,20 +13,23 @@ IUSE="debug +djvu doc +fb2 +mobi +pdf +postscript"

REQUIRED_USE="postscript? ( pdf )"

CDEPEND="~app-leechcraft/lc-core-${PV}
dev-qt/qtnetwork:5
dev-qt/qtwidgets:5
DEPEND="~app-leechcraft/lc-core-${PV}
dev-qt/qtconcurrent:5
dev-qt/qtnetwork:5
dev-qt/qtprintsupport:5
dev-qt/qtwidgets:5
dev-qt/qtxml:5
pdf? ( app-text/poppler[qt5] )
djvu? ( app-text/djvu )"
djvu? ( app-text/djvu )
pdf? ( app-text/poppler:= )
"

RDEPEND="${CDEPEND}
postscript? ( app-text/ghostscript-gpl )"
RDEPEND="${DEPEND}
postscript? ( app-text/ghostscript-gpl )
"

DEPEND="${CDEPEND}
doc? ( app-doc/doxygen[dot] )"
BDEPEND="
doc? ( app-doc/doxygen[dot] )
"

src_configure() {
local mycmakeargs=(
Expand All @@ -37,10 +40,18 @@ src_configure() {
-DENABLE_MONOCLE_PDF=$(usex pdf)
-DENABLE_MONOCLE_POSTRUS=$(usex postscript)
)
cmake-utils_src_configure
cmake_src_configure
}

src_install() {
cmake-utils_src_install
cmake_src_install
use doc && dodoc -r "${CMAKE_BUILD_DIR}"/out/html/*
}

pkg_postinst() {
xdg_desktop_database_update
}

pkg_postrm() {
xdg_desktop_database_update
}

0 comments on commit 8eb2a39

Please sign in to comment.