Skip to content

Commit

Permalink
dev-tex/latex2html: Found and fixed the last unescaped left brace. Bu…
Browse files Browse the repository at this point in the history
…g 617760.

Closes: https://bugs.gentoo.org/617760
Package-Manager: Portage-2.3.10, Repoman-2.3.3
  • Loading branch information
akhuettel committed Sep 23, 2017
1 parent 2580dbc commit 8eb4f77
Show file tree
Hide file tree
Showing 2 changed files with 94 additions and 0 deletions.
12 changes: 12 additions & 0 deletions dev-tex/latex2html/files/latex2html-2017.2-brace-2.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
diff -ruN latex2html-2017.2.orig/styles/frames.perl latex2html-2017.2/styles/frames.perl
--- latex2html-2017.2.orig/styles/frames.perl 2017-01-23 18:14:25.000000000 +0100
+++ latex2html-2017.2/styles/frames.perl 2017-09-23 15:49:27.184088195 +0200
@@ -706,7 +706,7 @@
$_[0] =~ s/<(META NAME|LINK)[^>]*>\s*//g;
$_[0] =~ s/$more_links_mark/$NO_ROBOTS\n$LATEX2HTML_META/g;
local($savedRS)=$/; $/ = '';
- $_[0] =~ s/\n{2;}/\n/sg;
+ $_[0] =~ s/\n\{2;}/\n/sg;
$_[0] =~ s/\s$//s;
$_[0] =~ s!\s*(\n</HEAD>\n)\s*!$1!s;
$/ = $savedRS;
82 changes: 82 additions & 0 deletions dev-tex/latex2html/latex2html-2017.2-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,82 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

DESCRIPTION="Convertor written in Perl that converts LATEX documents to HTML"
HOMEPAGE="http://www.latex2html.org/"
SRC_URI="http://mirrors.ctan.org/support/latex2html/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="gif png"

DEPEND="app-text/ghostscript-gpl
virtual/latex-base
media-libs/netpbm
dev-lang/perl
gif? ( media-libs/giflib )
png? ( media-libs/libpng:0 )"
RDEPEND="${DEPEND}"

PATCHES=(
"${FILESDIR}/${PN}"-{destdir,tests}.patch
"${FILESDIR}/${P}"-dotinc.patch
"${FILESDIR}/${P}"-dotinc-2.patch
"${FILESDIR}/${P}"-brace.patch
"${FILESDIR}/${P}"-brace-2.patch
)

src_prepare() {
default

sed -i -e 's%@PERL@%'"${EPREFIX}"'/usr/bin/perl%g' wrapper/unix.pin || die
}

src_configure() {
local myconf

use gif || use png || myconf="${myconf} --disable-images"

econf --libdir="${EPREFIX}"/usr/$(get_libdir)/latex2html \
--shlibdir="${EPREFIX}"/usr/$(get_libdir)/latex2html \
--enable-pk \
--enable-eps \
--enable-reverse \
--enable-pipes \
--enable-paths \
--enable-wrapper \
--with-texpath="${EPREFIX}"/usr/share/texmf-site/tex/latex/html \
--without-mktexlsr \
$(use_enable gif) \
$(use_enable png) \
${myconf}
}

src_install() {
emake DESTDIR="${D}" install

# make /usr/share/latex2html sticky
keepdir /usr/share/latex2html

# clean the perl scripts up to remove references to the sandbox
local dir="${ED}/usr/$(get_libdir)/latex2html"
if use png || use gif; then
# pstoimg isn't built unless gif or png useflags are enabled
sed -i -e "s:${T}:/tmp:g" "${dir}"/pstoimg.pl || die
fi
sed -i -e "s:${S}::g" "${dir}"/latex2html.pl || die
sed -i -e "s:${T}:/tmp:g" "${dir}"/cfgcache.pm || die
sed -i -e "s:${T}:/tmp:g" "${dir}"/l2hconf.pm || die

dodoc BUGS Changes FAQ MANIFEST README.md TODO
}

pkg_postinst() {
"${EROOT}"/usr/bin/mktexlsr
}

pkg_postrm() {
"${EROOT}"/usr/bin/mktexlsr
}

0 comments on commit 8eb4f77

Please sign in to comment.