Skip to content

Commit

Permalink
dev-python/spyder: bump to 3.2.3
Browse files Browse the repository at this point in the history
Thanks to  Roberto Castagnola <[email protected]>
Bug: https://bugs.gentoo.org/613396
Package-Manager: Portage-2.3.6, Repoman-2.3.3
  • Loading branch information
Andrey Grozin committed Sep 19, 2017
1 parent bd22e44 commit 8eea2eb
Show file tree
Hide file tree
Showing 3 changed files with 119 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/spyder/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST spyder-3.0.2.tar.gz 3207709 SHA256 c308cae5d963a7332548db2dd91ebf105263eb493ce208221a59ad77592399c1 SHA512 7f3723bd98876aa4769877327a93aa02510689708012afc72148c67acd91ab134501ae57471d9cf0e17c9e3892a541b7730a2392ace3c6525443058d0ed01612 WHIRLPOOL 5f1f278fa3c6a98b8d7050bb32e9186cd7053e21d9050bf92b29088154ea3494995bf9953e04d63db4c71ccc37d3a2cdd7e38222b1f82decc2b763144cdf3642
DIST spyder-3.2.3.tar.gz 3342954 SHA256 714c9b9941c1883c810bf87f34d6d46fc4458053e3d138d9e12435ea236b0dd2 SHA512 873a1a0c319fc6580dfbe7370dc5ca132d973b5baf75ba0b6cda228adb7fe7baf4fbdebf4d1984ed6f204c7d27b1bfc2c449199ab02aeb8caf9ebded738f3491 WHIRLPOOL 49729a844157bdd75ced53c1cdfea87cc5366590821f732334dab81bebf094f0d7f09095e88fe584b0d65434f61c71d2bcdb8da29f6af91781bcab1fb2e951e4
59 changes: 59 additions & 0 deletions dev-python/spyder/spyder-3.0.2-r3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python{2_7,3_4,3_5} )

inherit eutils distutils-r1

DESCRIPTION="Python IDE with matlab-like features"
HOMEPAGE="https://github.com/spyder-ide/spyder/ https://pypi.python.org/pypi/spyder/ http://pythonhosted.org/spyder/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc hdf5"

RDEPEND="
dev-python/PyQt5[${PYTHON_USEDEP},svg,webkit]
dev-python/QtPy[${PYTHON_USEDEP},svg,webkit]
dev-python/qtconsole[${PYTHON_USEDEP}]
>=dev-python/rope-0.10.7[${PYTHON_USEDEP}]
dev-python/jedi[${PYTHON_USEDEP}]
dev-python/pyflakes[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/pylint[${PYTHON_USEDEP}]
dev-python/pep8[${PYTHON_USEDEP}]
dev-python/psutil[${PYTHON_USEDEP}]
dev-python/nbconvert[${PYTHON_USEDEP}]
dev-python/qtawesome[${PYTHON_USEDEP}]
dev-python/pickleshare[${PYTHON_USEDEP}]
dev-python/pyzmq[${PYTHON_USEDEP}]
dev-python/chardet[${PYTHON_USEDEP}]
hdf5? ( dev-python/h5py[${PYTHON_USEDEP}] )"
DEPEND="${RDEPEND}
app-arch/unzip"

# Courtesy of Arfrever
PATCHES=( "${FILESDIR}"/${P}-build.patch )

python_compile_all() {
if use doc; then
sphinx-build doc doc/html || die "Generation of documentation failed"
fi
}

python_install() {
distutils-r1_python_install
python_newscript scripts/${PN} ${PN}${EPYTHON:6:1}
}

python_install_all() {
use doc && local HTML_DOCS=( doc/html/. )
distutils-r1_python_install_all
doicon spyder/images/spyder.svg
make_desktop_entry spyder Spyder spyder "Development;IDE"
}
59 changes: 59 additions & 0 deletions dev-python/spyder/spyder-3.2.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )

inherit eutils distutils-r1

DESCRIPTION="Python IDE with matlab-like features"
HOMEPAGE="https://github.com/spyder-ide/spyder/ https://pypi.python.org/pypi/spyder/ http://pythonhosted.org/spyder/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc hdf5"

RDEPEND="
dev-python/PyQt5[${PYTHON_USEDEP},svg,webkit]
dev-python/QtPy[${PYTHON_USEDEP},svg,webkit]
dev-python/qtconsole[${PYTHON_USEDEP}]
>=dev-python/rope-0.10.7[${PYTHON_USEDEP}]
dev-python/jedi[${PYTHON_USEDEP}]
dev-python/pyflakes[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/pylint[${PYTHON_USEDEP}]
dev-python/pep8[${PYTHON_USEDEP}]
dev-python/psutil[${PYTHON_USEDEP}]
dev-python/nbconvert[${PYTHON_USEDEP}]
>=dev-python/qtawesome-0.4.1[${PYTHON_USEDEP}]
dev-python/pickleshare[${PYTHON_USEDEP}]
dev-python/pyzmq[${PYTHON_USEDEP}]
dev-python/chardet[${PYTHON_USEDEP}]
hdf5? ( dev-python/h5py[${PYTHON_USEDEP}] )"
DEPEND="${RDEPEND}
app-arch/unzip"

# Courtesy of Arfrever
PATCHES=( "${FILESDIR}"/${P}-build.patch )

python_compile_all() {
if use doc; then
sphinx-build doc doc/html || die "Generation of documentation failed"
fi
}

python_install() {
distutils-r1_python_install
python_newscript scripts/${PN} ${PN}${EPYTHON:6:1}
}

python_install_all() {
use doc && local HTML_DOCS=( doc/html/. )
distutils-r1_python_install_all
doicon spyder/images/spyder.svg
make_desktop_entry spyder Spyder spyder "Development;IDE"
}

0 comments on commit 8eea2eb

Please sign in to comment.