Skip to content

Commit

Permalink
dev-python/pbr: 4.0.1 bup
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.27, Repoman-2.3.9
  • Loading branch information
prometheanfire committed Apr 4, 2018
1 parent 55ca058 commit 8f21775
Show file tree
Hide file tree
Showing 2 changed files with 71 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/pbr/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST pbr-0.8.2.tar.gz 77790 BLAKE2B 4b2efa9a06f0e47eac8d2b591d2c10223418c5813a8de83696348d7ec7ddd20f077492e43028994f1a2d1e28856d3d6159e4105174a760211584b026a616da24 SHA512 76d7d4c97660d5a6bbe9a33498a93b32528073024520e570739c511c0138ba1af7e35139bf77ca2a94063e5979baccd6252619449d6aed546fd1331be81ab52a
DIST pbr-1.10.0.tar.gz 111425 BLAKE2B 2cef589ada2892dd8357ad3248c4b544d58c699d24b6e299284f49a7f838dcfc846daabc4e40de388848ad415a12c19813e13aab1d3f3bf147e064269e4dd725 SHA512 f7f6ce2f70324e2d287f58c3d12e0be2e33ef9ed32311ad2c56410eb67cda20732adff2058ba2fc244249a17a4c95b0d589ba913db4777e63ff1023ae888c864
DIST pbr-3.1.1.tar.gz 102665 BLAKE2B 301515d50f8550f5553a29faacb1daef589b41b8116320abd4552bb67886498d89eced1f95e1efdd6ac0511a5587eb479dc9d2963a74e92300463c3c53201e7d SHA512 c01fb83678f8fc3acddc153dd341a17ed9d602b6770f0ff244b1c5b54c37d4ddcbd0c3d726f7d7020865819e02797c1c79a0c15e9ee2ae5c1510fce7112b2a3a
DIST pbr-4.0.1.tar.gz 107365 BLAKE2B 26e58558c752972726df5861c8f1c3d7b185064de97af1aade136207fc39ac2a6d994c9ef112fb748be067e84e000054f127aef3f22d48425fc23d7a2a09216e SHA512 f5795629f01dc4e7ebceb18e73eac0aaf44cf432d6c6892e8abf69e02357346da57f6671b00fd69c4e14b2b864a799a74c1f9ebd368ce9d4fd8ae4e51503d495
70 changes: 70 additions & 0 deletions dev-python/pbr/pbr-4.0.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,70 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
PYTHON_REQ_USE="threads(+)"

inherit distutils-r1

DESCRIPTION="Inject some useful and sensible default behaviors into setuptools"
HOMEPAGE="https://github.com/openstack-dev/pbr"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="test"

# git is needed for tests, see https://bugs.launchpad.net/pbr/+bug/1326682 and https://bugs.gentoo.org/show_bug.cgi?id=561038
# docutils is needed for sphinx exceptions... https://bugs.gentoo.org/show_bug.cgi?id=603848
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
>=dev-python/coverage-4.0[${PYTHON_USEDEP}]
!~dev-python/coverage-4.4[${PYTHON_USEDEP}]
>=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
>=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
>=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
>=dev-python/six-1.10.0[${PYTHON_USEDEP}]
>=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
>=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
>=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
>=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
>=dev-python/virtualenv-14.0.6[${PYTHON_USEDEP}]
dev-python/wheel[${PYTHON_USEDEP}]
dev-vcs/git
)"
PDEPEND=""

# This normally actually belongs here.
python_prepare_all() {
# This test passes when run within the source and doesn't represent a failure, but rather
# a gentoo sandbox constraint
# Rm tests that rely upon the package being already installed and fail
sed -e s':test_console_script_develop:_&:' \
-e s':test_console_script_install:_&:' \
-e s':test_sdist_extra_files:_&:' \
-e s':test_command_hooks:_&:' \
-e s':test_sdist_git_extra_files:_&:' \
-i pbr/tests/test_core.py || die
sed -e s':test_command_hooks:_&:' \
-e s':test_global_setup_hooks:_&:' \
-i pbr/tests/test_hooks.py || die
rm pbr/tests/test_wsgi.py || die "couldn't remove wsgi network tests"
einfo "rogue tests disabled"
sed -i '/^hacking/d' test-requirements.txt || die

distutils-r1_python_prepare_all
}

python_test() {
distutils_install_for_testing

rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPTYHON}"

testr init || die "testr init failed under ${EPYTHON}"
testr run || die "testr run failed under ${EPYTHON}"
}

0 comments on commit 8f21775

Please sign in to comment.