Skip to content

Commit

Permalink
dev-ruby/nio4r: add 2.0.0
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.3
  • Loading branch information
graaff committed Jan 31, 2017
1 parent 614103b commit 8f44934
Show file tree
Hide file tree
Showing 2 changed files with 40 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/nio4r/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST nio4r-1.2.1.gem 94208 SHA256 0a5a93676c7c116c51f00366800a7c039d67393dadb4b873059375d7cfa9b6a9 SHA512 3136863955bd6f4d489955bae9baf2fb527447c0e71dade1a05402f3e7c8570bf1dd9b8335d70d7303ec4df0a236b13e4ede74ce9154be00a108afcd7c6b7f40 WHIRLPOOL acb063c6a5e9cb4df6096ecd5bebc9e5d1b2968d35899f05b7110b0037bb37862942e01c44fcbd2731bcb492f9e7fd9acd70a23aee375dae93406688ac7ff593
DIST nio4r-2.0.0.gem 99840 SHA256 2ecc70fe1ae4c8a4638109475dbb6401249facdae5b4be12db931152864844cd SHA512 347afee015e673c8c878799b50affe155ad880608309162de2b4437c051a60feb902b44bc9f5ca5af6fb9e2f84a067410596eac68b1a39374a167205dadc1444 WHIRLPOOL fec5bdd5e2c1ffee8a73116fdf41a7716d72d7a60ed32b52647ee91f3457e1cd77bf39e2a094f2d1939c23d99a3e27294c93e94c0db272874a55573178e1ca14
39 changes: 39 additions & 0 deletions dev-ruby/nio4r/nio4r-2.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

USE_RUBY="ruby21 ruby22 ruby23"

RUBY_FAKEGEM_RECIPE_TEST="rspec3"

RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"

inherit ruby-fakegem

DESCRIPTION="A high performance selector API for monitoring IO objects"
HOMEPAGE="https://github.com/celluloid/nio4r"

LICENSE="MIT"
SLOT="2"
KEYWORDS="~amd64 ~arm ~ppc64 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""

# Note that nio4r bundles a patched copy of libev, and without these
# patches the tests fail: https://github.com/celluloid/nio4r/issues/15

all_ruby_prepare() {
sed -i -e '/[Cc]overalls/d' -e '/[Bb]undler/d' spec/spec_helper.rb || die
sed -e '/extension/ s:^:#:' -i Rakefile || die
}

each_ruby_configure() {
${RUBY} -Cext/${PN} extconf.rb || die
}

each_ruby_compile() {
emake V=1 -Cext/${PN}
cp ext/${PN}/*$(get_modname) lib/ || die
}

0 comments on commit 8f44934

Please sign in to comment.