forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-cpp/robin-hood-hashing: Fix build with gcc-15
Closes: https://bugs.gentoo.org/937693 Signed-off-by: Nick Sarnie <[email protected]>
- Loading branch information
Showing
2 changed files
with
37 additions
and
0 deletions.
There are no files selected for viewing
12 changes: 12 additions & 0 deletions
12
dev-cpp/robin-hood-hashing/files/robin-hood-hashing-include-cstdint.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,12 @@ | ||
diff --git a/src/include/robin_hood.h b/src/include/robin_hood.h | ||
index b4e0fbc..b83eaef 100644 | ||
--- a/src/include/robin_hood.h | ||
+++ b/src/include/robin_hood.h | ||
@@ -39,6 +39,7 @@ | ||
#define ROBIN_HOOD_VERSION_PATCH 5 // for backwards-compatible bug fixes | ||
|
||
#include <algorithm> | ||
+#include <cstdint> | ||
#include <cstdlib> | ||
#include <cstring> | ||
#include <functional> |
25 changes: 25 additions & 0 deletions
25
dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.5-r2.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,25 @@ | ||
# Copyright 1999-2024 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit cmake | ||
|
||
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86" | ||
SRC_URI="https://github.com/martinus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
DESCRIPTION="Fast & memory efficient hashtable based on robin hood hashing for C++11/14/17/20" | ||
HOMEPAGE="https://github.com/martinus/robin-hood-hashing" | ||
|
||
LICENSE="MIT" | ||
SLOT="0" | ||
|
||
PATCHES=( "${FILESDIR}/${PN}-include-cstdint.patch" ) | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DRH_STANDALONE_PROJECT=OFF | ||
-DCMAKE_INSTALL_LIBDIR="${EPREFIX}/usr/share/" | ||
) | ||
cmake_src_configure | ||
} |