Skip to content

Commit

Permalink
gnustep-libs/sope: remove libressl support
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.18, Repoman-3.0.2
Signed-off-by: Mikle Kolyada <[email protected]>
  • Loading branch information
Zlogene committed May 3, 2021
1 parent d12b81e commit 8fb68e8
Show file tree
Hide file tree
Showing 2 changed files with 6 additions and 22 deletions.
14 changes: 3 additions & 11 deletions gnustep-libs/sope/sope-4.1.1.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2019 Gentoo Authors
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
Expand All @@ -12,29 +12,21 @@ SRC_URI="https://github.com/inverse-inc/sope/archive/SOPE-${PV}.tar.gz -> ${P}.t
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="gnutls ldap libressl mysql postgres +ssl +xml"
IUSE="gnutls ldap mysql postgres +ssl +xml"

RDEPEND="
sys-libs/zlib
ldap? ( net-nds/openldap )
gnutls? ( net-libs/gnutls:= )
!gnutls? (
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
dev-libs/openssl:0=
)
mysql? ( dev-db/mysql-connector-c:= )
postgres? ( dev-db/postgresql:= )
xml? ( dev-libs/libxml2:2 )
"
DEPEND="${RDEPEND}"

pkg_pretend() {
if use ssl && use gnutls && use libressl ; then
ewarn "You have enabled both gnutls and libressl, but only"
ewarn "one provider can be active. Using gnutls!"
fi
}

src_configure() {
local ssl_provider
if use ssl ; then
Expand Down
14 changes: 3 additions & 11 deletions gnustep-libs/sope/sope-4.3.2.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2020 Gentoo Authors
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
Expand All @@ -12,29 +12,21 @@ SRC_URI="https://github.com/inverse-inc/sope/archive/SOPE-${PV}.tar.gz -> ${P}.t
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="gnutls ldap libressl mysql postgres +ssl +xml"
IUSE="gnutls ldap mysql postgres +ssl +xml"

RDEPEND="
sys-libs/zlib
ldap? ( net-nds/openldap )
gnutls? ( net-libs/gnutls:= )
!gnutls? (
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
dev-libs/openssl:0=
)
mysql? ( dev-db/mysql-connector-c:= )
postgres? ( dev-db/postgresql:= )
xml? ( dev-libs/libxml2:2 )
"
DEPEND="${RDEPEND}"

pkg_pretend() {
if use ssl && use gnutls && use libressl ; then
ewarn "You have enabled both gnutls and libressl, but only"
ewarn "one provider can be active. Using gnutls!"
fi
}

src_configure() {
local ssl_provider
if use ssl ; then
Expand Down

0 comments on commit 8fb68e8

Please sign in to comment.