Skip to content

Commit

Permalink
dev-libs/skalibs: add 2.13.0.0
Browse files Browse the repository at this point in the history
The --disable-static needs to be explicitly specified in configuration
phase otherwise static libraries are created.

Fixes: fa63abe ("dev-libs/skalibs: drop IUSE=static-libs")
Signed-off-by: Petr Vaněk <[email protected]>
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
arkamar authored and thesamesam committed Jan 17, 2023
1 parent 498bce5 commit 8fc513f
Show file tree
Hide file tree
Showing 2 changed files with 44 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/skalibs/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST skalibs-2.12.0.1.tar.gz 222717 BLAKE2B f094677bbe2efe4c4dcd4359bdfaafa07dc2d436691517a868870e88a360fed8fe81008ebb5ad6f2737d12764a8313b20c31fb52e0c424174744451eca991d9a SHA512 383961588eeb4934ef68e25764d3e258d7d9f19fdd14156490e8d9e2e111050c92b34b1786d007c269d09f82cd234bdcbecb13ef603c101e9439ce4b77a6e635
DIST skalibs-2.13.0.0.tar.gz 227804 BLAKE2B ece7fd2152002300209e209277dd5950de07fa7754145920e9a4a0c799a29a117a55bfb4bf6fcdb8416f9f73f763e5e78873ef7c7944fea1619e1b2ea8b0f9a6 SHA512 33309cb32a15186052a451e9c1eb9f5888f03005141285d121ff41f669ed37191462415dc425d6bf35a1bb448a2e1772d07a91b43513f527acddb0d60cff8b3a
43 changes: 43 additions & 0 deletions dev-libs/skalibs/skalibs-2.13.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit toolchain-funcs

DESCRIPTION="General-purpose libraries from skarnet.org"
HOMEPAGE="https://www.skarnet.org/software/skalibs/"
SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"

LICENSE="ISC"
SLOT="0/$(ver_cut 1-2)"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="doc ipv6"

HTML_DOCS=( doc/. )

src_prepare() {
default

# Avoid QA warning for LDFLAGS addition
sed -i -e 's/.*-Wl,--hash-style=both$/:/' configure || die

sed -i -e '/AR := /d' -e '/RANLIB := /d' Makefile || die
}

src_configure() {
tc-export AR CC RANLIB

local myconf=(
--datadir=/etc
--dynlibdir=/usr/$(get_libdir)
--libdir=/usr/$(get_libdir)/${PN}
--sysdepdir=/usr/$(get_libdir)/${PN}
--enable-clock
--enable-shared
--disable-static
$(use_enable ipv6)
)

econf "${myconf[@]}"
}

0 comments on commit 8fc513f

Please sign in to comment.