forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: portage-2.3.0
- Loading branch information
Showing
2 changed files
with
85 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST sqlite3-1.3.10.gem 60416 SHA256 70d815be84bd9630a0b68b236fd2811eef4297a8e4b53e3df89dd39f2d39efe3 SHA512 0a35896a4b9ce4f1e0f29ef9385f13b418b089d9bad467290e21eb12a4d09ce755231f5844c5009013ac9c73a27f7050ce899660d93d6ecc9e919f048a073cfe WHIRLPOOL 95f5f6d2944012cd4778f5d29e63ae43208e247ff5a9d184409dec4756beb14b90878c5ae6b337bf3f3d1fb9049de0cf65625a8544a429c735d5d9b66f90cd1d | ||
DIST sqlite3-1.3.11.gem 60928 SHA256 de8ecdcc00a7af0cda98661ed94ce442964b9403b425e95c3ac4544b1f3720a7 SHA512 02bef5f8f61d1f04c79d9032d62c9d708dddc2446dd256ad13f932ed4cae256d6c60f742a285bc4015ef5b1fb13e9541738f31fd270fe22320fc176525fe37bb WHIRLPOOL 2fb319f159e50d372ae374a6656b7452a746f6a85d94c7b15745feea73dc9c107dd4c51af54c76115ebe184ef906e41e53f2a72b9beffdada5a533cc5f142494 | ||
DIST sqlite3-1.3.12.gem 64512 SHA256 7d912f1b53d4bc11f84c4076c7ebae73bc21a9d82cc2df750fc37bbef3418d42 SHA512 fd1888b3107b02b15a65fdf081cad59445de4bc00ed244f4d3c09504c78ebbe97d9e1e189d61e6776ef70dedcb4d7b976799fd9d4752caafff733bc50cd0abf5 WHIRLPOOL 0cab560c5f5bae01ac80490d11154e9cb8ab1567fe2596db568023006bb35f2f26c6fa1dfdac47d5d70ec821df846a5337179ac0b96fb6667c4021c5b7f16a9b |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,84 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
USE_RUBY="ruby20 ruby21 ruby22 ruby23" | ||
|
||
RUBY_FAKEGEM_TASK_DOC="faq" | ||
RUBY_FAKEGEM_DOCDIR="doc faq" | ||
RUBY_FAKEGEM_EXTRADOC="API_CHANGES.rdoc README.rdoc ChangeLog.cvs CHANGELOG.rdoc" | ||
|
||
inherit multilib ruby-fakegem | ||
|
||
DESCRIPTION="An extension library to access a SQLite database from Ruby" | ||
HOMEPAGE="https://github.com/sparklemotion/sqlite3-ruby" | ||
LICENSE="BSD" | ||
|
||
KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris" | ||
SLOT="0" | ||
IUSE="" | ||
|
||
RDEPEND+=" >=dev-db/sqlite-3.6.16:3" | ||
DEPEND+=" >=dev-db/sqlite-3.6.16:3" | ||
|
||
ruby_add_bdepend " | ||
dev-ruby/rake-compiler | ||
dev-ruby/hoe | ||
doc? ( dev-ruby/redcloth ) | ||
test? ( dev-ruby/minitest:5 )" | ||
|
||
all_ruby_prepare() { | ||
# We remove the vendor_sqlite3 rake task because it's used to | ||
# bundle SQlite3 which we definitely don't want. | ||
rm tasks/vendor_sqlite3.rake || die | ||
|
||
# Remove license line from hoe to avoid depending on a newer | ||
# version. | ||
sed -i -e '/license/d' tasks/gem.rake || die | ||
|
||
sed -i -e 's:, HOE.spec::' -e '/task :test/d' tasks/native.rake || die | ||
} | ||
|
||
each_ruby_configure() { | ||
${RUBY} -Cext/sqlite3 extconf.rb || die | ||
} | ||
|
||
all_ruby_compile() { | ||
all_fakegem_compile | ||
|
||
if use doc; then | ||
rdoc --title "${P} Dcoumentation" -o doc --main README.rdoc lib *.rdoc ext/*/*.c || die | ||
fi | ||
} | ||
|
||
each_ruby_compile() { | ||
# TODO: not sure what happens with jruby | ||
|
||
emake -Cext/sqlite3 V=1 | ||
mv ext/sqlite3/sqlite3_native$(get_modname) lib/sqlite3/ || die | ||
} | ||
|
||
each_ruby_install() { | ||
each_fakegem_install | ||
|
||
# sqlite3 was called sqlite3-ruby before, so add a spec file that | ||
# simply loads sqlite3 to make sure that old projects load correctly | ||
# we don't even need to create a file to load this: the `require | ||
# sqlite3` was already part of sqlite3-ruby requirements. | ||
cat - <<EOF > "${T}/sqlite3-ruby.gemspec" | ||
# generated by ebuild | ||
# $Id$ | ||
Gem::Specification.new do |s| | ||
s.name = "sqlite3-ruby" | ||
s.version = "${RUBY_FAKEGEM_VERSION}" | ||
s.summary = "Fake gem to load sqlite3" | ||
s.homepage = "${HOMEPAGE}" | ||
s.specification_version = 3 | ||
s.add_runtime_dependency("${RUBY_FAKEGEM_NAME}", ["= ${RUBY_FAKEGEM_VERSION}"]) | ||
end | ||
EOF | ||
RUBY_FAKEGEM_NAME=sqlite3-ruby \ | ||
RUBY_FAKEGEM_GEMSPEC="${T}/sqlite3-ruby.gemspec" \ | ||
ruby_fakegem_install_gemspec | ||
} |