Skip to content

Commit

Permalink
*/*: Drop CMAKE_ECLASS meta var superfluous in EAPI-8
Browse files Browse the repository at this point in the history
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Aug 15, 2022
1 parent 3812501 commit 900accb
Show file tree
Hide file tree
Showing 41 changed files with 1 addition and 42 deletions.
1 change: 0 additions & 1 deletion dev-cpp/gtest/gtest-1.11.0.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,6 @@ EAPI=8
# Python is required for tests and some build tasks.
PYTHON_COMPAT=( python3_{8..10} )

CMAKE_ECLASS=cmake
inherit cmake-multilib python-any-r1

if [[ ${PV} == "9999" ]]; then
Expand Down
3 changes: 1 addition & 2 deletions dev-cpp/gtest/gtest-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,12 +1,11 @@
# Copyright 1999-2021 Gentoo Authors
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

# Python is required for tests and some build tasks.
PYTHON_COMPAT=( python3_{8..10} )

CMAKE_ECLASS=cmake
inherit cmake-multilib python-any-r1

if [[ ${PV} == "9999" ]]; then
Expand Down
1 change: 0 additions & 1 deletion dev-cpp/highway/highway-0.16.0-r1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
inherit cmake-multilib

DESCRIPTION="Performance-portable, length-agnostic SIMD with runtime dispatch"
Expand Down
1 change: 0 additions & 1 deletion dev-cpp/highway/highway-0.17.0.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
inherit cmake-multilib

DESCRIPTION="Performance-portable, length-agnostic SIMD with runtime dispatch"
Expand Down
1 change: 0 additions & 1 deletion dev-cpp/highway/highway-1.0.0.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
inherit cmake-multilib

DESCRIPTION="Performance-portable, length-agnostic SIMD with runtime dispatch"
Expand Down
1 change: 0 additions & 1 deletion dev-cpp/highway/highway-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
inherit cmake-multilib

DESCRIPTION="Performance-portable, length-agnostic SIMD with runtime dispatch"
Expand Down
1 change: 0 additions & 1 deletion dev-cpp/notcurses/notcurses-3.0.5.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS="cmake"
inherit cmake-multilib

DESCRIPTION="Blingful TUIs and character graphics"
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -14,7 +14,6 @@ else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi

CMAKE_ECLASS=cmake
inherit cmake-multilib toolchain-funcs

MULTILIB_CHOST_TOOLS=( /usr/bin/mariadb_config )
Expand Down
1 change: 0 additions & 1 deletion dev-db/mariadb-connector-c/mariadb-connector-c-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -14,7 +14,6 @@ else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi

CMAKE_ECLASS=cmake
inherit cmake-multilib toolchain-funcs

MULTILIB_CHOST_TOOLS=( /usr/bin/mariadb_config )
Expand Down
1 change: 0 additions & 1 deletion dev-libs/json-c/json-c-0.16-r1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
inherit cmake-multilib

DESCRIPTION="A JSON implementation in C"
Expand Down
1 change: 0 additions & 1 deletion dev-libs/json-c/json-c-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
inherit cmake-multilib git-r3

DESCRIPTION="A JSON implementation in C"
Expand Down
1 change: 0 additions & 1 deletion dev-libs/libfmt/libfmt-9.0.0.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
inherit cmake-multilib

DESCRIPTION="Small, safe and fast formatting library"
Expand Down
1 change: 0 additions & 1 deletion dev-libs/libfmt/libfmt-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
inherit cmake-multilib

DESCRIPTION="Small, safe and fast formatting library"
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
inherit cmake-multilib

MY_PN="OpenCL-ICD-Loader"
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
inherit cmake-multilib

MY_PN="OpenCL-ICD-Loader"
Expand Down
1 change: 0 additions & 1 deletion media-libs/codec2/codec2-1.0.3.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
inherit cmake-multilib

MY_PV="${PV%.*}${PV##*.}"
Expand Down
1 change: 0 additions & 1 deletion media-libs/openal/openal-1.22.2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
inherit cmake-multilib

MY_P="${PN}-soft-${PV}"
Expand Down
1 change: 0 additions & 1 deletion media-sound/fluidsynth/fluidsynth-2.2.8.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
inherit cmake-multilib systemd toolchain-funcs

DESCRIPTION="Software real-time synthesizer based on the Soundfont 2 specifications"
Expand Down
1 change: 0 additions & 1 deletion net-libs/libyang/libyang-2.0.194.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
inherit cmake-multilib

DESCRIPTION="YANG data modeling language library"
Expand Down
1 change: 0 additions & 1 deletion net-libs/ngtcp2/ngtcp2-0.7.0.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
inherit cmake-multilib

if [[ ${PV} == 9999 ]] ; then
Expand Down
1 change: 0 additions & 1 deletion net-libs/ngtcp2/ngtcp2-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
inherit cmake-multilib

if [[ ${PV} == 9999 ]] ; then
Expand Down
1 change: 0 additions & 1 deletion sci-mathematics/z3/z3-4.10.1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{8..10} )

inherit cmake-multilib java-pkg-opt-2 python-single-r1
Expand Down
1 change: 0 additions & 1 deletion sci-mathematics/z3/z3-4.10.2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{8..10} )

inherit cmake-multilib java-pkg-opt-2 python-single-r1
Expand Down
1 change: 0 additions & 1 deletion sci-mathematics/z3/z3-4.8.17.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{8..10} )

inherit cmake-multilib java-pkg-opt-2 python-single-r1
Expand Down
1 change: 0 additions & 1 deletion sci-mathematics/z3/z3-4.9.1-r1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{8..10} )

inherit cmake-multilib java-pkg-opt-2 python-single-r1
Expand Down
1 change: 0 additions & 1 deletion sys-libs/libcxx/libcxx-14.0.6.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{8..10} )
inherit cmake-multilib llvm llvm.org python-any-r1 toolchain-funcs

Expand Down
1 change: 0 additions & 1 deletion sys-libs/libcxx/libcxx-15.0.0.9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{8..11} )
inherit cmake-multilib flag-o-matic llvm llvm.org python-any-r1 \
toolchain-funcs
Expand Down
1 change: 0 additions & 1 deletion sys-libs/libcxx/libcxx-15.0.0_rc2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{8..11} )
inherit cmake-multilib flag-o-matic llvm llvm.org python-any-r1 \
toolchain-funcs
Expand Down
1 change: 0 additions & 1 deletion sys-libs/libcxx/libcxx-16.0.0.9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{8..11} )
inherit cmake-multilib flag-o-matic llvm llvm.org python-any-r1 \
toolchain-funcs
Expand Down
1 change: 0 additions & 1 deletion sys-libs/libcxxabi/libcxxabi-14.0.6.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{8..10} )
inherit cmake-multilib llvm llvm.org python-any-r1 toolchain-funcs

Expand Down
1 change: 0 additions & 1 deletion sys-libs/libcxxabi/libcxxabi-15.0.0.9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{8..11} )
inherit cmake-multilib flag-o-matic llvm llvm.org python-any-r1 \
toolchain-funcs
Expand Down
1 change: 0 additions & 1 deletion sys-libs/libcxxabi/libcxxabi-15.0.0_rc2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{8..11} )
inherit cmake-multilib flag-o-matic llvm llvm.org python-any-r1 \
toolchain-funcs
Expand Down
1 change: 0 additions & 1 deletion sys-libs/libcxxabi/libcxxabi-16.0.0.9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{8..11} )
inherit cmake-multilib flag-o-matic llvm llvm.org python-any-r1 \
toolchain-funcs
Expand Down
1 change: 0 additions & 1 deletion sys-libs/libomp/libomp-14.0.6-r1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{8..10} )
inherit cmake-multilib linux-info llvm llvm.org python-any-r1

Expand Down
1 change: 0 additions & 1 deletion sys-libs/libomp/libomp-15.0.0.9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{8..11} )
inherit cmake-multilib linux-info llvm llvm.org python-any-r1

Expand Down
1 change: 0 additions & 1 deletion sys-libs/libomp/libomp-15.0.0_rc2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{8..11} )
inherit cmake-multilib linux-info llvm llvm.org python-any-r1

Expand Down
1 change: 0 additions & 1 deletion sys-libs/libomp/libomp-16.0.0.9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{8..11} )
inherit cmake-multilib linux-info llvm llvm.org python-any-r1

Expand Down
1 change: 0 additions & 1 deletion sys-libs/llvm-libunwind/llvm-libunwind-14.0.6.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{8..10} )
inherit cmake-multilib llvm llvm.org python-any-r1 toolchain-funcs

Expand Down
1 change: 0 additions & 1 deletion sys-libs/llvm-libunwind/llvm-libunwind-15.0.0.9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{8..11} )
inherit cmake-multilib flag-o-matic llvm llvm.org python-any-r1 \
toolchain-funcs
Expand Down
1 change: 0 additions & 1 deletion sys-libs/llvm-libunwind/llvm-libunwind-15.0.0_rc2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{8..11} )
inherit cmake-multilib flag-o-matic llvm llvm.org python-any-r1 \
toolchain-funcs
Expand Down
1 change: 0 additions & 1 deletion sys-libs/llvm-libunwind/llvm-libunwind-16.0.0.9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@

EAPI=8

CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{8..11} )
inherit cmake-multilib flag-o-matic llvm llvm.org python-any-r1 \
toolchain-funcs
Expand Down

0 comments on commit 900accb

Please sign in to comment.