Skip to content

Commit

Permalink
app-shells/dash: fix build with format-security
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.8, Repoman-2.3.3
  • Loading branch information
Whissi committed Sep 13, 2017
1 parent 15f0e92 commit 900e620
Show file tree
Hide file tree
Showing 2 changed files with 89 additions and 0 deletions.
76 changes: 76 additions & 0 deletions app-shells/dash/dash-0.5.9.1-r3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,76 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit flag-o-matic toolchain-funcs versionator

#MY_PV="$(get_version_component_range 1-3)"
DEB_PATCH="" #$(get_version_component_range 4)
#MY_P="${PN}-${MY_PV}"

DESCRIPTION="Debian Almquist Shell"
HOMEPAGE="http://gondor.apana.org.au/~herbert/dash/"
SRC_URI="http://gondor.apana.org.au/~herbert/dash/files/${P}.tar.gz"
if [[ -n "${DEB_PATCH}" ]] ; then
DEB_PF="${PN}_${MY_PV}-${DEB_PATCH}"
SRC_URI+=" mirror://debian/pool/main/d/dash/${DEB_PF}.diff.gz"
fi

LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="libedit static vanilla"

RDEPEND="!static? ( libedit? ( dev-libs/libedit ) )"
DEPEND="${RDEPEND}
virtual/pkgconfig
libedit? ( static? ( dev-libs/libedit[static-libs] ) )"

PATCHES=( "${FILESDIR}"/${PN}-0.5.9.1-format-security.patch )

src_prepare() {
if [[ -n "${DEB_PATCH}" ]] ; then
eapply "${WORKDIR}"/${DEB_PF}.diff
eapply */debian/diff/*
fi

#337329 #527848
use vanilla || eapply "${FILESDIR}"/${PN}-0.5.9.1-dumb-echo.patch

default

# Fix the invalid sort
sed -i -e 's/LC_COLLATE=C/LC_ALL=C/g' src/mkbuiltins

# Use pkg-config for libedit linkage
sed -i \
-e "/LIBS/s:-ledit:\`$(tc-getPKG_CONFIG) --libs libedit $(usex static --static '')\`:" \
configure || die
}

src_configure() {
# don't redefine stat on Solaris
if [[ ${CHOST} == *-solaris* ]] ; then
export ac_cv_func_stat64=yes
fi
append-cppflags -DJOBS=$(usex libedit 1 0)
use static && append-ldflags -static
# Do not pass --enable-glob due to #443552.
# Autotools use $LINENO as a proxy for extended debug support
# (i.e. they're running bash), so disable that. #527644
local myeconfargs=(
--bindir="${EPREFIX}"/bin
--enable-fnmatch
--disable-lineno
$(use_with libedit)
)
econf "${myeconfargs[@]}"
}

src_install() {
default
if [[ -n "${DEB_PATCH}" ]] ; then
dodoc */debian/changelog
fi
}
13 changes: 13 additions & 0 deletions app-shells/dash/files/dash-0.5.9.1-format-security.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
Origin: https://bugzilla.redhat.com/show_bug.cgi?id=1037030#c2

--- a/src/jobs.c
+++ a/src/jobs.c
@@ -427,7 +427,7 @@ sprint_status(char *s, int status, int sigonly)
goto out;
#endif
}
- col = fmtstr(s, 32, strsignal(st));
+ col = fmtstr(s, 32, "%s", strsignal(st));
#ifdef WCOREDUMP
if (WCOREDUMP(status)) {
col += fmtstr(s + col, 16, " (core dumped)");

0 comments on commit 900e620

Please sign in to comment.