Skip to content

Commit

Permalink
dev-python/aiohttp: Bump to 3.7.2
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Oct 28, 2020
1 parent d24992d commit 902bfb4
Show file tree
Hide file tree
Showing 2 changed files with 85 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/aiohttp/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST aiohttp-3.6.2.tar.gz 1076923 BLAKE2B 14327a0bc5b5fffdf436a4c3525e4c25d80100aa464ed652316f7724c2bea6de4ace6c27e8a2a8cf9d895673ed63ed52e8c958ad611636e1e524a4e40efa4735 SHA512 49bd3089158c05ff6312420190ccd7fed95efb4a18b8aff7497d5507c71c692080d6949801edabdcd95379ca8e6614398408118d72ff1e782399e059e2cfc1a8
DIST aiohttp-3.7.0.tar.gz 1112272 BLAKE2B 73dffecc54e47806a7827ca3f6a18cca2121cece368e691b6ba31495affc66c3a4ef67279f218c7972d4a7e71ac123a329d6b2e9ca22dc0afb3b7373d9ab0726 SHA512 97083c2cf294e7324aaa68c36b2e0e352e588b96cd6856308ce1303b5da2df3f3cabcdcde59dc108b6d70c068901dd14ad6a883ee9e25c6b00738e30e3d8f852
DIST aiohttp-3.7.1.tar.gz 1111777 BLAKE2B 03d16e8c9d64ec407cf7b6dbbf5547a88f528ab23e9e256559c11fc2cb6f568101f79dad89b0e5698fd02a3918051e4bc3c349e3ea4358ecb5de1543fea91708 SHA512 accdd588fdd7ba1792cf5e8fb67c6d5dd3e1c5382d9c9ece14e449d6f4f1c116975809d2dad786e0d472b3bb54e3b8c59722be871401a82cef5eff9c12f3c3f8
DIST aiohttp-3.7.2.tar.gz 1111049 BLAKE2B faffc582f2c72ff892862b5b782da75b381e59b21b284b1120e4edb16f22b760f8cabe56261061e0049a5dfd041456076e294e942a02309e9b3d6b414facb0cb SHA512 2dd4f0264f1fb0801be366c269b73dd80b542e8e5bfe18a01fbdfadd0210022ccd6e3975be1be416551ccce82f42881e18735d5c6fc68a42b7452ab18e157dc5
84 changes: 84 additions & 0 deletions dev-python/aiohttp/aiohttp-3.7.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,84 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{6..9} )

inherit distutils-r1

DESCRIPTION="http client/server for asyncio"
HOMEPAGE="https://pypi.org/project/aiohttp/"
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc test"
RESTRICT="!test? ( test )"

COMMON_DEPEND="
>=dev-python/async_timeout-3.0.0[${PYTHON_USEDEP}]
>=dev-python/attrs-17.3.0[${PYTHON_USEDEP}]
dev-python/chardet[${PYTHON_USEDEP}]
>=dev-python/multidict-4.5.0[${PYTHON_USEDEP}]
>=dev-python/yarl-1.0[${PYTHON_USEDEP}]
dev-python/idna-ssl[${PYTHON_USEDEP}]
"
DEPEND="
dev-python/cython[${PYTHON_USEDEP}]
test? (
${COMMON_DEPEND}
!!dev-python/pytest-aiohttp
dev-python/async_generator[${PYTHON_USEDEP}]
dev-python/brotlipy[${PYTHON_USEDEP}]
dev-python/freezegun[${PYTHON_USEDEP}]
www-servers/gunicorn[${PYTHON_USEDEP}]
>=dev-python/pytest-3.4.0[${PYTHON_USEDEP}]
dev-python/pytest-mock[${PYTHON_USEDEP}]
dev-python/pytest-timeout[${PYTHON_USEDEP}]
dev-python/re-assert[${PYTHON_USEDEP}]
dev-python/trustme[${PYTHON_USEDEP}]
)
"
RDEPEND="${COMMON_DEPEND}"

DOCS=( CHANGES.rst CONTRIBUTORS.txt README.rst )

distutils_enable_sphinx docs \
'>=dev-python/alabaster-0.6.2' \
'dev-python/sphinxcontrib-asyncio' \
'dev-python/sphinxcontrib-blockdiag' \
'dev-python/sphinxcontrib-newsfeed' \
'dev-python/sphinxcontrib-spelling' \
'dev-python/sphinx' \
'dev-python/sphinx-aiohttp-theme'

distutils_enable_tests pytest || die "Tests fail with ${EPYTHON}"

python_prepare_all() {
# Fails due to a warning
sed -e 's:test_read_boundary_with_incomplete_chunk:_&:' \
-i tests/test_multipart.py || die
# with py3.7+
sed -e 's:test_aiohttp_request_coroutine:_&:' \
-i tests/test_client_functional.py || die

# Fails due to path mismatch
sed -e 's:test_static:_&:' \
-i tests/test_route_def.py || die

# Internet
sed -e 's:test_mark_formdata_as_processed:_&:' \
-i tests/test_formdata.py || die

distutils-r1_python_prepare_all
}

python_test() {
pushd "${BUILD_DIR}/lib" >/dev/null || die
ln -snf "${S}"/{LICENSE.txt,tests} . || die
pytest -vv tests || die "Tests fail with ${EPYTHON}"
rm -rf .pytest_cache tests || die
popd >/dev/null || die
}

0 comments on commit 902bfb4

Please sign in to comment.