Skip to content

Commit

Permalink
dev-java/jsr173: drop jaxme dependency.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
monsieurp committed Apr 1, 2017
1 parent a33756d commit 903ce83
Showing 1 changed file with 43 additions and 0 deletions.
43 changes: 43 additions & 0 deletions dev-java/jsr173/jsr173-1.0-r4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6

JAVA_PKG_IUSE="doc source"

inherit java-pkg-2 java-pkg-simple

DESCRIPTION="Yet another Java library for parsing and writing XML"
HOMEPAGE="http://dev2dev.bea.com/xml/stax.html"
SRC_URI="http://ftpna2.bea.com/pub/downloads/${PN}.jar"

LICENSE="bea.ri.jsr173"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"

RDEPEND="
${CDEPEND}
>=virtual/jre-1.6"

DEPEND="
${CDEPEND}
>=virtual/jdk-1.6"

S="${WORKDIR}"

DOCS=( README.txt jsr173_1.0.pdf )

src_unpack() {
cd "${S}" || die
jar xvf "${DISTDIR}/${A}" || die "failed to unpack"
jar xvf "${P//-/_}_src.jar" || die "failed to unpack"
}

src_prepare() {
default
java-pkg_clean
}

src_install() {
java-pkg-simple_src_install
use doc && einstalldocs
}

0 comments on commit 903ce83

Please sign in to comment.