Skip to content

Commit

Permalink
dev-ruby/ffi: add 1.9.22
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
graaff committed Feb 23, 2018
1 parent a880818 commit 907e381
Show file tree
Hide file tree
Showing 2 changed files with 65 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/ffi/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST ffi-git-1.9.18.tgz 901805 BLAKE2B b04715095858d461e4a0a904185dbd603e391611ef446de385deb533d8fcbff0ada3f1865599fb51e3446df629c16d491c476e179cfa356c7d8c84e1827b2729 SHA512 49c52e5e42e436b7969c35a34b28bd7929d75372638ac5373486a1d624026c12dc682009bc101e4a2c8f1442ed6f1ba17b438cda2e02d4256622b489c4bd9945
DIST ffi-git-1.9.21.tgz 161824 BLAKE2B f31f9caca1c6f90d7f6bee7756630fdfaff527a96735b3a80ac1f5f0c1a860d6ac6500da06c96e99527a2e75de0a839067d1171cdbefdf9401df101d59b38d4d SHA512 c3049baa2aada3deb1d5a029ce659f802cb0533e2fa6ab6ccc3a45abda4a97fde7964dde314f45e93e4ec3e73f66aa53ff8f7a397a12c70e191f4ddd0b3ed063
DIST ffi-git-1.9.22.tgz 159304 BLAKE2B 096f625d6f1b162cc99f70b9d0783f1176e0d9faa65dcf06c346ef0b78c495a85c50dc728b302bbd9a8648d4d589eea56c0e9791f6065bc5a87331bba92e9656 SHA512 0e2159133629f505de233fa44a004ec74196488540552c8036640c7dd770fadf2b90987096a48ca796ad98436dd63998bd4c7f8b01c871755be49b1ef6045642
64 changes: 64 additions & 0 deletions dev-ruby/ffi/ffi-1.9.22.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,64 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

USE_RUBY="ruby22 ruby23 ruby24"

RUBY_FAKEGEM_RECIPE_TEST="rspec3"

RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="README.md"

inherit multilib ruby-fakegem

DESCRIPTION="Ruby extension for programmatically loading dynamic libraries"
HOMEPAGE="https://wiki.github.com/ffi/ffi"

SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${PN}-git-${PV}.tgz"

IUSE=""
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"

RDEPEND+=" virtual/libffi"
DEPEND+=" virtual/libffi"

ruby_add_bdepend "dev-ruby/rake"

all_ruby_prepare() {
sed -i -e '/tasks/ s:^:#:' \
-e '/Gem::Tasks/,/end/ s:^:#:' Rakefile || die

# Fix Makefile for tests
sed -i -e '/CCACHE :=/ s:^:#:' \
-e 's/-O2//' \
-e 's/^CFLAGS =/CFLAGS +=/' libtest/GNUmakefile || die

# Remove bundled version of libffi.
rm -rf ext/ffi_c/libffi || die
}

each_ruby_configure() {
${RUBY} -Cext/ffi_c extconf.rb || die
}

each_ruby_compile() {
emake -Cext/ffi_c V=1
cp ext/ffi_c/ffi_c$(get_modname) lib/ || die

${RUBY} -S rake -f gen/Rakefile || die "types.conf generation failed"
}

each_ruby_test() {
CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" ${RUBY} -S rspec spec || die
}

all_ruby_install() {
all_fakegem_install

docinto examples
dodoc samples/*
}

0 comments on commit 907e381

Please sign in to comment.