Skip to content

Commit

Permalink
dev-java/gson: add 2.9.0
Browse files Browse the repository at this point in the history
Signed-off-by: Volkmar W. Pogatzki <[email protected]>
Closes: gentoo#25443
Signed-off-by: Florian Schmaus <[email protected]>
  • Loading branch information
vaukai authored and Flowdalic committed May 11, 2022
1 parent 7b93756 commit 908691d
Show file tree
Hide file tree
Showing 2 changed files with 64 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-java/gson/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST gson-2.8.8-sources.tar.gz 393941 BLAKE2B ebdd1088a069eea58e5ea4e2eddea0d42064c53f7284778b1b7217c8bc7abeb7e14350e19d838af1d94f78c5c38aca6de0f37674b022f0e528ed65eef803c3f1 SHA512 f90ad679c99c5e9a6ee9e397e59ab1d7d94a9c82366902b808addc40ebbab101fdba7fc83e4666c4f35e52d8b127e6f901e65072a7de210496466074dcd043c5
DIST gson-2.9.0.tar.gz 350309 BLAKE2B f17f7a7410744b14cb79c979b35c7f3c46a3d9e922722c41893b872013319a1bd06d81526e8380055aafa47524bfcc50e02629d1c5994e1f9f81df4391a9c651 SHA512 25e57f0e3cbff7e4d33070d250ba4ecf1c659380bce07863c52a3b30edd0ba88c923e55b0f38098b5ce3827a74a21c4d41f9de02f6a84da771ae39fd823667d3
63 changes: 63 additions & 0 deletions dev-java/gson/gson-2.9.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,63 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

# Skeleton command:
# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/google/gson/archive/gson-parent-2.9.0.tar.gz --slot 2.6 --keywords "~amd64 ~arm ~arm64 ~ppc64 ~x86" --ebuild gson-2.9.0.ebuild

EAPI=8

JAVA_PKG_IUSE="doc source test"
MAVEN_ID="com.google.code.gson:gson:2.9.0"
JAVA_TESTING_FRAMEWORKS="junit-4"

inherit java-pkg-2 java-pkg-simple

DESCRIPTION="Gson JSON library"
HOMEPAGE="https://github.com/google/gson"
SRC_URI="https://github.com/google/${PN}/archive/${PN}-parent-${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="2.6"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"

DEPEND="
virtual/jdk:11
"

# Set to jre-11:* since jre-1.8:* causes errors:
# error: Invalid SafeVarargs annotation. Instance method <T>assertIterationOrder(Iterable<T>,T...) is not final.
# in src/test/java/com/google/gson/internal/LinkedTreeMapTest.java:164:
RDEPEND="
>=virtual/jre-11:*
"

S="${WORKDIR}/${PN}-${PN}-parent-${PV}/${PN}"

JAVA_SRC_DIR=(
"src/main/java"
"src/main/java-templates"
)

JAVA_TEST_GENTOO_CLASSPATH="junit-4"
JAVA_TEST_SRC_DIR="src/test/java"
JAVA_TEST_RESOURCE_DIRS=(
"src/test/resources"
)

JAVA_TEST_EXCLUDES=(
# requires the test class to be obfuscated using proguard which we do not have atm
"com.google.gson.functional.EnumWithObfuscatedTest"
# FAILURES!!!
# Tests run: 1090, Failures: 3
# testComGoogleGsonAnnotationsPackage(com.google.gson.regression.OSGiTest)
# junit.framework.AssertionFailedError: Cannot find com.google.gson OSGi bundle manifest
"com.google.gson.regression.OSGiTest"
# testSerializeInternalImplementationObject(com.google.gson.functional.ReflectionAccessTest)
# java.lang.IllegalStateException: Expected BEGIN_ARRAY but was BEGIN_OBJECT at line 1 column 2 path $
"com.google.gson.functional.ReflectionAccessTest"
)

src_prepare() {
default
sed -i "s/\${project.version}/${PV}/g" src/main/java-templates/com/google/gson/internal/GsonBuildConfig.java || die "Failed to set version"
}

0 comments on commit 908691d

Please sign in to comment.