Skip to content

Commit

Permalink
dev-ml/menhir: bump to 20151026.
Browse files Browse the repository at this point in the history
Fixes bug #564310

Package-Manager: portage-2.2.23
  • Loading branch information
aballier committed Oct 30, 2015
1 parent ba0e385 commit 909ec35
Show file tree
Hide file tree
Showing 2 changed files with 37 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ml/menhir/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST menhir-20151012.tar.gz 627290 SHA256 c7d4e8cf8e3b009577794c5c01f590379201c77fdc61a832e714beffe7cf22be SHA512 04c10a171fdc24078b6340484314c771b97967a91f506a882bdae741bcc2464ccf3e7f5982339f8cc836abdb0066dc7bcd58a38edbc730a89daf935979fee79c WHIRLPOOL 49b8b0ff0e094e6a5429d747d4ced5ee5515a2f77812f508bd9da872653539ff5540639f6a5a812e4999a7a815bb62b9a6534a71f476dc495a0297ef8f89d737
DIST menhir-20151023.tar.gz 671810 SHA256 2dfb642ba08f95afbb75f71b9bbdcf6733c0e8f81d69406373f1420c5cfeca8a SHA512 0e53365400e88e39d0d595beb594d53bf5614061dc9b0149ec20c00cd3188dd1568ddcca15e1a08dddce20244bebd6263871ab83f761c68c2c62fbedb0d6c980 WHIRLPOOL 1e4b9a32959f2c9e98c92bb75436650c26430f1664d2b663fd572a369c0ce6d5225caa3ea28faa9cee18162fead6481a9777eabf99d6694b999179046b98c7a7
DIST menhir-20151026.tar.gz 672165 SHA256 a735ebdfc3bc4ac132ea4f7c06814915576516915a80ae1c33c45a9368327355 SHA512 86fde7e955164861823dd5fac510235b0bb13f771528435495b3ff3a44bcd4837d2cd8085ba6c53e6e5eaf12f935749951cff09056cbb03a93cef062072fcf2a WHIRLPOOL 4327788dde765a4ea2c06637769626022a64352d36bee29fc615a07485efce2adeacb65267cb44f726203405ee23eea23affdde88e76109f1eb76bd3160dfcdc
36 changes: 36 additions & 0 deletions dev-ml/menhir/menhir-20151026.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit findlib

DESCRIPTION="LR(1) parser generator for the OCaml language"
HOMEPAGE="http://gallium.inria.fr/~fpottier/menhir/"
SRC_URI="http://gallium.inria.fr/~fpottier/menhir/${P}.tar.gz"

LICENSE="QPL-1.0 LGPL-2-with-linking-exception"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="examples +ocamlopt"

DEPEND=">=dev-lang/ocaml-4.02:=[ocamlopt?]"
RDEPEND="${DEPEND}"

src_configure() {
if ! use ocamlopt ; then
export TARGET=byte
fi
}

src_compile() {
emake PREFIX="${EPREFIX}"/usr -j1
}

src_install() {
findlib_src_preinst
emake PREFIX="${ED}"/usr docdir="${ED}"/usr/share/doc/"${PF}" $(use examples || echo "DOCS=manual.pdf") install
use examples && docompress -x /usr/share/doc/${PF}/demos
dodoc AUTHORS CHANGES
}

0 comments on commit 909ec35

Please sign in to comment.