forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-sound/snd: version bump to 16.3
Gentoo-Bug: 404201, 475150 * EAPI=6 Package-Manager: portage-2.2.27
- Loading branch information
1 parent
43df9dd
commit 90c03ac
Showing
3 changed files
with
171 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST snd-12.8.tar.gz 15546751 SHA256 1ff683615ec6d0c7e2c8359e921117f4fd78695675bb06eb765667edb55a1939 SHA512 99a8600a175a889ad597053e9f52af69124cab8feca693c852cb03d34df5b80bcc50994ea66d070fe61e318eca715fdfe095a458b22da80d95f88a1d695baebd WHIRLPOOL b8903b138ab31f2ee51aeabe66068943c24e15e2cd82e628bc446224ebb0e697365c0070ec99d126379a02c1ef7544a1c6195e0bb3a0c8ecb167751eb3c673ef | ||
DIST snd-16.3.tar.gz 14824756 SHA256 7314fd8c73da9d3afa0ed2c7b5a10cda94eaf1e7fb6ab9f6ac2e085c18f50934 SHA512 b58971e95411839b2f1cafde4cdd66784f41510c67588f3816408290fc826b6c24054a03423ca3a59b11dddd45c058cb592fb97cd90d1333eeec36dd125a7821 WHIRLPOOL ad00d30d80e8dbf9b533824a382864725f14ad8a587803a8df6bedb8fe59cc36ae442e345599ebf08d67b9503d6e79e643c066b33be92d50d832d03677da8792 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,49 @@ | ||
--- snd-16.3/configure.ac | ||
+++ snd-16.3/configure.ac | ||
@@ -527,8 +527,9 @@ | ||
|
||
if test "$with_portaudio" = yes ; then | ||
AC_DEFINE(MUS_PORTAUDIO) | ||
+ PKG_CHECK_MODULES([PORTAUDIO], [portaudio-2.0]) | ||
AUDIO_SYSTEM=portaudio | ||
- AUDIO_LIB="-lportaudio" | ||
+ AUDIO_LIB="${PORTAUDIO_LIBS}" | ||
fi | ||
|
||
if test "$with_jack" = yes ; then | ||
--- snd-16.3/makefile.in | ||
+++ snd-16.3/makefile.in | ||
@@ -11,6 +11,7 @@ | ||
GL_FLAGS = @GL_FLAGS@ | ||
GSL_FLAGS = @GSL_CFLAGS@ | ||
JACK_FLAGS = @JACK_FLAGS@ | ||
+PORTAUDIO_CFLAGS = @PORTAUDIO_CFLAGS@ | ||
|
||
ORIGINAL_LDFLAGS = @ORIGINAL_LDFLAGS@ | ||
LDFLAGS = @LDFLAGS@ | ||
@@ -26,6 +27,7 @@ | ||
FFTW_LIBS = @FFTW_LIBS@ | ||
JACK_LIBS = @JACK_LIBS@ | ||
GMP_LIBS = @GMP_LIBS@ | ||
+PORTAUDIO_LIBS = @PORTAUDIO_LIBS@ | ||
|
||
LDSO_FLAGS = @LDSO_FLAGS@ | ||
SO_FLAGS = @SO_FLAGS@ | ||
@@ -51,7 +53,7 @@ | ||
.SUFFIXES: .c .o | ||
|
||
.c.o: | ||
- $(CC) -c $(DEFS) $(GTK_CFLAGS) $(CAIRO_CFLAGS) $(CFLAGS) $(XEN_CFLAGS) $(GSL_FLAGS) $(GL_FLAGS) $(JACK_FLAGS) $(FFTW_CFLAGS) $< | ||
+ $(CC) -c $(DEFS) $(GTK_CFLAGS) $(CAIRO_CFLAGS) $(CFLAGS) $(XEN_CFLAGS) $(GSL_FLAGS) $(GL_FLAGS) $(JACK_FLAGS) $(FFTW_CFLAGS) $(PORTAUDIO_CFLAGS) $< | ||
|
||
SND_SCRIPTS = *.scm *.fs *.rb *.fsm | ||
SNDLIB_HEADERS = mus-config.h sndlib.h _sndlib.h sndlib-strings.h clm.h vct.h sndlib2xen.h clm2xen.h xen.h clm-strings.h | ||
@@ -82,7 +84,7 @@ | ||
main_target: @MAKE_TARGET@ | ||
|
||
snd: $(SNDLIB_HEADERS) $(SND_HEADERS) $(GX_HEADERS) $(S7_HEADERS) $(S7_O_FILES) $(SNDLIB_O_FILES) $(O_FILES) $(GX_FILES) $(GL_FILES) | ||
- $(CC) $(LDFLAGS) $(CFLAGS) $(S7_O_FILES) $(SNDLIB_O_FILES) $(O_FILES) $(GX_FILES) $(GL_FILES) -o snd $(SNDLIB_LIB) $(XEN_LIBS) $(GTK_LIBS) $(GL_LIBS) $(JACK_LIBS) $(AUDIO_LIB) $(FFTW_LIBS) $(GSL_LIBS) $(GMP_LIBS) $(LIBS) | ||
+ $(CC) $(LDFLAGS) $(CFLAGS) $(S7_O_FILES) $(SNDLIB_O_FILES) $(O_FILES) $(GX_FILES) $(GL_FILES) -o snd $(SNDLIB_LIB) $(XEN_LIBS) $(GTK_LIBS) $(GL_LIBS) $(JACK_LIBS) $(AUDIO_LIB) $(FFTW_LIBS) $(GSL_LIBS) $(GMP_LIBS) $(PORTAUDIO_LIBS) $(LIBS) | ||
|
||
xm: xen.h mus-config.h $(S7_HEADERS) | ||
$(CC) -c xm.c -DUSE_SND=0 $(DEFS) $(SO_FLAGS) $(GTK_CFLAGS) $(CAIRO_CFLAGS) $(CFLAGS) $(XEN_CFLAGS) $(GSL_FLAGS) $(JACK_FLAGS) $(GL_FLAGS) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,121 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
inherit autotools flag-o-matic | ||
|
||
DESCRIPTION="Snd is a sound editor" | ||
HOMEPAGE="http://ccrma.stanford.edu/software/snd/" | ||
SRC_URI="ftp://ccrma-ftp.stanford.edu/pub/Lisp/${P}.tar.gz" | ||
|
||
LICENSE="Snd BSD-2 HPND GPL-2+ LGPL-2.1+ LGPL-3+ ruby? ( free-noncomm ) s7? ( free-noncomm )" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~ppc ~x86 ~x86-interix ~amd64-linux ~x86-linux" | ||
IUSE="alsa doc fftw gmp gsl gtk jack ladspa motif opengl oss portaudio pulseaudio readline ruby +s7" | ||
|
||
RDEPEND="media-libs/audiofile | ||
alsa? ( media-libs/alsa-lib ) | ||
fftw? ( sci-libs/fftw ) | ||
gmp? ( dev-libs/gmp | ||
dev-libs/mpc | ||
dev-libs/mpfr ) | ||
gsl? ( sci-libs/gsl ) | ||
gtk? ( x11-libs/gtk+:3 | ||
x11-libs/pango | ||
x11-libs/cairo | ||
opengl? ( x11-libs/gtkglext ) ) | ||
jack? ( media-sound/jack-audio-connection-kit ) | ||
ladspa? ( media-libs/ladspa-sdk ) | ||
motif? ( >=x11-libs/motif-2.3:0 ) | ||
opengl? ( virtual/opengl ) | ||
portaudio? ( media-libs/portaudio ) | ||
pulseaudio? ( media-sound/pulseaudio ) | ||
readline? ( sys-libs/readline ) | ||
ruby? ( dev-lang/ruby )" | ||
|
||
REQUIRED_USE=" | ||
portaudio? ( !pulseaudio ) | ||
pulseaudio? ( !portaudio ) | ||
^^ ( | ||
( !ruby !s7 ) | ||
( ruby !s7 ) | ||
( !ruby s7 ) | ||
)" | ||
PATCHES=( | ||
"${FILESDIR}/${P}-portaudio.patch" | ||
) | ||
|
||
pkg_setup() { | ||
if ! use gtk && ! use motif ; then | ||
ewarn "Warning: no graphic toolkit selected (gtk or motif)." | ||
ewarn "Upstream suggests to enable one of the toolkits (or both)" | ||
ewarn "or only the command line utilities will be helpful." | ||
fi | ||
} | ||
|
||
src_prepare() { | ||
default | ||
sed -i -e "s:-O2 ::" configure.ac || die | ||
eautoreconf | ||
} | ||
|
||
src_configure() { | ||
# Workaround executable sections QA warning (bug #348754) | ||
append-ldflags -Wl,-z,noexecstack | ||
|
||
local myconf | ||
if ! use ruby && ! use s7 ; then | ||
myconf+=" --without-extension-language" | ||
fi | ||
|
||
econf \ | ||
$(use_with alsa) \ | ||
$(use_with fftw) \ | ||
$(use_with gmp) \ | ||
$(use_with gsl) \ | ||
$(use_with gtk) \ | ||
$(use_with jack) \ | ||
$(use_with ladspa) \ | ||
$(use_with motif) \ | ||
$(use_with oss) \ | ||
$(use_with portaudio) \ | ||
$(use_with pulseaudio) \ | ||
$(use_with ruby) \ | ||
$(use_with s7) \ | ||
${myconf} | ||
} | ||
|
||
src_compile() { | ||
emake snd | ||
|
||
# Do not compile ruby extensions for command line programs since they fail | ||
sed -i -e "s:HAVE_RUBY 1:HAVE_RUBY 0:" mus-config.h || die | ||
|
||
local i | ||
for i in sndplay sndinfo; do | ||
emake ${i} | ||
done | ||
} | ||
|
||
src_install () { | ||
dobin snd sndplay sndinfo | ||
|
||
if use ruby ; then | ||
insinto /usr/share/snd | ||
doins *.rb | ||
fi | ||
|
||
if use s7 ; then | ||
insinto /usr/share/snd | ||
doins *.scm | ||
fi | ||
|
||
dodoc README.Snd HISTORY.Snd NEWS | ||
|
||
if use doc ; then | ||
docinto html/ | ||
dodoc -r *.html pix/*.png tutorial | ||
fi | ||
} |