Skip to content

Commit

Permalink
dev-php/xcache: new revision for v3.2.0.
Browse files Browse the repository at this point in the history
The main reason for this revision is to make the coverager module
optional. It is now hidden behind the USE=coverage flag and is not
enabled by default (it is not recommended for production servers).

At the same time, the ebuild was upgraded to EAPI=6 and now uses the
newer revision php-ext-source-r3.eclass. Finally, the htdocs/ admin
interface directory was moved out of /usr/share/php and into
/usr/share/xcache, which is more appropriate. Two minor repoman
warnings were also corrected.

Gentoo-Bug: 491358

Package-Manager: portage-2.2.28
  • Loading branch information
orlitzky committed Jul 10, 2016
1 parent 0164391 commit 90d6b36
Show file tree
Hide file tree
Showing 3 changed files with 71 additions and 60 deletions.
7 changes: 7 additions & 0 deletions dev-php/xcache/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -5,4 +5,11 @@
<email>[email protected]</email>
<name>PHP</name>
</maintainer>

<use>
<flag name="coverage">
Enable the coverager module (not recommended for
production servers).
</flag>
</use>
</pkgmetadata>
64 changes: 64 additions & 0 deletions dev-php/xcache/xcache-3.2.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,64 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

PHP_EXT_NAME="xcache"
PHP_EXT_SAPIS="apache2 cgi fpm"
USE_PHP="php5-5 php5-6"

inherit php-ext-source-r3 confutils

DESCRIPTION="A fast and stable PHP opcode cacher"
HOMEPAGE="http://xcache.lighttpd.net/"
SRC_URI="http://xcache.lighttpd.net/pub/Releases/${PV}/${P}.tar.bz2"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="coverage"

# make test would just run php's test and as such need the full php source
RESTRICT="test"

DEPEND="
!dev-php/eaccelerator
!dev-php/pecl-apc
virtual/httpd-php:*
php_targets_php5-5? ( !dev-lang/php:5.5[opcache] )
"
RDEPEND="${DEPEND}"

DOCS=( AUTHORS ChangeLog NEWS README THANKS )

src_configure() {
PHP_EXT_ECONF_ARGS=(
--enable-xcache=shared
--enable-xcache-constant \
--enable-xcache-optimizer \
$(use_enable coverage xcache-coverager) \
--enable-xcache-assembler \
--enable-xcache-encoder \
--enable-xcache-decoder )

php-ext-source-r3_src_configure
}

src_install() {
php-ext-source-r3_src_install

insinto "${PHP_EXT_SHARED_DIR}"
doins lib/Decompiler.class.php

# Install the admin interface somewhere where it can be
# copied/symlinked into a document root.
insinto "/usr/share/${PN}"
doins -r htdocs
}

pkg_postinst() {
elog "The lib/Decompiler.class.php file shipped with this release"
elog "was installed into ${PHP_EXT_SHARED_DIR}. The htdocs/ admin"
elog "interface directory can be found under ${EPREFIX}/usr/share/${PN}."
}
60 changes: 0 additions & 60 deletions dev-php/xcache/xcache-3.2.0.ebuild

This file was deleted.

0 comments on commit 90d6b36

Please sign in to comment.