Skip to content

Commit

Permalink
app-shells/fzf: add 0.36.0
Browse files Browse the repository at this point in the history
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Jan 17, 2023
1 parent 4984fd1 commit 90dc450
Show file tree
Hide file tree
Showing 2 changed files with 74 additions and 0 deletions.
2 changes: 2 additions & 0 deletions app-shells/fzf/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -4,3 +4,5 @@ DIST fzf-0.35.0-deps.tar.xz 16796112 BLAKE2B 61c22a914bb1eb8cb6da1daf4b25a19d98e
DIST fzf-0.35.0.tar.gz 218715 BLAKE2B 7eb4a36e481738e56e031ec6e10c69b6499bd6fde204f8bc9474f80b9c6371ca66ebafd5733d4b5de3f2a1fed0c7f2b9b8bbb97681d6194a79f6c82088d6c28e SHA512 8dfdee14b6eced0f2fffc717d6f4e33b93531002754cfcc6b915169feb5f0b62060addf26eb43af028d3d62cdda3c2581a878305ed2fd89f0b27622b6d813cbb
DIST fzf-0.35.1-deps.tar.xz 16796112 BLAKE2B 61c22a914bb1eb8cb6da1daf4b25a19d98e7b0dcd1575b47b6da995ae0fb5e5bc47612b7abafe2917d12b4900a69e604ffff87bf31f811de449522fe800af8f4 SHA512 eed0a0c5a48c5dfee2b6c4d3320280d75f19c16841e3ad731371060da55885c3ddd8d0490dbfc53a68f095dcff02727e8d804494bfa8edf6da041ffcb197dc74
DIST fzf-0.35.1.tar.gz 218773 BLAKE2B 79b95e23a85865ea9218a222eba522a0a9d7f042f9119b308bc711cccc5327098dae271ba10fff9619f3ba7bc88037c70459f1caf511d5069264b931c875c49f SHA512 4e32836aa331835b6a7370ea342d2ddfa47a2059f5f7c5eec0b2c0dc9fdede14940bf64977c91df201775b3f4a06763a92593df7a50693d04d13b1befb194753
DIST fzf-0.36.0-deps.tar.xz 16806808 BLAKE2B f121b3000bc5a0d72ee5cb66f59f4f44c41af30f28ca935a607b424399d12dc762f25811aea999e5de126e2727f8bda614e026da6983ed535d048a7229a07065 SHA512 121c6b1be0cd3af752b11461a72c22e3bc55eec12c12367b354a4ff4d4dc75fb0215cf19cec52008473045c6330a4af71b2e3a14a9a0a124e18aacc1aaad97a9
DIST fzf-0.36.0.tar.gz 229126 BLAKE2B faa04870b7654b1ffb2f1c453636e33eab94e682c7db4702719419a5eca5ea136c657179248dd646573a625f575c823f9dcfd0023a96390bbf689e7455224411 SHA512 8e87dbd3b5ae9e0dc6a76855f7c75c9b4edc8ce797b2cd4eda053c4e1d618bb9afb2b24602e01776a49e47a00f2cd803ed433043f0acec8d385f741b13583e9e
72 changes: 72 additions & 0 deletions app-shells/fzf/fzf-0.36.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,72 @@
# Copyright 2019-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit bash-completion-r1 go-module

DESCRIPTION="General-purpose command-line fuzzy finder, written in Golang"
HOMEPAGE="https://github.com/junegunn/fzf"

# For fancy versioning only. Bump on the next release!
# MY_GIT_REV is the first 7 characters of release commit, we truncate it
# after to make it easier to copy/paste.
MY_GIT_REV=20230117636c9dfa3ed6f6428c5bc4c51b02f60a
MY_GIT_REV=${MY_GIT_REV:0:7}

SRC_URI="https://github.com/junegunn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"

LICENSE="MIT BSD-with-disclosure"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"

src_prepare() {
default
sed -i 's/-s -w //' Makefile || die # bug 795225
}

src_compile() {
emake PREFIX="${EPREFIX}"/usr VERSION=${PV} REVISION=${MY_GIT_REV} bin/${PN}
}

src_install() {
dobin bin/${PN}
doman man/man1/${PN}.1

dobin bin/${PN}-tmux
doman man/man1/${PN}-tmux.1

insinto /usr/share/vim/vimfiles/plugin
doins plugin/${PN}.vim

insinto /usr/share/nvim/runtime/plugin
doins plugin/${PN}.vim

newbashcomp shell/completion.bash ${PN}

insinto /usr/share/zsh/site-functions
newins shell/completion.zsh _${PN}

insinto /usr/share/fzf
doins shell/key-bindings.bash
doins shell/key-bindings.fish
doins shell/key-bindings.zsh
}

pkg_postinst() {
if [[ -z ${REPLACING_VERSIONS} ]]; then
elog "To add fzf support to your shell, make sure to use the right file"
elog "from ${EROOT}/usr/share/fzf."
elog
elog "For bash, add the following line to ~/.bashrc:"
elog
elog " # source ${EROOT}/usr/share/bash-completion/completions/fzf"
elog " # source ${EROOT}/usr/share/fzf/key-bindings.bash"
elog
elog "Plugins for Vim and Neovim are installed to respective directories"
elog "and will work out of the box."
elog
elog "For fzf support in tmux see fzf-tmux(1)."
fi
}

0 comments on commit 90dc450

Please sign in to comment.