Skip to content

Commit

Permalink
app-arch/dpkg: Version bump.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.2
  • Loading branch information
Jeroen Roovers committed Nov 7, 2016
1 parent ac2344f commit 9169cd0
Show file tree
Hide file tree
Showing 2 changed files with 108 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-arch/dpkg/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST dpkg_1.17.26.tar.xz 4410860 SHA256 aa4e758752cdfd7ecb118d7a7d31139a0c090c92
DIST dpkg_1.17.27.tar.xz 4413092 SHA256 90749c31b9f1fceb46dd9fab5b50de34272efef333cc16d9e144f514fd944bb6 SHA512 6f0229bf6c6b76be22d0baf4af21b1175b5397c4a84eb47f0d02bb93173207cc087015a53a2ed9feb7195d313d447d71a0d7361eb1238377c38f8be4465f8bbd WHIRLPOOL cc8525d391bbb42e399e4a1ecb526db1071122272f7eb1b23bdbbad361dfa0f7af8f1fac867f5fb2028d74171ecd3b175b813b2370b2982b17c1d05b39921455
DIST dpkg_1.18.10.tar.xz 4645448 SHA256 025524da41ba18b183ff11e388eb8686f7cc58ee835ed7d48bd159c46a8b6dc5 SHA512 83188277a703b57fa3b5570765db849f9b20f592237fa9a9f3a7e0b24c292c8cfc5528a049f6ecd85f2598c89521727599b406cd3924b2b8c56f9295b560e279 WHIRLPOOL 8bfb17cbc6598482b27502088a6c878b127edeb4dfe54631f776f0db1a6ea32c776929ca15d2251bfb1be1921f775a49f142bcc9c5689c2c374c383df04744d8
DIST dpkg_1.18.12.tar.xz 4486092 SHA256 090be9eb714cb0c942b0e3f2b86763f402d736149521080cc1214c70c9c18c49 SHA512 995d9da0d58c2a8317d1e78cf93dd014e32a4d5dc89d8a0f4a0a8b7e8f116fd108ae7d0bf7ab3526f33a594762e95b937a70f5168479522bc50e7fddd51e1f74 WHIRLPOOL f5f057038c7896d54d4a3a42f5d48fb7130a52591023ce4aae3492ab95ad5374197ed00859b713ca1f0d44cea0e1e24a052b13396b9c7654bb783c2427acb763
DIST dpkg_1.18.13.tar.xz 4489244 SHA256 51f98e37ccf21c8df1ba919d6670286bc48b905ff20d6e4cf9620d9b318a3990 SHA512 56902cac9dbd78a88af83b4bc4f7635a20ab8f784a6f3a73f8ff4d10640d39768b8cdcef845d32c5914769d6820a14297f22188a21c515694c1dd92e49955d7e WHIRLPOOL 5a1acdd26c1cfdf2d8382cb67d8f4ff17b2c294601674ed00db9ca2e5c4738504b1f84b180e7833bf12697d71a15a83c46278482c6cd1c18e7297c5b04752318
107 changes: 107 additions & 0 deletions app-arch/dpkg/dpkg-1.18.13.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,107 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit eutils multilib autotools toolchain-funcs

DESCRIPTION="Package maintenance system for Debian"
HOMEPAGE="http://packages.qa.debian.org/dpkg"
SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
IUSE="+bzip2 +lzma nls selinux test unicode +update-alternatives +zlib"

RDEPEND="
>=dev-lang/perl-5.6.0:=
dev-perl/TimeDate
bzip2? ( app-arch/bzip2 )
lzma? ( app-arch/xz-utils )
selinux? ( sys-libs/libselinux )
zlib? ( >=sys-libs/zlib-1.1.4 )
"
DEPEND="
${RDEPEND}
app-arch/xz-utils
sys-devel/flex
virtual/pkgconfig
nls? (
app-text/po4a
>=sys-devel/gettext-0.18.2
)
test? (
dev-perl/DateTime-Format-DateParse
dev-perl/IO-String
dev-perl/Test-Pod
virtual/perl-Test-Harness
)
"

DOCS=(
ChangeLog
THANKS
TODO
)
PATCHES=(
"${FILESDIR}"/${PN}-1.18.9-strerror.patch
"${FILESDIR}"/${PN}-1.18.12-flags.patch
"${FILESDIR}"/${PN}-1.18.12-rsyncable.patch
"${FILESDIR}"/${PN}-1.18.12-dpkg_buildpackage-test.patch
)

src_prepare() {
# Force the use of the running bash for get-version (this file is never
# installed, so no need to worry about hardcoding a temporary bash)
sed -i -e '1c\#!'"${BASH}" get-version || die

if [[ ${CHOST} == mips64*-linux-gnu ]] ; then
# Debian targets use custom full tuples. Map the default one
# based on the ABI we're using.
local abi
if [[ ${ABI} == "n64" ]] ; then
abi="mips64"
else
abi="mipsn32"
fi
printf "gnu-linux-mips64 ${abi}\ngnu-linux-mips64el ${abi}el\n" >> triplettable
fi

use nls && strip-linguas -i po

default

eautoreconf
}

src_configure() {
tc-export CC
econf \
$(use_enable nls) \
$(use_enable unicode) \
$(use_enable update-alternatives) \
$(use_with bzip2 libbz2) \
$(use_with lzma liblzma) \
$(use_with selinux libselinux) \
$(use_with zlib libz) \
--disable-compiler-warnings \
--disable-dselect \
--disable-silent-rules \
--disable-start-stop-daemon \
--localstatedir="${EPREFIX}"/var \
--without-libmd
}

src_compile() {
emake AR=$(tc-getAR)
}

src_install() {
default

keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}

prune_libtool_files
}

0 comments on commit 9169cd0

Please sign in to comment.