Skip to content

Commit

Permalink
games-emulation/gnuboy: update EAPI 6 -> 7, add libsdl[joystick]
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/743100
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Aug 19, 2021
1 parent cc5711b commit 91aff97
Show file tree
Hide file tree
Showing 2 changed files with 14 additions and 16 deletions.
5 changes: 2 additions & 3 deletions games-emulation/gnuboy/files/gnuboy-1.0.3-include.patch
Original file line number Diff line number Diff line change
@@ -1,6 +1,5 @@
diff -ru gnuboy-1.0.3.orig/defs.h gnuboy-1.0.3/defs.h
--- gnuboy-1.0.3.orig/defs.h 2001-01-23 07:04:22.000000000 -0500
+++ gnuboy-1.0.3/defs.h 2014-07-04 03:56:46.685149736 -0400
--- a/defs.h
+++ b/defs.h
@@ -4,6 +4,10 @@
#ifndef __DEFS_H__
#define __DEFS_H__
Expand Down
25 changes: 12 additions & 13 deletions games-emulation/gnuboy/gnuboy-1.0.3-r2.ebuild
Original file line number Diff line number Diff line change
@@ -1,7 +1,8 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
EAPI=7

inherit autotools

DESCRIPTION="Gameboy emulator with multiple renderers"
Expand All @@ -12,22 +13,24 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="X sdl"
REQUIRED_USE="!X? ( sdl )"

RDEPEND="
sdl? ( media-libs/libsdl )
!X? ( media-libs/libsdl )
X? ( x11-libs/libXext )
"
DEPEND="${RDEPEND}
X? ( x11-base/xorg-proto )
"

PATCHES=(
"${FILESDIR}"/${P}-exec-stack.patch
"${FILESDIR}"/${P}-linux-headers.patch
"${FILESDIR}"/${P}-include.patch
)

src_prepare() {
default
eapply \
"${FILESDIR}"/${P}-exec-stack.patch \
"${FILESDIR}"/${P}-linux-headers.patch \
"${FILESDIR}"/${P}-include.patch

mv configure.in configure.ac || die
eautoreconf
Expand All @@ -36,10 +39,6 @@ src_prepare() {
src_configure() {
local myconf

if ! use X ; then
myconf="--with-sdl"
fi

econf \
$(use_with X x) \
$(use_with sdl) \
Expand All @@ -50,11 +49,11 @@ src_configure() {
}

src_install() {
for f in sdlgnuboy xgnuboy
do
for f in sdlgnuboy xgnuboy; do
if [[ -f ${f} ]] ; then
dobin ${f}
fi
done

dodoc README docs/{CHANGES,CONFIG,CREDITS,FAQ,HACKING,WHATSNEW}
}

0 comments on commit 91aff97

Please sign in to comment.