Skip to content

Commit

Permalink
kde-apps/kate: Fix major bug with kde-frameworks 5.17
Browse files Browse the repository at this point in the history
Caused by a change in kxmlgui. Lingering kate processes in the background,
inability to open new files in kate, countless empty kate windows at login

Package-Manager: portage-2.2.24
  • Loading branch information
a17r authored and kensington committed Dec 13, 2015
1 parent d411755 commit 91bff47
Show file tree
Hide file tree
Showing 2 changed files with 98 additions and 0 deletions.
26 changes: 26 additions & 0 deletions kde-apps/kate/files/kate-15.08.3-fix-lingering-processes.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,26 @@
From: Andreas Hartmetz <[email protected]>
Date: Sat, 05 Dec 2015 15:31:24 +0000
Subject: setQuitOnLastWindowClosed(false) causes lingering processes. Remove.
X-Git-Url: http://quickgit.kde.org/?p=kate.git&a=commitdiff&h=cd0163d7b956ace0e786a76d8211d06790a2c174
---
setQuitOnLastWindowClosed(false) causes lingering processes. Remove.

Previously, it was set to true again later from
KMainWindowPrivate::init(). I have changed that in KMainWindowPrivate
so that applications have a better chance to set the property as they
like - commit 155f524dd79add7d in kxmlgui.
For Kate, true seems to be the correct setting.
---


--- a/kate/src/main.cpp
+++ b/kate/src/main.cpp
@@ -133,7 +133,6 @@
app.setApplicationDisplayName(aboutData.displayName());
app.setOrganizationDomain(aboutData.organizationDomain());
app.setApplicationVersion(aboutData.version());
- app.setQuitOnLastWindowClosed(false);

/**
* set the program icon

72 changes: 72 additions & 0 deletions kde-apps/kate/kate-15.08.3-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,72 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

KDE_HANDBOOK="true"
KDE_TEST="true"
inherit kde5

DESCRIPTION="Kate is an advanced text editor"
HOMEPAGE="https://www.kde.org/applications/utilities/kate http://kate-editor.org"
KEYWORDS=" ~amd64 ~x86"
IUSE="+addons"

DEPEND="
$(add_frameworks_dep kactivities)
$(add_frameworks_dep kcodecs)
$(add_frameworks_dep kcompletion)
$(add_frameworks_dep kconfig)
$(add_frameworks_dep kconfigwidgets)
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kcrash)
$(add_frameworks_dep kdbusaddons)
$(add_frameworks_dep kguiaddons)
$(add_frameworks_dep ki18n)
$(add_frameworks_dep kiconthemes)
$(add_frameworks_dep kio)
$(add_frameworks_dep kitemmodels)
$(add_frameworks_dep kitemviews)
$(add_frameworks_dep kjobwidgets)
$(add_frameworks_dep kparts)
$(add_frameworks_dep kservice)
$(add_frameworks_dep ktexteditor)
$(add_frameworks_dep ktextwidgets)
$(add_frameworks_dep kwidgetsaddons)
$(add_frameworks_dep kwindowsystem)
$(add_frameworks_dep kxmlgui)
dev-qt/qtdbus:5
dev-qt/qtgui:5
dev-qt/qtscript:5
dev-qt/qtwidgets:5
dev-qt/qtxml:5
addons? (
$(add_frameworks_dep kbookmarks)
$(add_frameworks_dep knewstuff)
$(add_frameworks_dep knotifications)
$(add_frameworks_dep kwallet)
$(add_frameworks_dep plasma)
$(add_frameworks_dep threadweaver)
dev-qt/qtsql:5
>=dev-libs/libgit2-0.22.0:=
)
"
RDEPEND="${DEPEND}"

PATCHES=( "${FILESDIR}/${PN}-15.08.3-fix-lingering-processes.patch" )

src_prepare() {
kde5_src_prepare

sed -i -e "/add_subdirectory( kwrite )/d" doc/CMakeLists.txt || die
}

src_configure() {
local mycmakeargs=(
-DBUILD_ADDONS=$(usex addons)
-DBUILD_kwrite=FALSE
)

kde5_src_configure
}

0 comments on commit 91bff47

Please sign in to comment.