Skip to content

Commit

Permalink
app-arch/dpkg: Version bump (bug #567258).
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
Jeroen Roovers committed Dec 2, 2015
1 parent 8ef2e12 commit 91ce1ab
Show file tree
Hide file tree
Showing 2 changed files with 99 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-arch/dpkg/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST dpkg_1.17.25.tar.xz 4407792 SHA256 07019d38ae98fb107c79dbb3690cfadff877f153b8c4970e3a30d2e59aa66baa SHA512 6a4b45c0f59cd11fc104d954ab790dd7e11e650cd6dde303a664023a04bf6fbc49c878eaf00e27dd7f9bf5e79a92b3a5f5923d003942436758a3027364a0b7c7 WHIRLPOOL 6ed2d8a645787a83f431803214cce9b1c7516c4083ffe651deb7c2f8b641b85d3a17271030286155a985dfd0046fbd584d2d750ab8954e8e5af74085d7651bd2
DIST dpkg_1.17.26.tar.xz 4410860 SHA256 aa4e758752cdfd7ecb118d7a7d31139a0c090c92aa494aa2e46603006deb1ec8 SHA512 4d2f2a7691dd34d47b62ec1f602d9bab612b151f05362607ec8e31037c4ba0baf5d609c46352240e9806e5781db8df9781e8a0ee9fd24faf54f8b43244a7e538 WHIRLPOOL 56decf0774f2d4405fb0934415c50749230c06fe9112e0ebb4458a8917538c83644eadb885d24350bbf713a6250dd5687956b70d47e22c06cf39ff87cb2d5a23
DIST dpkg_1.18.2.tar.xz 4345224 SHA256 11484f2a73d027d696e720a60380db71978bb5c06cd88fe30c291e069ac457a4 SHA512 cd84ba53a0a8d6f8c9a79d1b3e4c7716249e6dbf8b92635f4691cc31c9896bc156f6ea5a42de419210133497d05c41eb00208b3ec02d44a177015d23873003af WHIRLPOOL 2f4a60e8127c3514ba9ee51723e4057724b8b8a99caea6812d80bca5617cd6f3971a80c219162fd16059e08bd0914d15a39e618fd115bb6dcb8a6b402c64be42
DIST dpkg_1.18.3.tar.xz 4359884 SHA256 a40ffe38d7f36d858a752189a306433cfc52c7d15d7b98f61d9f9dd49e0e4807 SHA512 f9f06b7b629b88504a219d48f3d041e72fb41468bc9d7bba59a255660bf0d169b050ce816d4ddbee8da85ac3901e55cfc4301eadf94d42ab6038dcacde89f8fc WHIRLPOOL a4e372c162df514beb102fcae1ff0ab7788eaa09e07542e8a66ad0242942a0689a22f761d9932935db5c189d439b5ac7f65c1db8d0dd609442be3fe475ef30f3
98 changes: 98 additions & 0 deletions app-arch/dpkg/dpkg-1.17.26.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,98 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit eutils multilib autotools toolchain-funcs

DESCRIPTION="Package maintenance system for Debian"
HOMEPAGE="http://packages.qa.debian.org/dpkg"
SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
IUSE="+bzip2 +lzma nls selinux test unicode +update-alternatives +zlib"

RDEPEND="
>=dev-lang/perl-5.6.0:=
dev-perl/TimeDate
>=sys-libs/ncurses-5.2-r7
bzip2? ( app-arch/bzip2 )
lzma? ( app-arch/xz-utils )
selinux? ( sys-libs/libselinux )
zlib? ( >=sys-libs/zlib-1.1.4 )
"
DEPEND="
${RDEPEND}
app-arch/xz-utils
sys-devel/flex
virtual/pkgconfig
nls? (
app-text/po4a
>=sys-devel/gettext-0.18.2
)
test? (
dev-perl/DateTime-Format-DateParse
dev-perl/IO-String
dev-perl/Test-Pod
virtual/perl-Test-Harness
)
"

DOCS=( ChangeLog THANKS TODO )

src_prepare() {
# do not expect Debian's gzip --rsyncable extension
epatch "${FILESDIR}"/${PN}-1.17.0-gzip-rsyncable.patch

epatch "${FILESDIR}"/${PN}-1.17.1-flags.patch

# Force the use of the running bash for get-version (this file is never
# installed, so no need to worry about hardcoding a temporary bash)
sed -i -e '1c\#!'"${BASH}" get-version || die

if [[ ${CHOST} == mips64*-linux-gnu ]] ; then
# Debian targets use custom full tuples. Map the default one
# based on the ABI we're using.
local abi
if [[ ${ABI} == "n64" ]] ; then
abi="mips64"
else
abi="mipsn32"
fi
printf "gnu-linux-mips64 ${abi}\ngnu-linux-mips64el ${abi}el\n" >> triplettable
fi

use nls && strip-linguas -i po

eautoreconf
}

src_configure() {
tc-export CC
econf \
$(use_enable nls) \
$(use_enable unicode) \
$(use_enable update-alternatives) \
$(use_with bzip2 bz2) \
$(use_with lzma liblzma) \
$(use_with selinux) \
$(use_with zlib) \
--disable-compiler-warnings \
--disable-dselect \
--disable-silent-rules \
--disable-start-stop-daemon \
--localstatedir="${EPREFIX}"/var
}

src_compile() {
emake AR=$(tc-getAR)
}

src_install() {
default

keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
}

0 comments on commit 91ce1ab

Please sign in to comment.