Skip to content

Commit

Permalink
dev-lua/lua-openssl: bump to version 0.8.0-6
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.18, Repoman-3.0.3
Signed-off-by: Conrad Kostecki <[email protected]>
  • Loading branch information
ConiKost committed Apr 14, 2021
1 parent 1a4a214 commit 91d0ebf
Show file tree
Hide file tree
Showing 2 changed files with 127 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lua/lua-openssl/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST lua-auxiliar-8d09895473b73e4fb72b7573615f69c36e1860a2.tar.gz 3690 BLAKE2B 8e31e8ad75bcc5840223068fdc9b634c2cbc42d713bba0792a0b04f8e018e36e3bab16a07aaa725d8b2bbd55c3a74271a21366c2cde1b4c6bd735c9438efedec SHA512 c461c23cd50ef43aa37ce2c819a9a485ead1011ecb5ff083a092e49ac79d5398aff1631f441cb8e59acd820024ed51e74420b74da751c0fccd2cfce94f039952
DIST lua-compat-5.3-0.10.tar.gz 53695 BLAKE2B e570aedb23b8ed7ca38c4316ffab25b93a0f9f6f0fae79af563ca8a81dd6453ac273e1f9e70674c484a2dec68749e7d53a1c1736a72616c210b8e38a31b3f191 SHA512 f7f39085f4f6b16095f41e635b4c5477b3dab5e42b5b65a9d522941a3807ea521d4a27a77293a3c9d0ecea78a1f6c2a2497394b2d220f4d7d65e23510563d46d
DIST lua-openssl-0.7.8_p0.tar.gz 397072 BLAKE2B 048ae34c195f6f0ff252f33d14a7151b629d5b9ba828c331459e58f23f0ee62e66f00b8fdbe5665eb7f247d4bb97986e158ea89107189aba4199fcb878f2d724 SHA512 a23b5010633aec70639903fe4d0473101e42c2690456ff2d730c45ef4710134058bc6b3e364c79d3cf3dd4c323a89bd98f07a17d23f226b0bb7e0bb1f2be32c5
DIST lua-openssl-0.8.0_p6.tar.gz 418000 BLAKE2B 34474c607f6e39985c17f142b1067f2438b51c7e6f62861f65fa8c471722b56dee05a7a45eae277b368ee643a1820334de03c08f09c88a17e851925d575df6d4 SHA512 56125b8a88783b48bbeabd56be4732afe22ef54224b3f03f16e3cbc1ce94f554d6d8dea8236bff34786aad2720b53cbd05dcba85ca41497db61f339014fa3b95
126 changes: 126 additions & 0 deletions dev-lua/lua-openssl/lua-openssl-0.8.0_p6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,126 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

EGIT_COMMIT_AUX="8d09895473b73e4fb72b7573615f69c36e1860a2"
LUA_COMPAT=( lua5-{1..4} luajit )
MY_PN_AUX="lua-auxiliar"
MY_PN_COMPAT="lua-compat-5.3"
MY_PV="${PV//_p/-}"
MY_PV_COMPAT="0.10"

inherit lua toolchain-funcs

DESCRIPTION="OpenSSL binding for Lua"
HOMEPAGE="https://github.com/zhaozg/lua-openssl"
SRC_URI="
https://github.com/zhaozg/${PN}/archive/refs/tags/${MY_PV}.tar.gz -> ${P}.tar.gz
https://github.com/zhaozg/${MY_PN_AUX}/archive/${EGIT_COMMIT_AUX}.tar.gz -> ${MY_PN_AUX}-${EGIT_COMMIT_AUX}.tar.gz
https://github.com/keplerproject/${MY_PN_COMPAT}/archive/v${MY_PV_COMPAT}.tar.gz -> ${MY_PN_COMPAT}-${MY_PV_COMPAT}.tar.gz
"
S="${WORKDIR}/${PN}-${MY_PV}"

LICENSE="MIT openssl PHP-3"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="libressl test"
REQUIRED_USE="${LUA_REQUIRED_USE}"
RESTRICT="!test? ( test )"

RDEPEND="
!dev-lua/luaossl
!dev-lua/luasec
libressl? ( dev-libs/libressl:0= )
!libressl? ( dev-libs/openssl:0=[-bindist] )
${LUA_DEPS}
"
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
test? ( ${RDEPEND} )
"

DOCS=( "README.md" "samples/." )

src_prepare() {
default

# Allow override of LUA* variables
sed -e '/LUA /s/:=/?=/g' -e '/LUA_VERSION/s/:=/?=/g' -i Makefile || die

# Prepare needed dependencies (source code files only)
rm -r deps/{auxiliar,lua-compat} || die
mv "${WORKDIR}/${MY_PN_AUX}-${EGIT_COMMIT_AUX}" deps/auxiliar || die
mv "${WORKDIR}/${MY_PN_COMPAT}-${MY_PV_COMPAT}" deps/lua-compat || die

lua_copy_sources
}

lua_src_compile() {
pushd "${BUILD_DIR}" || die

local myemakeargs=(
"AR=$(tc-getAR)"
"CC=$(tc-getCC)"
"LUA="
"LUA_CFLAGS=${CFLAGS} $(lua_get_CFLAGS)"
"LUA_LIBS=${LDFLAGS}"
"LUA_VERSION=$(ver_cut 1-2 $(lua_get_version))"
"TARGET_SYS=${CTARGET:-${CHOST}}"
)

emake "${myemakeargs[@]}"

popd
}

src_compile() {
lua_foreach_impl lua_src_compile
}

lua_src_test() {
pushd "${BUILD_DIR}" || die

local myemakeargs=(
"LUA=${ELUA}"
"LUA_CFLAGS="
"LUA_LIBS="
"LUA_VERSION=$(ver_cut 1-2 $(lua_get_version))"
"TARGET_SYS=${CTARGET:-${CHOST}}"
)

emake "${myemakeargs[@]}" test

popd
}

src_test() {
lua_foreach_impl lua_src_test
}

lua_src_install() {
pushd "${BUILD_DIR}" || die

local myemakeargs=(
"LUA="
"LUA_CFLAGS="
"LUA_LIBDIR=${ED}/$(lua_get_cmod_dir)"
"LUA_LIBS="
"LUA_VERSION=$(ver_cut 1-2 $(lua_get_version))"
"TARGET_SYS=${CTARGET:-${CHOST}}"
)

emake "${myemakeargs[@]}" install

insinto "$(lua_get_lmod_dir)"
doins -r "lib/."

popd
}

src_install() {
lua_foreach_impl lua_src_install

einstalldocs
}

0 comments on commit 91d0ebf

Please sign in to comment.