Skip to content

Commit

Permalink
dev-lang/php: Backport patch from upstream for ICU 70 changes
Browse files Browse the repository at this point in the history
Already fixed in 7.4.26, 8.0.13 and 8.1.0_rc6

Signed-off-by: Brian Evans <[email protected]>
  • Loading branch information
Brian Evans committed Nov 24, 2021
1 parent e77e29e commit 91dcbea
Show file tree
Hide file tree
Showing 6 changed files with 50 additions and 0 deletions.
45 changes: 45 additions & 0 deletions dev-lang/php/files/php-icu-70.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
diff --git a/ext/intl/locale/locale_methods.c b/ext/intl/locale/locale_methods.c
index 1c4ba327bd83..1bdfb27b7e2e 100644
--- a/ext/intl/locale/locale_methods.c
+++ b/ext/intl/locale/locale_methods.c
@@ -1326,7 +1326,7 @@ PHP_FUNCTION(locale_filter_matches)
if( token && (token==cur_lang_tag) ){
/* check if the char. after match is SEPARATOR */
chrcheck = token + (strlen(cur_loc_range));
- if( isIDSeparator(*chrcheck) || isEndOfTag(*chrcheck) ){
+ if( isIDSeparator(*chrcheck) || isKeywordSeparator(*chrcheck) || isEndOfTag(*chrcheck) ){
efree( cur_lang_tag );
efree( cur_loc_range );
if( can_lang_tag){
diff --git a/ext/intl/breakiterator/codepointiterator_internal.cpp b/ext/intl/breakiterator/codepointiterator_internal.cpp
index bf44678efc06..143c181590e9 100644
--- a/ext/intl/breakiterator/codepointiterator_internal.cpp
+++ b/ext/intl/breakiterator/codepointiterator_internal.cpp
@@ -75,7 +75,11 @@ CodePointBreakIterator::~CodePointBreakIterator()
clearCurrentCharIter();
}

+#if U_ICU_VERSION_MAJOR_NUM >= 70
+bool CodePointBreakIterator::operator==(const BreakIterator& that) const
+#else
UBool CodePointBreakIterator::operator==(const BreakIterator& that) const
+#endif
{
if (typeid(*this) != typeid(that)) {
return FALSE;
diff --git a/ext/intl/breakiterator/codepointiterator_internal.h b/ext/intl/breakiterator/codepointiterator_internal.h
index 7ecf12deb5ae..0baf607782d0 100644
--- a/ext/intl/breakiterator/codepointiterator_internal.h
+++ b/ext/intl/breakiterator/codepointiterator_internal.h
@@ -39,7 +39,11 @@ namespace PHP {

virtual ~CodePointBreakIterator();

+#if U_ICU_VERSION_MAJOR_NUM >= 70
+ virtual bool operator==(const BreakIterator& that) const;
+#else
virtual UBool operator==(const BreakIterator& that) const;
+#endif

virtual CodePointBreakIterator* clone(void) const;

1 change: 1 addition & 0 deletions dev-lang/php/php-7.3.32.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -152,6 +152,7 @@ RESTRICT="!test? ( test )"

PATCHES=(
"${FILESDIR}/php-freetype-2.9.1.patch"
"${FILESDIR}/php-icu-70.patch"
)

PHP_MV="$(ver_cut 1)"
Expand Down
1 change: 1 addition & 0 deletions dev-lang/php/php-7.3.33.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -152,6 +152,7 @@ RESTRICT="!test? ( test )"

PATCHES=(
"${FILESDIR}/php-freetype-2.9.1.patch"
"${FILESDIR}/php-icu-70.patch"
)

PHP_MV="$(ver_cut 1)"
Expand Down
1 change: 1 addition & 0 deletions dev-lang/php/php-7.4.25.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -146,6 +146,7 @@ PHP_MV="$(ver_cut 1)"

PATCHES=(
"${FILESDIR}"/php-iodbc-header-location.patch
"${FILESDIR}/php-icu-70.patch"
)

php_install_ini() {
Expand Down
1 change: 1 addition & 0 deletions dev-lang/php/php-8.0.12.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -146,6 +146,7 @@ PHP_MV="$(ver_cut 1)"
PATCHES=(
"${FILESDIR}/php-iodbc-header-location.patch"
"${FILESDIR}/php80-firebird-warnings.patch"
"${FILESDIR}/php-icu-70.patch"
)

php_install_ini() {
Expand Down
1 change: 1 addition & 0 deletions dev-lang/php/php-8.1.0_rc5.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -146,6 +146,7 @@ PHP_MV="$(ver_cut 1)"

PATCHES=(
"${FILESDIR}/php-iodbc-header-location.patch"
"${FILESDIR}/php-icu-70.patch"
)

php_install_ini() {
Expand Down

0 comments on commit 91dcbea

Please sign in to comment.