Skip to content

Commit

Permalink
app-admin/clsync: version bump
Browse files Browse the repository at this point in the history
Bump to 0.4.2, update ebuild to EAPI 6.

Package-Manager: portage-2.3.1
Signed-off-by: Andrew Savchenko <[email protected]>
  • Loading branch information
bircoph committed Sep 30, 2016
1 parent 0b015be commit 91f8e6c
Show file tree
Hide file tree
Showing 2 changed files with 105 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/clsync/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST clsync-0.4.1-20150524-v2.patch.xz 13632 SHA256 90a1ef820c83629c528e8c6fe4da5183caf60f8079c4de01a6d26945734c92f7 SHA512 d39c3c4f116eff2365668374ef62f4dfd8e5926267cbbf36b430f97ad5306f92cf6be3164c0e1c3d959db55453f5ded00d98d48af62f9eacde39a9f9667cfbf9 WHIRLPOOL d22fc6a1f0a59514506377f26ab7d9c0f4faca0abab044f2ce2e61ffa973ff04b43da561a4dd5c69d99e21108baa71d77bb2ea524313661b3b2440ceddca56aa
DIST clsync-0.4.1.tar.gz 253890 SHA256 3f14a72d7c3c1747ea908e373f25bd1918ce00450492fbb7094549db6bf21e27 SHA512 875280f706026d44806b92c22fa58d016136b2792f67a6b7e77f932465081da7a1ebaf22c25e538e4b58bfe04cd1cd5450ecab99c3df53ddd2a0fa966442d444 WHIRLPOOL 10ab11821766f7d16d03993069ac4da5fe362a1e5977ea6721e49ada7044d3659e59b507b03be4de09609b0a0ca9d7878407d7b6e1f40df5dbe1d041dac373cb
DIST clsync-0.4.2.tar.gz 256042 SHA256 1af63b86c1d0bd663311f2129792446dc8fc4def5559f76658b51b69a8d0c3bd SHA512 d14a2efc4bf58d9d5c7a3fe5634cacdd182cd7cd814b0e9ebd99024a7282b056d1f7ceeec6903666391c3572d599a18e205af818b098ed7768d5c0e0f4cd1200 WHIRLPOOL a59446337282cb63455b43bbbf17ad1213e39713d9c267ca5ee8785d863bc90e7b99e5938e4d5be02f3103a98b1bb5d5a628580160952d821e6caaad72fa2679
104 changes: 104 additions & 0 deletions app-admin/clsync/clsync-0.4.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,104 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit autotools eutils linux-info

DESCRIPTION="Live sync tool based on inotify, written in GNU C"
HOMEPAGE="https://github.com/xaionaro/clsync http://ut.mephi.ru/oss/clsync"
SRC_URI="https://github.com/xaionaro/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+caps cluster control-socket cgroups debug extra-debug
extra-hardened gio hardened +highload-locks +inotify mhash
namespaces seccomp"

REQUIRED_USE="
|| ( gio inotify )
extra-debug? ( debug )
extra-hardened? ( hardened )
mhash? ( cluster )
seccomp? ( caps )
"
CDEPEND="
dev-libs/glib:2
cgroups? ( dev-libs/libcgroup )
mhash? ( app-crypt/mhash )
"
DEPEND="${CDEPEND}
virtual/pkgconfig
"
RDEPEND="${CDEPEND}
~app-doc/clsync-docs-${PV}
"

pkg_pretend() {
use namespaces && CONFIG_CHECK="~NAMESPACES ~UTS_NS ~IPC_NS ~USER_NS ~PID_NS ~NET_NS"
use seccomp && CONFIG_CHECK+=" ~SECCOMP"
check_extra_config
}

src_prepare() {
eapply_user
eautoreconf
}

src_configure() {
local harden_level=0
use hardened && harden_level=1
use extra-hardened && harden_level=2

local debug_level=0
use debug && debug_level=1
use extra-debug && debug_level=2

econf \
--docdir="${EPREFIX}/usr/share/doc/${PF}" \
--disable-socket-library \
--enable-clsync \
--enable-debug=${debug_level} \
--enable-paranoid=${harden_level} \
--without-bsm \
--without-kqueue \
$(use_enable caps capabilities) \
$(use_enable cluster) \
$(use_enable control-socket socket) \
$(use_enable highload-locks) \
$(use_enable namespaces unshare) \
$(use_enable seccomp) \
$(use_with cgroups libcgroup) \
$(use_with gio gio lib) \
$(use_with inotify inotify native) \
$(use_with mhash)
}

src_install() {
emake DESTDIR="${D}" install

# docs go into clsync-docs
rm -rf "${ED}/usr/share/doc" || die

newinitd "${FILESDIR}/${PN}.initd" "${PN}"
newconfd "${FILESDIR}/${PN}.confd" "${PN}"

# filter rules and sync scripts are supposed to be here
keepdir "${EPREFIX}/etc/${PN}"
insinto "/etc/${PN}"
newins "${FILESDIR}/${PN}.conf" "${PN}.conf"
}

pkg_postinst() {
einfo "${PN} is just a convenient way to run synchronization tools on live data,"
einfo "it doesn't copy data itself, so you need to install software to do actual"
einfo "data transfer. Usually net-misc/rsync is a good choise, but ${PN} is"
einfo "is flexible enough to use any user tool, see manual page for details."
einfo
einfo "${PN} init script can be multiplexed, to use symlink init script to"
einfo "othername and use conf.d/othername to configure it."
einfo
einfo "If you're interested in improved security, enable"
einfo "USE=\"caps cgroups hardened namespaces seccomp\""
}

0 comments on commit 91f8e6c

Please sign in to comment.