Skip to content

Commit

Permalink
app-misc/ddctool: version bump to 0.5.3
Browse files Browse the repository at this point in the history
Signed off by Jonathan Scruggs ([email protected], irc Dracwyrm
  • Loading branch information
dracwyrm authored and Michael Palimaka committed Sep 29, 2016
1 parent 2d876d8 commit 922ae20
Show file tree
Hide file tree
Showing 2 changed files with 101 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-misc/ddctool/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST ddctool-0.5.0.tar.gz 322864 SHA256 8773b98f7ca226f8b9cdca3c681ddf0f8aacb5d2c1591764e2a9080a14fe518d SHA512 5fc55a4363335eb8468a73f6e617cba7efcb454f8cefa081c6d13d9c2ac35cc191001a466c61ecfc9c944aea5b837b993646b4b2c78dfb63057ef01c3c05fed5 WHIRLPOOL 66679e7f2a81dab012e38aad24961b5aa3f3860f64b49e0818362c3ac5f5bab2a1a4e0528cf27540041e4f8a548342a1d7f4bd1b422c4185a83721dc6720b218
DIST ddctool-0.5.3.tar.gz 323620 SHA256 8ad0d4d2ff2a8206ee42eec691f20a97492cf58e56b8b1282a90db0890bf3c27 SHA512 f96609083d2afb1e2792ff0977128b39b7fb7f9f88d63db2ed38f5d764a14930a7ae363e0d01a3b1fe336c234a2b9174ba14326460166d7047c16b1fa2c663a8 WHIRLPOOL 1499ed473f68a7b22d8438b61caf8ce8a70266c495ef52260283bb0347d057597b3ccfcf49fe03dce398a98d56399c9131032502f5b9243b974e1f7704c82a1b
100 changes: 100 additions & 0 deletions app-misc/ddctool/ddctool-0.5.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,100 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit autotools linux-info udev user

DESCRIPTION="Program for querying and changing monitor settings"
HOMEPAGE="http://www.ddctool.com/"

SRC_URI="https://github.com/rockowitz/ddctool/archive/v${PV}.tar.gz -> ${P}.tar.gz"

# Binary drivers need special instructions compared to the open source counterparts.
# If a user switches drivers, they will need to set different use flags for
# Xorg or Wayland or Mesa, so this will trigger the rebuild against
# the different drivers.
IUSE="usb-monitor user-permissions video_cards_fglrx video_cards_nvidia"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"

RDEPEND="x11-libs/libXrandr
sys-apps/i2c-tools
virtual/udev
usb-monitor? (
dev-libs/hidapi
virtual/libusb:1
sys-apps/usbutils )"
DEPEND="video_cards_fglrx? ( x11-libs/amd-adl-sdk )
virtual/pkgconfig
${RDEPEND}"

pkg_pretend() {
# This program needs /dev/ic2-* devices to communicate with the monitor.
CONFIG_CHECK="~I2C_CHARDEV"
ERROR_I2C_CHARDEV="You must enable I2C_CHARDEV in your kernel to continue"
if use usb-monitor; then
CONFIG_CHECK+="~HIDRAW ~USB_HIDDEV"
ERROR_HIDRAW="HIDRAW is needed to support USB monitors"
ERROR_I2C_CHARDEV="USB_HIDDEV is needed to support USB monitors"
fi

# Now do the actual checks setup above
check_extra_config
}

src_prepare() {
default
eautoreconf
}

src_configure() {
local myeconfargs=(
$(usex video_cards_fglrx "--with-adl-headers=/usr/include/ADL" "")
$(use_enable usb-monitor usb)
)

econf "${myeconfargs[@]}"
}

src_install() {
default
if use user-permissions; then
udev_dorules data/etc/udev/rules.d/45-ddctool-i2c.rules
if use usb-monitor; then
udev_dorules data/etc/udev/rules.d/45-ddctool-usb.rules
fi
fi
}

pkg_postinst() {
if use user-permissions; then
enewgroup i2c
einfo "To allow non-root users access to the /dev/i2c-* devices, add those"
einfo "users to the i2c group: usermod -aG i2c user"
einfo "Restart the computer or reload the i2c-dev module to activate"
einfo "the new udev rule."
einfo "For more information read: http://www.ddctool.com/i2c_permissions/"

if use usb-monitor; then
enewgroup video
einfo "To allow non-root users access to USB monitors, add those users"
einfo "to the video group: usermod -aG video user"
einfo "Restart the computer, reload the hiddev and hidraw modules, or replug"
einfo "the monitor to activate the new udev rule."
einfo "For more information read: http://www.ddctool.com/usb/"
fi

udev_reload
fi

if use video_cards_nvidia; then
einfo "=================================================================="
einfo "Please read the following webpage on proper usage with the nVidia "
einfo "binary drivers, or it may not work: http://www.ddctool.com/nvidia/"
einfo "=================================================================="
fi
}

0 comments on commit 922ae20

Please sign in to comment.