forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Add in eclass as bash filetype (as previously done in nvimrc). Package-Manager: portage-2.2.20.1
- Loading branch information
Showing
2 changed files
with
67 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST neovim-0.0.0_pre20150627.tar.xz 4715400 SHA256 5e5769c81a60637b731dc13e7584b6f91c7a4f2fa9116c7d688b938aa000ab69 SHA512 44f527e82dc8d70735110b7da687b87fb622127078dd32b9d8b284d8f3c3bce2c9978640234583f130e71378190c29e9c37cc19be8fd994eb338d1d9a5a98701 WHIRLPOOL 08125b0a0d96d2f5202b314e85b26e32e7aaf2170dfa69df660b2d36ad3218b24a9313c6f7a7c0e0ed8677a717e5d478851d1dc6bc8c020dc6798e3dd4462a2d | ||
DIST neovim-0.0.0_pre20150727.tar.xz 4703336 SHA256 da9bd3070ac60691be4e033947548c13b0ede86b2422d66bd207ac2310b735c1 SHA512 db225fff860d730d4514a33c363ed7748949aaeb3a5fb31c0775120d31219a9fad154ff6f457c4ea25aff666e34dc0e7c8ab1acbc3bbe73bed17d01c67d13627 WHIRLPOOL 23b553f6be136f42c7279d332e1c917083d48aa0ae27df949972ce4eae93d07ea301f9b5853d3d320cc4a6366a483f3f9d43e016607d500646c71ea33e5ffdb8 | ||
DIST neovim-0.0.0_pre20150814.tar.xz 4718836 SHA256 e7abdb0b3a44ec3c312b06aa825caca4520f1b857045c45c925e8005e2bf3ada SHA512 638e6807929880c2648bd2d0efde509842423488272926bb3ae89a6681144b86fe5137ef313ae102fe8c2fa82819fe96e0dcc0a8d45e3ccaf18b207cf9c1aad1 WHIRLPOOL f1ca40e0bef46da63c466e0fcc51bcf37c57f64009a680f6e51cb1cf3b0d481011dff33957b5da38dfe8d55978c368efe9d905d4f26a272e915470fab239dcff |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,66 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
inherit cmake-utils flag-o-matic | ||
|
||
DESCRIPTION="Ambitious vim fork focused on extensibility and agility" | ||
HOMEPAGE="https://github.com/neovim/neovim" | ||
if [[ ${PV} == 9999 ]]; then | ||
inherit git-r3 | ||
EGIT_REPO_URI="git://github.com/neovim/neovim.git" | ||
else | ||
SRC_URI="http://dev.gentoo.org/~yngwin/distfiles/${P}.tar.xz" | ||
KEYWORDS="~amd64 ~x86" | ||
fi | ||
|
||
LICENSE="Apache-2.0 vim" | ||
SLOT="0" | ||
IUSE="perl python" | ||
|
||
CDEPEND="dev-lang/luajit:2 | ||
>=dev-libs/libtermkey-0.17 | ||
dev-libs/libvterm-neovim | ||
>=dev-libs/unibilium-1.1.1 | ||
>=dev-libs/libuv-1.2.0 | ||
>=dev-libs/msgpack-0.6.0_pre20150220 | ||
dev-lua/lpeg | ||
dev-lua/messagepack" | ||
DEPEND="${CDEPEND} | ||
virtual/libiconv | ||
virtual/libintl" | ||
RDEPEND="${CDEPEND} | ||
perl? ( dev-lang/perl ) | ||
python? ( dev-python/neovim-python-client )" | ||
|
||
src_prepare() { | ||
# use our system vim dir | ||
sed -e '/^# define SYS_VIMRC_FILE/s|$VIM|'"${EPREFIX}"'/etc/vim|' \ | ||
-i src/nvim/os/unix_defs.h || die | ||
|
||
# add eclass to bash filetypes | ||
sed -e 's|*.ebuild|*.ebuild,*.eclass|' -i runtime/filetype.vim || die | ||
|
||
cmake-utils_src_prepare | ||
} | ||
|
||
src_configure() { | ||
export USE_BUNDLED_DEPS=OFF | ||
append-cflags "-Wno-error" | ||
append-cppflags "-DNDEBUG -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1" | ||
local mycmakeargs=( | ||
-DCMAKE_BUILD_TYPE=Release | ||
-DLIBUNIBILIUM_USE_STATIC=OFF | ||
-DLIBTERMKEY_USE_STATIC=OFF | ||
-DLIBVTERM_USE_STATIC=OFF | ||
) | ||
cmake-utils_src_configure | ||
} | ||
|
||
src_install() { | ||
cmake-utils_src_install | ||
# install a default configuration file | ||
insinto /etc/vim | ||
doins "${FILESDIR}"/nvimrc | ||
} |