forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Patrick Lauer <[email protected]>
- Loading branch information
1 parent
6cae10d
commit 9255e2b
Showing
3 changed files
with
89 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,28 @@ | ||
From f1b26bb0e8f4e0a00ac31f9defb1ed74b820eb39 Mon Sep 17 00:00:00 2001 | ||
From: Stefan Seifert <[email protected]> | ||
Date: Mon, 15 Jul 2019 12:04:45 +0200 | ||
Subject: [PATCH] Fix Configure.pl failing when --prefix /usr is passed | ||
|
||
gerd++ reported this on Github 1143 and supplied the diagnostics and | ||
fix: | ||
If the prefix is exact /usr, then it seems that in build/Makefile.in | ||
@moardll@: $(OBJECTS) $(THIRDPARTY) | ||
$(MSG) linking $@ | ||
$(CMD)$(LD) @ldout@$@ $(LDFLAGS) @ldshared@ @moarshared@ $(OBJECTS) $(DLL_LIBS) | ||
moarshared will not be substituted or is wrong. | ||
--- | ||
Configure.pl | 1 + | ||
1 file changed, 1 insertion(+) | ||
|
||
diff --git a/Configure.pl b/Configure.pl | ||
index b71b576be..753dcfaac 100755 | ||
--- a/Configure.pl | ||
+++ b/Configure.pl | ||
@@ -441,6 +441,7 @@ sub uniq { | ||
push @ldflags, $ENV{LDFLAGS} if $ENV{LDFLAGS}; | ||
$config{ldflags} = join ' ', @ldflags; | ||
|
||
+$config{moarshared} = ''; | ||
# Switch shared lib compiler flags in relocatable case. | ||
if (not $args{static} and $config{prefix} ne '/usr') { | ||
$config{moarshared} = $config{moarshared_relocatable} if $args{relocatable}; |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,60 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit flag-o-matic | ||
|
||
MY_PN="MoarVM" | ||
if [[ ${PV} == "9999" ]]; then | ||
EGIT_REPO_URI="https://github.com/${MY_PN}/${MY_PN}.git" | ||
inherit git-r3 | ||
KEYWORDS="" | ||
S="${WORKDIR}/${P}" | ||
else | ||
SRC_URI="http://moarvm.org/releases/${MY_PN}-${PV}.tar.gz" | ||
KEYWORDS="~amd64 ~x86" | ||
S="${WORKDIR}/${MY_PN}-${PV}" | ||
fi | ||
|
||
DESCRIPTION="A 6model-based VM for NQP and Rakudo Perl 6" | ||
HOMEPAGE="http://moarvm.org" | ||
LICENSE="Artistic-2" | ||
SLOT="0" | ||
|
||
#USE=optimize triggers makefile bug | ||
IUSE="asan clang debug doc +jit static-libs ubsan" | ||
|
||
RDEPEND="dev-libs/libatomic_ops | ||
>=dev-libs/libuv-1.26 | ||
dev-lang/lua:= | ||
virtual/libffi" | ||
DEPEND="${RDEPEND} | ||
clang? ( >=sys-devel/clang-3.1 ) | ||
dev-lang/perl" | ||
|
||
DOCS=( CREDITS README.markdown ) | ||
|
||
# Tests are conducted via nqp | ||
RESTRICT=test | ||
|
||
# known configure bug | ||
PATCHES="${FILESDIR}/fix-quoting.patch" | ||
|
||
src_configure() { | ||
use doc && DOCS+=( docs/* ) | ||
local myconfigargs=( | ||
"--prefix" "/usr" | ||
"--has-libuv" | ||
"--has-libatomic_ops" | ||
"--has-libffi" | ||
"--libdir" "$(get_libdir)" | ||
"--compiler" "$(usex clang clang gcc)" | ||
"$(usex asan --asan)" | ||
"$(usex debug --debug --no-debug)" | ||
"$(usex static-libs --static)" | ||
"$(usex ubsan --ubsan)" | ||
) | ||
|
||
perl Configure.pl "${myconfigargs[@]}" moarshared || die | ||
} |