forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-util/pycharm-community: Version bump to 2017.1.5
Package-Manager: Portage-2.3.6, Repoman-2.3.3
- Loading branch information
Showing
2 changed files
with
46 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST pycharm-community-2016.3.2.tar.gz 215633678 SHA256 e1092d3692118f9097e4182edfccc76159160353b7d7379cada3249b9e2d4f39 SHA512 64f8fd908c2165e4534f77596e6f9a86e72a04390432a0c1206d8a5cfde8a54067d5747a6f1f2a5ba5bb168e311d5f432939c87a15f871330ce2c2e42c9bfc8a WHIRLPOOL 92320d3f96b76148bba1e0ead93578cde6890119fa963e1390b7da2ea570d4b99e6bebdffe6167e283d534073b06cd063c2d9e70c0100436afc6b6d0fd264eda | ||
DIST pycharm-community-2017.1.3.tar.gz 195297254 SHA256 6dedbf06c62490047b5d8a539c94af89affc80048f4cf79eea25d29f50894a1b SHA512 9e8f1ab779bd10073e7cd1922cc0b8d43bebd02b64b1626d242d2fd1fdf21fe66811cc1809c17675b9ad91aff26bbef5c6b2c8afd47f70486dc66c7e66cde017 WHIRLPOOL 51212ddcf95167387fab8c274d098b77f74ce4832720fdffc62694e34d3eba4a77df12ea5c99a654ca97f6102fd02003afc44a8107fcd200ee9e2e17a6d8bf33 | ||
DIST pycharm-community-2017.1.5.tar.gz 195342869 SHA256 1a0bbf0d881527e08aad7a5adaa3ad44e8754c3eb2c3a8ed5ab113491549679b SHA512 1eac6062a1b92782e50425e053ec326965eaff6bf36ec3cf6d4e9fcdc1fe1a8baaf4d16131a38fc506c55c384943aaea51cf5f4c9d8d2e36080b7342ef1af21c WHIRLPOOL 1a655bcaa78b4a6607601229455e822cc56341c70132363a57cb9f6597f9f31ce007426a70284467cfe2c1a082972883746957e67dc678b5d379956f46a6c3cf | ||
DIST pycharm-community-2017.1.tar.gz 195354973 SHA256 6669120b68873a0bcb7faf179ea79f7c2dd7eac34d377d1f574724604b70e692 SHA512 056b23ba8b6cda4d609a2011b18e207f470670048185afeff0ad18dff8093d0ff0efa20a0a20b020ce81bc23008a31c7c9620c7fb4dc1f7e3d3b62316005322c WHIRLPOOL 0fefc16a433d41d64034a2df057a27bd035ec92cc7e00246f93a1afc0ef2350e919018071781e87d6285526993997507616f01f310e8c308bc4a1552b3eb4ef3 |
45 changes: 45 additions & 0 deletions
45
dev-util/pycharm-community/pycharm-community-2017.1.5.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,45 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit eutils readme.gentoo-r1 | ||
|
||
DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis" | ||
HOMEPAGE="http://www.jetbrains.com/pycharm/" | ||
SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz" | ||
|
||
LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
RDEPEND=">=virtual/jre-1.8" | ||
DEPEND="" | ||
|
||
RESTRICT="mirror strip" | ||
|
||
QA_PREBUILT="opt/${PN}/bin/fsnotifier | ||
opt/${PN}/bin/fsnotifier64 | ||
opt/${PN}/bin/fsnotifier-arm" | ||
|
||
MY_PN=${PN/-community/} | ||
|
||
src_prepare() { | ||
default | ||
|
||
rm -rf jre || die | ||
} | ||
|
||
src_install() { | ||
insinto /opt/${PN} | ||
doins -r * | ||
|
||
fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh} | ||
|
||
dosym ../../opt/${PN}/bin/pycharm.sh /usr/bin/${PN} | ||
newicon "bin/${MY_PN}.png" ${PN}.png | ||
make_desktop_entry ${PN} "${PN}" "${PN}" | ||
|
||
readme.gentoo_create_doc | ||
} |