Skip to content

Commit

Permalink
media-sound/audacious: Version bump to 3.9
Browse files Browse the repository at this point in the history
* USE='gtk3' removed, seeing that upstream wants to
  remove GTK+3 support anyways.
* Remove all the minor arches, they are just pose a
  maintenance burden.

Closes: https://bugs.gentoo.org/556700
Closes: https://bugs.gentoo.org/629374
Package-Manager: Portage-2.3.13, Repoman-2.3.4
  • Loading branch information
SoapGentoo committed Nov 5, 2017
1 parent b899d37 commit 927ebb3
Show file tree
Hide file tree
Showing 3 changed files with 153 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-sound/audacious/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -5,4 +5,5 @@ DIST audacious-3.7.1-gtk3.tar.bz2 571720 SHA256 30d63066916d0de32891c74b6b39e3c9
DIST audacious-3.7.1.tar.bz2 571450 SHA256 c8366870aea21d5f4a5a282dee45fba99390e4e3d5164cd119e343f79e9ecbbf SHA512 4c74fcfa6e575375501828905f01ed1e769d88fa346a99162c6800da5bc6aa33ec5598c5de1201c4e24cadb31b8c36768ea390aa4884de6bdbf42b0bea5a31a8 WHIRLPOOL 19fb9e0bd4b606e09ef21a66b8684fbc5ccac4e97c0f26abe96b42851fc3a2c629d89b39ec3f9a5ec82a779a2d6a5ae56ab36ab0993a2e0c1ff48861e6c28518
DIST audacious-3.8.2-gtk3.tar.bz2 591423 SHA256 4ec6bd82d812c5cdcb1c32f4b0912b219edc8f1ce2603b07f714e0c4f2ed08bc SHA512 fc2c69748c8f044aa8eae1848771b45088d85fbb67baf5dcd3ab2ff52e0848ba626e138d1a37756df98249f32cb3d6c54de29355b218602c6a47ff15c8ba0b96 WHIRLPOOL 7d9e2c295e89ec40ef91613f4a4c1f808446f156bbbc6e6be89511fa94a4b9cce5bef209187d1396edd008dd4474c127ad97a493cf9bf3deffd6064f07cdec8e
DIST audacious-3.8.2.tar.bz2 591209 SHA256 bdf1471cce9becf9599c742c03bdf67a2b26d9101f7d865f900a74d57addbe93 SHA512 13914d837ab5f283c45297424033486d9a5158f78f17f5538ecce780125fa76585e9e45852d15f6ecf3ed974e7a2f6289ceaaeffa97b2ea79b2bef449d8c786b WHIRLPOOL 9027baf4fe10e69fd41417d46db2d9105701a6a8c8b80f5bfa3f0aa9615b07a0103b159585b601c01b3483f93872ed890ed81f921b512d295648bffc820267f0
DIST audacious-3.9.tar.bz2 599488 SHA256 2d8044673ac786d71b08004f190bbca368258bf60e6602ffc0d9622835ccb05e SHA512 d8ef24c91c84bfa80831075cd9a12fc4bf02cec8bc96bcfa5a941254d194cccdc482482b1c015bc63e1142718c2221034c0f3a87e2cb6e4daf3b4cc428328aaa WHIRLPOOL a3e3d4f6b9fb0b3e2e90ea249101ae9cc0263d8dda0e49696e44ee00492218d9e19770669abcbcc4b8adfc4e53c263de1e8c9b5d5cdcc9a43d90e9b70d76e282
DIST gentoo_ice-xmms-0.2.tar.bz2 51839 SHA256 d1be63368b76f4a8b1d5b0e955cd7a77177f56a7f0b828c6603d8fd2836422b1 SHA512 e863a8f86073007c47ce8c20739aae4bff22e22a7ddc11556b12ae6ebb68654cec7310fdc9d05f2c47f81cf2591fe601b2eb12a2fd911c0a6118c9f3cc524f05 WHIRLPOOL b7a4409629a860021477f34f8886c40c005ea2ec34373d80e6a696323866e54f361e38c76b1ac536775ae5912308f11416e613dec791f21473f01a2fad35bcfd
76 changes: 76 additions & 0 deletions media-sound/audacious/audacious-3.9.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,76 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

MY_P="${P/_/-}"
S="${WORKDIR}/${MY_P}"

DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
HOMEPAGE="http://audacious-media-player.org/"

if [[ ${PV} == *9999 ]]; then
inherit autotools git-r3
EGIT_REPO_URI="https://github.com/audacious-media-player/audacious.git"
else
SRC_URI="mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
KEYWORDS="~amd64 ~x86"
fi

SRC_URI+="mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"

LICENSE="BSD-2"
SLOT="0"
IUSE="gtk nls qt5"
REQUIRED_USE="^^ ( gtk qt5 )"

RDEPEND="
>=dev-libs/dbus-glib-0.60
>=dev-libs/glib-2.28
>=x11-libs/cairo-1.2.6
>=x11-libs/pango-1.8.0
virtual/freedesktop-icon-theme
gtk? ( x11-libs/gtk+:2 )
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
)"
DEPEND="${RDEPEND}
virtual/pkgconfig
nls? ( dev-util/intltool )"
PDEPEND="~media-plugins/audacious-plugins-${PV}"

src_unpack() {
default
[[ ${PV} == *9999 ]] && git-r3_src_unpack
}

src_prepare() {
default
[[ ${PV} == *9999 ]] && eautoreconf
}

src_configure() {
# D-Bus is a mandatory dependency, remote control,
# session management and some plugins depend on this.
# Building without D-Bus is *unsupported* and a USE-flag
# will not be added due to the bug reports that will result.
# Bugs #197894, #199069, #207330, #208606
econf \
--disable-valgrind \
--enable-dbus \
$(use_enable gtk) \
$(use_enable nls) \
$(use_enable qt5 qt)
}

src_install() {
default

# Gentoo_ice skin installation; bug #109772
insinto /usr/share/audacious/Skins/gentoo_ice
doins -r "${WORKDIR}"/gentoo_ice/.
docinto gentoo_ice
dodoc "${WORKDIR}"/README
}
76 changes: 76 additions & 0 deletions media-sound/audacious/audacious-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,76 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

MY_P="${P/_/-}"
S="${WORKDIR}/${MY_P}"

DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
HOMEPAGE="http://audacious-media-player.org/"

if [[ ${PV} == *9999 ]]; then
inherit autotools git-r3
EGIT_REPO_URI="https://github.com/audacious-media-player/audacious.git"
else
SRC_URI="mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
KEYWORDS="~amd64 ~x86"
fi

SRC_URI+="mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"

LICENSE="BSD-2"
SLOT="0"
IUSE="gtk nls qt5"
REQUIRED_USE="^^ ( gtk qt5 )"

RDEPEND="
>=dev-libs/dbus-glib-0.60
>=dev-libs/glib-2.28
>=x11-libs/cairo-1.2.6
>=x11-libs/pango-1.8.0
virtual/freedesktop-icon-theme
gtk? ( x11-libs/gtk+:2 )
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
)"
DEPEND="${RDEPEND}
virtual/pkgconfig
nls? ( dev-util/intltool )"
PDEPEND="~media-plugins/audacious-plugins-${PV}"

src_unpack() {
default
[[ ${PV} == *9999 ]] && git-r3_src_unpack
}

src_prepare() {
default
[[ ${PV} == *9999 ]] && eautoreconf
}

src_configure() {
# D-Bus is a mandatory dependency, remote control,
# session management and some plugins depend on this.
# Building without D-Bus is *unsupported* and a USE-flag
# will not be added due to the bug reports that will result.
# Bugs #197894, #199069, #207330, #208606
econf \
--disable-valgrind \
--enable-dbus \
$(use_enable gtk) \
$(use_enable nls) \
$(use_enable qt5 qt)
}

src_install() {
default

# Gentoo_ice skin installation; bug #109772
insinto /usr/share/audacious/Skins/gentoo_ice
doins -r "${WORKDIR}"/gentoo_ice/.
docinto gentoo_ice
dodoc "${WORKDIR}"/README
}

0 comments on commit 927ebb3

Please sign in to comment.