Skip to content

Commit

Permalink
dev-python/celery: Add python3_6 to PYTHON_COMPAT
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
zmedico committed Mar 17, 2017
1 parent 41c0243 commit 9285605
Show file tree
Hide file tree
Showing 2 changed files with 28 additions and 2 deletions.
8 changes: 6 additions & 2 deletions dev-python/celery/celery-4.0.2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@

EAPI=6

PYTHON_COMPAT=( python2_7 python3_{4,5} )
PYTHON_COMPAT=( python2_7 python3_{4,5,6} )

inherit distutils-r1 bash-completion-r1

Expand Down Expand Up @@ -49,12 +49,16 @@ DEPEND="
>=dev-python/sphinx_celery-1.3[${PYTHON_USEDEP}]
dev-python/jinja[${PYTHON_USEDEP}]
dev-python/sqlalchemy[${PYTHON_USEDEP}]
dev-python/typing[${PYTHON_USEDEP}]
$(python_gen_cond_dep 'dev-python/typing[${PYTHON_USEDEP}]' python2_7 python3_4)
)"

# testsuite needs it own source
DISTUTILS_IN_SOURCE_BUILD=1

PATCHES=(
"${FILESDIR}"/${P}-log-endless-loop.patch
)

python_compile_all() {
if use doc; then
mkdir docs/.build || die
Expand Down
22 changes: 22 additions & 0 deletions dev-python/celery/files/celery-4.0.2-log-endless-loop.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,22 @@
From 9c950b47eca2b4e93fd2fe52cf80f158e6cf97ad Mon Sep 17 00:00:00 2001
From: George Psarakis <[email protected]>
Date: Mon, 23 Jan 2017 11:49:38 +0200
Subject: [PATCH] AWS DynamoDB result backend (#3736)

* Fix endless loop in logger_isa (Python 3.6)

https://github.com/celery/celery/pull/3736#issuecomment-274155454

diff --git a/celery/utils/log.py b/celery/utils/log.py
index 2fb15e6..00df476 100644
--- a/celery/utils/log.py
+++ b/celery/utils/log.py
@@ -82,7 +82,7 @@ def logger_isa(l, p, max=1000):
else:
if this in seen:
raise RuntimeError(
- 'Logger {0!r} parents recursive'.format(l),
+ 'Logger {0!r} parents recursive'.format(l.name),
)
seen.add(this)
this = this.parent

0 comments on commit 9285605

Please sign in to comment.