Skip to content

Commit

Permalink
net-misc/gns3-gui: version bump (2.2.28)
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.30, Repoman-3.0.3
Signed-off-by: Michael Mair-Keimberger <[email protected]>
Signed-off-by: Ionen Wolkens <[email protected]>
  • Loading branch information
mm1ke authored and ionenwks committed Jan 4, 2022
1 parent fc777e4 commit 92a2788
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-misc/gns3-gui/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST gns3-gui-2.2.25.tar.gz 5043324 BLAKE2B bd9a04dc91a35b80cdbf8fee7e8bed98ae5d4d8dd887e8902c3f8d2b08c405b9d6ec707fc9b0202053b1409b3326d9b09be7804cb85d0f14eb90af2db13ea5cd SHA512 d70806efa9251e8be419d838ebf0361bcc7d1ca923962dc4c9b364032772e37f2ae9d646b5e6b96b6c54cc7100dc3b1814eb85270d09e21c1f2679a4a3afda53
DIST gns3-gui-2.2.26.tar.gz 5043462 BLAKE2B 119c7ff65fde1624e6742215d23976137e13c90761314cbb8cfb5abb3772e5893c21b600acc5dca6e9874654088a3ebbdfb123d41acd9f1ee456c57f87aa3bdc SHA512 b994ae1b844956e4303b23688b71ccb70c2bc1d0803a316ad489fd5de61b7adbf126693e551618f6cf3c15c2404dadb02344e4821fe7e52a2ec8c42293e9a8f6
DIST gns3-gui-2.2.28.tar.gz 5043019 BLAKE2B 734e614d9364d7c0462621eefd62225b4c784af47ef7d1b60e76dca0f8a6baf21269ccc1a63f00bfe2992d12d2079bd822d310c4a6fbce9a0fc6e772c4d0108b SHA512 514ca1c40e1652d0941cdbc1f5adc41cd71990138a84f96ec522a50dcd39433e1312a6bf4768cd926cdc25b69a5291e8ac7028c33ef19338746a9cd25a042b45
40 changes: 40 additions & 0 deletions net-misc/gns3-gui/gns3-gui-2.2.28.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{8,9} )
DISTUTILS_USE_SETUPTOOLS=rdepend

inherit distutils-r1 virtualx xdg

DESCRIPTION="Graphical Network Simulator"
HOMEPAGE="https://www.gns3.com/ https://github.com/GNS3/gns3-gui"
SRC_URI="https://github.com/GNS3/gns3-gui/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"

#net-misc/gns3-server version should always match gns3-gui version
RDEPEND="
>=dev-python/distro-1.6.0[${PYTHON_USEDEP}]
>=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
>=dev-python/psutil-5.7.0[${PYTHON_USEDEP}]
>=dev-python/sentry-sdk-1.3.1[${PYTHON_USEDEP}]
~net-misc/gns3-server-${PV}[${PYTHON_USEDEP}]
dev-python/PyQt5[gui,network,svg,websockets,widgets,${PYTHON_USEDEP}]
"

distutils_enable_tests pytest

src_prepare() {
default

# newer python packages are fine
sed -i -e 's/[<>=].*//' requirements.txt || die
}

src_test() {
virtx distutils-r1_src_test
}

0 comments on commit 92a2788

Please sign in to comment.