Skip to content

Commit

Permalink
dev-python/bpython: is now compatible with recent curtsies
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
Andrey Grozin committed Sep 27, 2016
1 parent 7819ce5 commit 92aa994
Showing 1 changed file with 56 additions and 0 deletions.
56 changes: 56 additions & 0 deletions dev-python/bpython/bpython-0.15-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 python3_{3,4,5} )

inherit distutils-r1

DESCRIPTION="Syntax highlighting and autocompletion for the Python interpreter"
HOMEPAGE="http://www.bpython-interpreter.org/ https://github.com/bpython/bpython https://pypi.python.org/pypi/bpython"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc test"

RDEPEND="
>=dev-python/curtsies-0.2.9[${PYTHON_USEDEP}]
dev-python/greenlet[${PYTHON_USEDEP}]
dev-python/jedi[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/six-1.5[${PYTHON_USEDEP}]
dev-python/urwid[${PYTHON_USEDEP}]
dev-python/watchdog[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( dev-python/mock[${PYTHON_USEDEP}] )"

DOCS=( AUTHORS CHANGELOG sample.theme light.theme )

# Req'd for clean build by each impl
DISTUTILS_IN_SOURCE_BUILD=1

python_compile_all() {
if use doc; then
sphinx-build -b html -c doc/sphinx/source/ \
doc/sphinx/source/ doc/sphinx/source/html || die "docs build failed"
fi
}

python_test() {
pushd build/lib > /dev/null
"${PYTHON}" -m unittest discover || die
popd > /dev/null
}

python_install_all() {
use doc && local HTML_DOCS=( doc/sphinx/source/html/. )
distutils-r1_python_install_all
}

0 comments on commit 92aa994

Please sign in to comment.