Skip to content

Commit

Permalink
dev-python/CacheControl: Bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
patricklauer committed Oct 1, 2016
1 parent 51ebe6b commit 92b3c4b
Show file tree
Hide file tree
Showing 2 changed files with 38 additions and 0 deletions.
37 changes: 37 additions & 0 deletions dev-python/CacheControl/CacheControl-0.11.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )

inherit distutils-r1 eutils

DESCRIPTION="The httplib2 caching algorithms packaged up for use with requests"
HOMEPAGE="https://github.com/ionrock/cachecontrol https://pypi.python.org/pypi/cachecontrol/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="test"

RDEPEND="
dev-python/requests[${PYTHON_USEDEP}]
>=dev-python/lockfile-0.9[${PYTHON_USEDEP}]"
DEPENDS="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
"

# Not included
RESTRICT=test

python_test() {
py.test -v -v || die
}

pkg_postinst() {
optfeature "Redis based caches" dev-python/redis-py
}
1 change: 1 addition & 0 deletions dev-python/CacheControl/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST CacheControl-0.11.5.tar.gz 13104 SHA256 b78484d6feb17b501267f4048c364a8fc26fcef35ca3ff62bdba63d41fa4cf42 SHA512 2acce5a8be2e409a1a18254cfe71314074037bce3341f8b8fdec52c43500c90bfdb6063b2121c5cf6c8a2fc7c0903e4fd0c15813ffdfa547810b33571d211deb WHIRLPOOL 5e12640ba5c952ee8a83f5271bbbd105f148cd080bf6ae5c2cbc9c6cc20361005aa5cf1a95feaa1a808c56c26b7abdfbde3b7bffc873f26072d23262c12b49ca
DIST CacheControl-0.11.6.tar.gz 13642 SHA256 37dfcb453e7f186c95b330834a1673e022db900d5e3a883f80257c4369477695 SHA512 5640805db3a0f3e0e96192f2122159f0391be4821934ae6624b2778e91de319d5acf0e8693d00cf9910314ff7e2e1e7d2c82789b46fb012363fbb1c38dcb0d29 WHIRLPOOL 9187c18e12196b379136afa89d64c5dda461f9f0fa1764a5922046d579d9c10921a7bc8f8b409db29cd51d6bc0c358ab9bd8f3cf142de375da2b0a5723ed4117
DIST CacheControl-0.11.7.tar.gz 13902 SHA256 8f7829d92584f1f2360ebfff4517ee359787d5b7dfa2ef9579f871b628745a1e SHA512 fad1f93140dd6fcedb3797f4dbc1587045ade8dafe6cbc6774bf62bd635fbc1ba08b2dec124745cffed5259606b55f0e2edee036b5b5e34156d3114f6bf63493 WHIRLPOOL 736a503fae24d8ba1ecc13a1d47d8f51b0f478f1890de52747b56b3aba770e44aba4eae48bd6140a0611931fa1cdfb5ee5315f833abb997aa69143ee9b84b9e4

0 comments on commit 92b3c4b

Please sign in to comment.