Skip to content

Commit

Permalink
dev-db/sqlcipher: add 4.6.1
Browse files Browse the repository at this point in the history
- remove subslot binder for zlib
- add github to HOMEPAGE
- remove unneeded src_prepare
- changed econfargs to be stored in an array

Signed-off-by: Filip Kobierski <[email protected]>
Closes: gentoo#38166
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
fkobi authored and juippis committed Aug 29, 2024
1 parent 6e3debe commit 92ba67a
Show file tree
Hide file tree
Showing 2 changed files with 66 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-db/sqlcipher/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST sqlcipher-4.5.5.tar.gz 18816611 BLAKE2B 46c6c64140848e02f7572afc3268db648f9968c41bd7d7e945d4918904ac572d57e0fdc049cf3dac40cc0fd0b034fb96693438ff04fffb4fcd603db2263b7ae9 SHA512 034774f8d320a53f08a9735c035bf83f81ef9223780473c39ec07658b80af89dc665599caa3b2662055039fa678c7a29cbf777d046922948e86123e677b823bc
DIST sqlcipher-4.6.1.tar.gz 19115004 BLAKE2B 792e3342eba78ed8aee49265fcb9e216edaeb7d4c68fd9a95ac9abe60093a8baeb755e32e736a7af98811921d1bfd93f882418864bf5785952ffc2bbae1fc649 SHA512 023b2fc7248fe38b758ef93dd8436677ff0f5d08b1061e7eab0adb9e38ad92d523e0ab69016ee69bd35c1fd53c10f61e99b01f7a2987a1f1d492e1f7216a0a9c
65 changes: 65 additions & 0 deletions dev-db/sqlcipher/sqlcipher-4.6.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,65 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit flag-o-matic multilib-minimal

DESCRIPTION="Full Database Encryption for SQLite"
HOMEPAGE="
https://www.zetetic.net/sqlcipher/
https://github.com/sqlcipher/sqlcipher
"
SRC_URI="https://github.com/sqlcipher/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug libedit readline tcl test"
# Testsuite requires compilation with TCL, bug #582584
REQUIRED_USE="
?? ( libedit readline )
test? ( tcl )
"
RESTRICT="!test? ( test )"

RDEPEND="
dev-libs/openssl:=[${MULTILIB_USEDEP}]
sys-libs/zlib[${MULTILIB_USEDEP}]
libedit? ( dev-libs/libedit[${MULTILIB_USEDEP}] )
readline? ( sys-libs/readline:=[${MULTILIB_USEDEP}] )
tcl? ( dev-lang/tcl:=[${MULTILIB_USEDEP}] )
"
DEPEND="${RDEPEND}"
BDEPEND="dev-lang/tcl"

src_configure() {
# Column metadata added due to bug #670346
append-cflags -DSQLITE_HAS_CODEC -DSQLITE_ENABLE_COLUMN_METADATA

multilib-minimal_src_configure
}

multilib_src_configure() {
local myeconfargs=(
--enable-fts3
--enable-fts4
--enable-fts5
--enable-geopoly
--enable-memsys5
--enable-rtree
--enable-session
--enable-tempstore
$(use_enable debug)
$(use_enable libedit editline)
$(use_enable readline)
$(use_enable tcl)
)
ECONF_SOURCE="${S}" \
econf "${myeconfargs[@]}"
}

multilib_src_install_all() {
einstalldocs
find "${ED}" -name '*.la' -type f -delete || die
}

0 comments on commit 92ba67a

Please sign in to comment.