Skip to content

Commit

Permalink
games-engines/residualvm: remove deprecated games eclass
Browse files Browse the repository at this point in the history
Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: Portage-2.3.2, Repoman-2.3.1
  • Loading branch information
austin987 committed Jan 20, 2017
1 parent 9bbd7dc commit 92e6566
Showing 1 changed file with 82 additions and 0 deletions.
82 changes: 82 additions & 0 deletions games-engines/residualvm/residualvm-0.2.1-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,82 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit eutils toolchain-funcs gnome2-utils

DESCRIPTION="A cross-platform 3D game interpreter for play LucasArts' LUA-based 3D adventures"
HOMEPAGE="http://www.residualvm.org/"
SRC_URI="mirror://sourceforge/${PN}/${P}-sources.tar.bz2"

LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

# TODO: fix dynamic plugin support
# games crash without media-libs/libsdl[alsa]
RDEPEND="
media-libs/alsa-lib
media-libs/freetype:2
media-libs/libsdl[X,sound,alsa,joystick,opengl,video]
sys-libs/zlib
virtual/glu
virtual/opengl"
DEPEND="${RDEPEND}"

src_configure() {
# not an autotools script
# most configure options currently do nothing, verify on version bump !!!
# disable explicitly, otherwise we get unneeded linkage (some copy-paste build system)
./configure \
--backend=sdl \
--disable-debug \
--disable-faad \
--disable-flac \
--disable-fluidsynth \
--disable-libunity \
--disable-mad \
--disable-sparkle \
--disable-translation \
--disable-tremor \
--disable-vorbis \
--docdir="/usr/share/doc/${PF}" \
--enable-all-engines \
--enable-release-mode \
--enable-zlib \
|| die "configure failed"
}

src_compile() {
emake \
VERBOSE_BUILD=1 \
AR="$(tc-getAR) cru" \
RANLIB=$(tc-getRANLIB)
}

src_install() {
dobin residualvm

insinto "/usr/share/${PN}"
doins gui/themes/modern.zip dists/engine-data/residualvm-grim-patch.lab

doicon -s scalable icons/${PN}.svg
doicon -s 256 icons/${PN}.png
domenu dists/${PN}.desktop

doman dists/${PN}.6
dodoc AUTHORS README.md KNOWN_BUGS TODO
}

pkg_preinst() {
gnome2_icon_savelist
}

pkg_postinst() {
gnome2_icon_cache_update
}

pkg_postrm() {
gnome2_icon_cache_update
}

0 comments on commit 92e6566

Please sign in to comment.