Skip to content

Commit

Permalink
dev-python/jupyter_client: include the missing patch.
Browse files Browse the repository at this point in the history
Credit:  Harris Landgarten
Bug: 629376

Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
heroxbd committed Aug 31, 2017
1 parent 2bd0ab7 commit 9350101
Showing 1 changed file with 39 additions and 0 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
From f9bd2643d42b3354b27e64368d8c15cad18101d2 Mon Sep 17 00:00:00 2001
From: Philipp A <[email protected]>
Date: Tue, 8 Aug 2017 17:38:52 +0200
Subject: [PATCH] Always use setuptools if availabe
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

When running `python* setup.py install`, the `jupyter-run` script doesn’t get installed without this.
---
setup.py | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)

diff --git a/setup.py b/setup.py
index 60fa17c..0831f7a 100644
--- a/setup.py
+++ b/setup.py
@@ -70,6 +70,7 @@
],
)

+# require setuptools for these cases
if 'develop' in sys.argv or any(a.startswith('bdist') for a in sys.argv):
import setuptools

@@ -85,7 +86,12 @@
'test': ['ipykernel', 'ipython', 'mock', 'pytest'],
}

-if 'setuptools' in sys.modules:
+# always try to use setuptools if available
+try:
+ import setuptools
+except ImportError:
+ pass
+else:
setup_args.update(setuptools_args)
setup_args['entry_points'] = {
'console_scripts': [

0 comments on commit 9350101

Please sign in to comment.