forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Signed-off-by: Michał Górny <[email protected]>
- Loading branch information
Showing
2 changed files
with
34 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST cbor2-5.4.3.tar.gz 86499 BLAKE2B 0303ed49a1c468a3aa13e12a4bebef17479f106bc3f0a92e35c6029ff1bd86aea6a77f557ac0c8acb5e055ec0b56c82e5c95e9417d00715a1fb244bd94d0f60d SHA512 9527bec5a36464bb7dc9a8c0ece3ad72f1c6182272a7edf0526668b264c957b72bc031d2398dc6af38af09bb298219c316da194084fab410bae5f9100b22328b | ||
DIST cbor2-5.4.4.tar.gz 86755 BLAKE2B 616a5e3d10f979f7f5923b0226d6ca52392e79bf1c4dcdef6d44143af75b02a91846e1a8f0c571f096f2168908137a5f31995199c13383b4d81cb1f17062b1fd SHA512 f8754423490b8a9643ca3309c99254f6be5e9eeab2163b57631fd2e6fd3f5f5dbd8495e24bbfcf96720f07467797eb3f4e3603822a7d6999f1ee4fa66651f2d7 | ||
DIST cbor2-5.4.5.tar.gz 86800 BLAKE2B 2911cf15d31ec77aab79129719f9fc869392da8383b8a1afbff7e7d9c0d90ad341f66b5b76ae5142eae7036b7446dd54d545a48695de43aaf54e0824e9d8052c SHA512 ee360318c24ab6cdd93162ef78b0ab099990630ebd14c581012b0d86b1a30c9aa1e4b45d285d33da5684f5385db976189e89d32589d68272f79fcd8f7130bf7b | ||
DIST cbor2-5.4.6.tar.gz 86909 BLAKE2B df24c786f32819f9a93a2db28536b78349db6185108188d0a20e7298ff8c083d1feb59110865b4e21190e0363b113201ccddaa0d36b49bd7bbacf9d5ee7695f4 SHA512 44fb3e2e2249c79b1454487670d53eb672ffae4c22374d2a2bb9e314ac15470e4e7913e4eb1981a8bd4d722e6827328dde7e57c5f0556843e951c4723ae5bd8e |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,33 @@ | ||
# Copyright 1999-2022 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
DISTUTILS_USE_PEP517=setuptools | ||
PYTHON_COMPAT=( python3_{8..11} ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Pure Python CBOR (de)serializer with extensive tag support" | ||
HOMEPAGE=" | ||
https://github.com/agronholm/cbor2/ | ||
https://pypi.org/project/cbor2/ | ||
" | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" | ||
|
||
LICENSE="MIT" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86" | ||
|
||
BDEPEND=" | ||
>=dev-python/setuptools-61[${PYTHON_USEDEP}] | ||
>=dev-python/setuptools_scm-6.4[${PYTHON_USEDEP}] | ||
" | ||
|
||
distutils_enable_tests pytest | ||
|
||
python_prepare_all() { | ||
# remove pytest-cov dep | ||
sed -i -e "s/--cov//" pyproject.toml || die | ||
distutils-r1_python_prepare_all | ||
} |