Skip to content

Commit

Permalink
app-portage/iwdevtools: add 0.12.5
Browse files Browse the repository at this point in the history
Signed-off-by: Ionen Wolkens <[email protected]>
  • Loading branch information
ionenwks committed May 26, 2023
1 parent 5aa32b9 commit 93abaf5
Show file tree
Hide file tree
Showing 2 changed files with 66 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-portage/iwdevtools/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST iwdevtools-0.12.4.tar.gz 89925 BLAKE2B 6fd87cc528784d443cf966fd126f4bcb020bbaf759509eb1d3e512af73d16fc22b12de06510d2486fcb96ff8c86f8fc77d404d55b2935ef0b456f582a007d903 SHA512 c6486a16ade37a98f38e551e8c01c19c1704b1d99cef87fd1bff9575dcb52df6a1429a2fc26783cbcdc64c971f4885286e9155786a8aa23360c32826e6b8f19e
DIST iwdevtools-0.12.5.tar.gz 89999 BLAKE2B de7c1c98a93df42ca0436e9c08a6ec2eeec1ae5db524a8b95c94ab70e43a10f8a649cc489f671712c273fe52b1ee8223e4afac670aedccec254d9c035565feb0 SHA512 97372288421e5db71faf8d98544e8f273c2bfa7d36dd5ceb9bdde5e288547f7863fe7548f2dcc7db568a293e05bafce77e0cb29335f6e79841b0ecf78fbefecc
65 changes: 65 additions & 0 deletions app-portage/iwdevtools/iwdevtools-0.12.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,65 @@
# Copyright 2021-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit meson optfeature

DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
HOMEPAGE="https://github.com/ionenwks/iwdevtools"
SRC_URI="https://github.com/ionenwks/iwdevtools/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
IUSE="test"
RESTRICT="!test? ( test )"

RDEPEND="
app-misc/pax-utils
app-portage/portage-utils
>=app-shells/bash-5.1
dev-libs/libxml2:2
sys-apps/coreutils
sys-apps/diffutils
sys-apps/file
sys-apps/portage
|| ( sys-apps/util-linux app-misc/getopt )"
BDEPEND="
sys-apps/help2man
|| ( sys-apps/util-linux app-misc/getopt )
test? ( ${RDEPEND} )"

src_configure() {
local emesonargs=(
-Ddocdir=${PF}
-Deprefix="${EPREFIX}"
-Dshellcheck=false
$(meson_use test)
)

has_version sys-apps/util-linux || emesonargs+=( -Dgetopt=getopt-long )

meson_src_configure
}

pkg_postinst() {
optfeature "detecting potential ABI issues using abidiff" dev-util/libabigail

if [[ ! ${REPLACING_VERSIONS} ]]; then
elog "Optional portage integration relies on using /etc/portage/bashrc."
elog "The example bashrc can be used as-is if not already using one:"
elog
elog " ln -s ../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
elog
elog "Otherwise, inspect the tools' --help output and the example to integrate"
elog "(if not defining the same phase functions, the example can be sourced)."
elog
elog "Note that \`eqawarn\` is used for portage output by default. QA messages"
elog "aren't logged / shown post-emerge unless e.g. in /etc/portage/make.conf:"
elog
elog ' PORTAGE_ELOG_CLASSES="${PORTAGE_ELOG_CLASSES} qa"'
elog
elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for information on tools."
fi
}

0 comments on commit 93abaf5

Please sign in to comment.