Skip to content

Commit

Permalink
nawk: version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.30, Repoman-3.0.3
Signed-off-by: Christoph Junghans <[email protected]>
  • Loading branch information
junghans committed Dec 1, 2022
1 parent b7d704b commit 93b3f38
Show file tree
Hide file tree
Showing 2 changed files with 55 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-apps/nawk/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST nawk-20180827.tar.gz 1824076 BLAKE2B 4cfd000842d75d9a713fe73a85eefab33c17f9ecaca4f7f663d1157da411fd9fcf2badbf5180b4a90910445332095fe457e7acf0643621ac8a68da1a246b5e5f SHA512 cd6561149be71e6311aaa69c86b90ee4b29a057e5c2595470ccc8a41c40c653ec31b4bd46d7f58896d012f5fb5952103a76aa463a69e5128cba43d80eedf0b9b
DIST nawk-20220122.tar.gz 1832761 BLAKE2B f704ff9cf5012545ec3adc1887c0d43625d7e38e19589cba91fe31f664e72ccce20dee3f2484067a31af793be16439c1389603fbdb33c119efeafb18559a0d97 SHA512 46ab7936705288c9cd22867ad9f5b080ade67c4b05d674304e0e5cae8ea329420a9a46e3578bf3a014b7066a1185b7506b0f74445bb52aafb1090e7a82a5bf28
54 changes: 54 additions & 0 deletions sys-apps/nawk/nawk-20220122.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit toolchain-funcs

DESCRIPTION="Brian Kernighan's pattern scanning and processing language"
HOMEPAGE="https://www.cs.princeton.edu/~bwk/btl.mirror/"
SRC_URI="https://github.com/onetrueawk/awk/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux"

RDEPEND="
app-eselect/eselect-awk"

DEPEND="
${RDEPEND}
virtual/yacc"

S="${WORKDIR}/awk-${PV}"

DOCS=( README.md FIXES )

src_compile() {
emake \
CC="$(tc-getCC)" \
CFLAGS="${CFLAGS}" \
CPPFLAGS=-DHAS_ISBLANK \
ALLOC="${LDFLAGS}" \
YACC=$(type -p bison) \
YFLAGS="-d"
}

src_install() {
newbin a.out "${PN}"
sed \
-e 's/awk/nawk/g' \
-e 's/AWK/NAWK/g' \
-e 's/Awk/Nawk/g' \
awk.1 > "${PN}".1 || die "manpage patch failed"
doman "${PN}.1"
einstalldocs
}

pkg_postinst() {
eselect awk update ifunset
}

pkg_postrm() {
eselect awk update ifunset
}

0 comments on commit 93b3f38

Please sign in to comment.