Skip to content

Commit

Permalink
dev-libs/botan: add 3.1.1
Browse files Browse the repository at this point in the history
  • Loading branch information
thesamesam committed Jul 14, 2023
1 parent 38cd1b9 commit 93ec230
Show file tree
Hide file tree
Showing 2 changed files with 220 additions and 0 deletions.
2 changes: 2 additions & 0 deletions dev-libs/botan/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -6,3 +6,5 @@ DIST Botan-3.0.0.tar.xz 8752380 BLAKE2B 06ac29dc0cbaef43a38cc30185f431e1b1f40834
DIST Botan-3.0.0.tar.xz.asc 488 BLAKE2B 6a34817ec4700983151f97d2e278870736860ac72f3936fcc63e241d89ba758bdf7765d3c877d88019055562a6067c278ecbac263e8d87cc310790089e47f662 SHA512 46ff64bb4d215a48b0549d90ae2461ae39ae5ecf588a7e130876759ec30561c5a2db77ee9cdc7a3dab990927b51ea732f5b56592bdc150062ca25690378ab817
DIST Botan-3.1.0.tar.xz 8807364 BLAKE2B 4f990905d213d42969e54e2f95844832ceecad91eac08436d221a3881719e896e3a4fa564e8b267d5d74d9955b55b547b3df9ca77726993a9a8136e42add4533 SHA512 2234f026bc79657699ab53042dca7d67f4beee91593bf12c32a94688978bd4a99ef4e632ecdb2d21b20481e1cdc353a8fa8665db0f0130b2e8f0f84ebeac8970
DIST Botan-3.1.0.tar.xz.asc 488 BLAKE2B 921092f09ea4e00742c66827298bc5b1476dbb98c5c76fd10a09013333b0d9522484eb85cffef359ffc952c9d01892295c125b7c8957fa028cad2a931b599e05 SHA512 11f43d6147113fbe4d49d81b5b2f74a99951cee6cb52ebea741c36a7dec577e1fc14af7241dc60c14b271ba1432dc19a59939b3984233738159198d187973e3e
DIST Botan-3.1.1.tar.xz 8800368 BLAKE2B c31365e6bd4106f96a033e5f092c528c0185577f41d9a698d2630ece0f660f87f03e0775ebeb5c4d812819bbc6eb556b5ff15c16f243288ae73c8bf1fbb991ce SHA512 ed6bdadb910b0775245648140212953ed364aa26107f851e39ac5cb664d7f476c519a22cdad41f0e520796c4ebe453c56ca68a2178e39f815d445e9979333795
DIST Botan-3.1.1.tar.xz.asc 488 BLAKE2B 9ac94473d90a26932e507cdb3f46d8381565deecff38a5a2f7fe043b33405071adf0baee4235dd94bb6d35fa3ffedca6192fb5f5d76030874a90a399d88f9744 SHA512 f52e8602a57f590150f6f49829e788910006e5113ab6e85c6efe73009b8db752b5f28b869c6265ef6dd3c2727c64c0182d125f02f92485485768416c618acdb9
218 changes: 218 additions & 0 deletions dev-libs/botan/botan-3.1.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,218 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{10..12} )
VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/botan.asc
inherit edo flag-o-matic multiprocessing python-r1 toolchain-funcs verify-sig

MY_P="Botan-${PV}"
DESCRIPTION="C++ crypto library"
HOMEPAGE="https://botan.randombit.net/"
SRC_URI="https://botan.randombit.net/releases/${MY_P}.tar.xz"
SRC_URI+=" verify-sig? ( https://botan.randombit.net/releases/${MY_P}.tar.xz.asc )"
S="${WORKDIR}/${MY_P}"

LICENSE="BSD-2"
# New major versions are parallel-installable
SLOT="$(ver_cut 1)/$(ver_cut 1-2)" # soname version
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~ppc-macos"
IUSE="doc boost bzip2 lzma python static-libs sqlite test tools zlib"
RESTRICT="!test? ( test )"

CPU_USE=(
cpu_flags_arm_{aes,neon}
cpu_flags_ppc_altivec
cpu_flags_x86_{aes,avx2,popcnt,rdrand,sha,sse2,ssse3,sse4_1,sse4_2}
)

IUSE+=" ${CPU_USE[@]}"

REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

# NOTE: Boost is needed at runtime too for the CLI tool.
DEPEND="
boost? ( dev-libs/boost:= )
bzip2? ( >=app-arch/bzip2-1.0.5:= )
lzma? ( app-arch/xz-utils:= )
python? ( ${PYTHON_DEPS} )
sqlite? ( dev-db/sqlite:3= )
zlib? ( >=sys-libs/zlib-1.2.3:= )
"
RDEPEND="
${DEPEND}
!<dev-libs/botan-2.19.3-r1:2[tools]
"
BDEPEND="
${PYTHON_DEPS}
$(python_gen_any_dep '
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
')
|| ( >=sys-devel/gcc-11:* >=sys-devel/clang-14:* )
verify-sig? ( sec-keys/openpgp-keys-botan )
"

# NOTE: Considering patching Botan?
# Please see upstream's guidance:
# https://botan.randombit.net/handbook/packaging.html#minimize-distribution-patches

python_check_deps() {
use doc || return 0
python_has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
}

pkg_pretend() {
[[ ${MERGE_TYPE} == binary ]] && return

# bug #908958
if tc-is-gcc && ver_test $(gcc-version) -lt 11 ; then
eerror "Botan needs >=gcc-11 or >=clang-14 to compile."
eerror "Please upgrade GCC: emerge -v1 sys-devel/gcc"
die "GCC version is too old to compile Botan!"
elif tc-is-clang && ver_test $(clang-version) -lt 14 ; then
eerror "Botan needs >=gcc-11 or >=clang-14 to compile."
eerror "Please upgrade Clang: emerge -v1 sys-devel/clang"
die "Clang version is too old to compile Botan!"
fi
}

src_configure() {
tc-export AR CC CXX
python_setup

local disable_modules=(
$(usev !boost 'boost')
)

if [[ -z "${DISABLE_MODULES}" ]] ; then
elog "Disabling module(s): ${disable_modules[@]}"
fi

local chostarch="${CHOST%%-*}"

# Arch specific wrangling
local myos=
case ${CHOST} in
*-darwin*)
myos=darwin
;;
*)
myos=linux

if [[ ${CHOST} == *hppa* ]] ; then
chostarch=parisc
elif [[ ${ABI} == sparc64 ]] ; then
chostarch="sparc64"
elif [[ ${ABI} == sparc32 ]] ; then
chostarch="sparc32"
fi
;;
esac

local pythonvers=()
if use python ; then
_append() {
pythonvers+=( ${EPYTHON/python/} )
}

python_foreach_impl _append
fi

local myargs=(
# Intrinsics
# TODO: x86 RDSEED (new CPU_FLAGS_X86?)
# TODO: POWER Crypto (new CPU_FLAGS_PPC?)
$(usev !cpu_flags_arm_aes '--disable-armv8crypto')
$(usev !cpu_flags_arm_neon '--disable-neon')
$(usev !cpu_flags_ppc_altivec '--disable-altivec')
$(usev !cpu_flags_x86_aes '--disable-aes-ni')
$(usev !cpu_flags_x86_avx2 '--disable-avx2')
$(usev !cpu_flags_x86_popcnt '--disable-bmi2')
$(usev !cpu_flags_x86_rdrand '--disable-rdrand')
$(usev !cpu_flags_x86_sha '--disable-sha-ni')
$(usev !cpu_flags_x86_sse2 '--disable-sse2')
$(usev !cpu_flags_x86_ssse3 '--disable-ssse3')
$(usev !cpu_flags_x86_sse4_1 '--disable-sse4.1')
$(usev !cpu_flags_x86_sse4_2 '--disable-sse4.2')

# HPPA's GCC doesn't support SSP
$(usev hppa '--without-stack-protector')

$(use_with boost)
$(use_with bzip2)
$(use_with doc documentation)
$(use_with doc sphinx)
$(use_with lzma)
$(use_enable static-libs static-library)
$(use_with sqlite sqlite3)
$(use_with zlib)

--cpu=${chostarch}
--docdir=share/doc
--disable-modules=$(IFS=","; echo "${disable_modules[*]}")
--distribution-info="Gentoo ${PVR}"
--libdir="$(get_libdir)"
# Avoid collisions between slots for tools (bug #905700)
--program-suffix=$(ver_cut 1)

# Don't install Python bindings automatically
# (do it manually later in the right place)
# bug #723096
--no-install-python-module

--os=${myos}
--prefix="${EPREFIX}"/usr
--with-endian="$(tc-endian)"
--with-python-version=$(IFS=","; echo "${pythonvers[*]}")
)

local build_targets=(
shared
$(usev static-libs static)
$(usev tools cli)
$(usev test tests)
)

myargs+=(
--build-targets=$(IFS=","; echo "${build_targets[*]}")
)

if use elibc_glibc && use kernel_linux ; then
myargs+=(
--with-os-features=getrandom,getentropy
)
fi

local sanitizers=()
if is-flagq -fsanitize=address ; then
sanitizers+=( address )
fi
if is-flagq -fsanitize=undefined ; then
sanitizers+=( undefined )
fi
filter-flags '-fsanitize=*'
myargs+=(
--enable-sanitizers=$(IFS=","; echo "${sanitizers[*]}")
)

edo ${EPYTHON} configure.py --verbose "${myargs[@]}"
}

src_test() {
LD_LIBRARY_PATH="${S}" edo ./botan-test$(ver_cut 1) --test-threads="$(makeopts_jobs)"
}

src_install() {
default

if [[ -d "${ED}"/usr/share/doc/${P} && ${P} != ${PF} ]] ; then
# --docdir in configure controls the parent directory unfortunately
mv "${ED}"/usr/share/doc/${P} "${ED}"/usr/share/doc/${PF} || die
fi

# Manually install the Python bindings (bug #723096)
if use python ; then
python_foreach_impl python_domodule src/python/botan$(ver_cut 1).py
fi
}

0 comments on commit 93ec230

Please sign in to comment.