Skip to content

Commit

Permalink
net-im/toxic: new package
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.2
  • Loading branch information
Daniel Campbell committed Oct 28, 2016
1 parent e889970 commit 93f1ff2
Show file tree
Hide file tree
Showing 3 changed files with 71 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-im/toxic/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST toxic-0.7.1.tar.gz 1137112 SHA256 414ca2cd369e277872c7248c43f82afa0ac2f6c8fa5fc8e93f7c3e8ab6d11b9c SHA512 c304b07a67ed27a25394590eb8759b5dd957605be4eb9e64590d4580da0977e1cd201e8b95ae1b31e995772560510ceb0643028696e2df69e1f5d0dff575b553 WHIRLPOOL 228193bb78bf38bd5f5f5ff371a87f12561edcb5729337b58198df36e5ec55b99f2c2ca84f5b471846e7f84445f1c5181c5fa71ff287f62d5e34f833a45747d6
22 changes: 22 additions & 0 deletions net-im/toxic/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,22 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Daniel Campbell</name>
</maintainer>
<upstream>
<maintainer>
<email>[email protected]</email>
<name>JFreegman</name>
</maintainer>
<remote-id type="github">jfreegman/toxic</remote-id>
</upstream>
<longdescription lang="en">
An ncurses-based Tox client written in C. Supports audio calling, file sharing, and desktop notifications.
</longdescription>
<use>
<flag name="notifications">Enables desktop notifications with libnotify</flag>
<flag name="av">Enables audio calling and/or audio notifications</flag>
</use>
</pkgmetadata>
48 changes: 48 additions & 0 deletions net-im/toxic/toxic-0.7.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

DESCRIPTION="A curses-based client for Tox."
HOMEPAGE="https://github.com/JFreegman/toxic"
SRC_URI="https://github.com/JFreegman/toxic/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+X +av notifications"

RDEPEND="
net-libs/tox[av?]
dev-libs/libconfig
media-gfx/qrencode
net-misc/curl
sys-libs/ncurses:0=
av? ( media-libs/openal media-libs/freealut )
notifications? ( x11-libs/libnotify )
"
DEPEND="${RDEPEND}"

src_configure() {
if ! use av; then
export DISABLE_AV=1
export DISABLE_SOUND_NOTIFY=1
fi
if ! use X; then
export DISABLE_X11=1
fi
if ! use notifications; then
export DISABLE_DESKTOP_NOTIFY=1
fi
sed -i \
-e "s,/usr/local,${EPREFIX}/usr,g" \
cfg/global_vars.mk || die "PREFIX sed failed"
}

src_install() {
default
if ! use av; then
rm -r "${ED%/}"/usr/share/${PN}/sounds || die "Could not remove sound dir"
fi
}

0 comments on commit 93f1ff2

Please sign in to comment.