forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-editors/neovim: Add version 0.1.1
Package-Manager: portage-2.2.25
- Loading branch information
1 parent
cef53b6
commit 945f73f
Showing
2 changed files
with
79 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST neovim-0.0.0_pre20151025.tar.xz 4947384 SHA256 62b3bd93e0395c3f2d1f829a1e4e444ac081de1acc99114f6ceba7d61a7055a3 SHA512 a0390097cc0cfae401779ddd229a6237fa63522caaa6515dfff025b506b83e2597a10711bae0a1a60770d2a244963aa56af58f734885ce73091a19865a420bf0 WHIRLPOOL becfec39f4aa1a22f48991f17dbca003f38dfa6b085ed6043e34ed7e852217dddd3e4fce4d33873b0385e1b46754ae11db21ce47cbecd12822e5073d38a5fda1 | ||
DIST neovim-0.1.0.tar.gz 7644722 SHA256 e8659558103b8f5a65aac84007a12e3581b32736321778028017fd07365cfff8 SHA512 b91e5ce5561155ecb3554f56fd4371219612ed3bc35dfeb60a225eb1dbe1473fce5f573eb996bdb01fd9569f764da86493108665c98dc7555fc44f410befb00a WHIRLPOOL 33d7b88588c214ddc670a7b3cffcfd855699e90b15c5e327ac0c17972fddb73bd519b1a8eb609f8454d6c463f18764f17bc1314b6b27448c5ac4607cdbce1551 | ||
DIST neovim-0.1.1.tar.gz 7584560 SHA256 f39bcab23457c66ce0d67dcf8029743703f860413db0070f75d4f0ffad27c6c1 SHA512 7098bef9b81862f009789cff49a063d56d52d2f5c74e2fe68ad65c952c61c07eabeb6be150b369a5a179957f20187de3051caaa30b1e0cb4ec1e9e49b4e77333 WHIRLPOOL 9df0d6d59bdda2def2d8a393eec579f341256aff18c485cbb08c96637c597ee4df73a68a09105e776605194412274df2c82b78f7ca0e0bc1e20d4780fcdfa57f |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,78 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
inherit cmake-utils flag-o-matic | ||
|
||
DESCRIPTION="Vim-fork focused on extensibility and agility." | ||
HOMEPAGE="https://neovim.io" | ||
if [[ ${PV} == 9999 ]]; then | ||
inherit git-r3 | ||
EGIT_REPO_URI="git://github.com/neovim/neovim.git" | ||
else | ||
SRC_URI="https://github.com/neovim/neovim/archive/v${PV}.tar.gz -> ${P}.tar.gz" | ||
KEYWORDS="~amd64 ~x86" | ||
fi | ||
|
||
LICENSE="Apache-2.0 vim" | ||
SLOT="0" | ||
IUSE="+nvimpager perl python +jemalloc" | ||
|
||
CDEPEND="dev-lang/luajit:2 | ||
>=dev-libs/libtermkey-0.17 | ||
>=dev-libs/libuv-1.2.0 | ||
>=dev-libs/msgpack-0.6.0_pre20150220 | ||
>=dev-libs/unibilium-1.1.1 | ||
dev-libs/libvterm | ||
dev-lua/lpeg | ||
dev-lua/messagepack | ||
jemalloc? ( dev-libs/jemalloc ) | ||
" | ||
DEPEND="${CDEPEND} | ||
virtual/libiconv | ||
virtual/libintl" | ||
RDEPEND="${CDEPEND} | ||
perl? ( dev-lang/perl ) | ||
python? ( dev-python/neovim-python-client )" | ||
|
||
CMAKE_BUILD_TYPE=RelWithDebInfo | ||
|
||
src_prepare() { | ||
# use our system vim dir | ||
sed -e '/^# define SYS_VIMRC_FILE/s|$VIM|'"${EPREFIX}"'/etc/vim|' \ | ||
-i src/nvim/os/unix_defs.h || die | ||
|
||
# add eclass to bash filetypes | ||
sed -e 's|*.ebuild|*.ebuild,*.eclass|' -i runtime/filetype.vim || die | ||
|
||
# make less.sh macro actually work with neovim | ||
sed -e 's|vim |nvim |g' -i runtime/macros/less.sh || die | ||
|
||
cmake-utils_src_prepare | ||
} | ||
|
||
src_configure() { | ||
export USE_BUNDLED_DEPS=OFF | ||
append-cflags "-Wno-error" | ||
local mycmakeargs=( | ||
$(cmake-utils_use_enable jemalloc JEMALLOC) | ||
-DLIBUNIBILIUM_USE_STATIC=OFF | ||
-DLIBTERMKEY_USE_STATIC=OFF | ||
-DLIBVTERM_USE_STATIC=OFF | ||
) | ||
cmake-utils_src_configure | ||
} | ||
|
||
src_install() { | ||
cmake-utils_src_install | ||
|
||
# install a default configuration file | ||
insinto /etc/vim | ||
doins "${FILESDIR}"/sysinit.vim | ||
|
||
# conditionally install a symlink for nvimpager | ||
if use nvimpager; then | ||
dosym /usr/share/nvim/runtime/macros/less.sh /usr/bin/nvimpager | ||
fi | ||
} |