Skip to content

Commit

Permalink
dev-java/openjdk: add gcc10 patch to openjdk-8
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/721970
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Georgy Yakovlev <[email protected]>
  • Loading branch information
gyakovlev committed May 24, 2020
1 parent 30cc6d3 commit 9465512
Show file tree
Hide file tree
Showing 2 changed files with 54 additions and 0 deletions.
49 changes: 49 additions & 0 deletions dev-java/openjdk/files/openjdk-8-detect-gcc10.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
From 6d96aaac5662f734b0a933397ebb8cd4ff66606d Mon Sep 17 00:00:00 2001
From: Georgy Yakovlev <[email protected]>
Date: Sat, 23 May 2020 20:48:10 -0700
Subject: [PATCH] backport gcc10 fix

https://hg.openjdk.java.net/jdk8u/jdk8u/rev/39a7914e14a0
---
common/autoconf/generated-configure.sh | 4 ++--
common/autoconf/toolchain.m4 | 2 +-
2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/common/autoconf/generated-configure.sh b/common/autoconf/generated-configure.sh
index 5e71c50..90c017d 100644
--- a/common/autoconf/generated-configure.sh
+++ b/common/autoconf/generated-configure.sh
@@ -27955,7 +27955,7 @@ $as_echo "$as_me: The result from running with --version was: \"$COMPILER_VERSIO
COMPILER_VERSION_STRING=`$ECHO $COMPILER_VERSION_OUTPUT | \
$SED -e 's/ *Copyright .*//'`
COMPILER_VERSION_NUMBER=`$ECHO $COMPILER_VERSION_OUTPUT | \
- $SED -e 's/^.* \([1-9]\.[0-9.]*\) .*$/\1/'`
+ $SED -e 's/^.* \([1-9][0-9]*\.[0-9.]*\) .*$/\1/'`
elif test "x$TOOLCHAIN_TYPE" = xclang; then
# clang --version output typically looks like
# Apple LLVM version 5.0 (clang-500.2.79) (based on LLVM 3.3svn)
@@ -29696,7 +29696,7 @@ $as_echo "$as_me: The result from running with --version was: \"$COMPILER_VERSIO
COMPILER_VERSION_STRING=`$ECHO $COMPILER_VERSION_OUTPUT | \
$SED -e 's/ *Copyright .*//'`
COMPILER_VERSION_NUMBER=`$ECHO $COMPILER_VERSION_OUTPUT | \
- $SED -e 's/^.* \([1-9]\.[0-9.]*\) .*$/\1/'`
+ $SED -e 's/^.* \([1-9][0-9]*\.[0-9.]*\) .*$/\1/'`
elif test "x$TOOLCHAIN_TYPE" = xclang; then
# clang --version output typically looks like
# Apple LLVM version 5.0 (clang-500.2.79) (based on LLVM 3.3svn)
diff --git a/common/autoconf/toolchain.m4 b/common/autoconf/toolchain.m4
index e3a82c8..c0a4af5 100644
--- a/common/autoconf/toolchain.m4
+++ b/common/autoconf/toolchain.m4
@@ -433,7 +433,7 @@ AC_DEFUN([TOOLCHAIN_EXTRACT_COMPILER_VERSION],
COMPILER_VERSION_STRING=`$ECHO $COMPILER_VERSION_OUTPUT | \
$SED -e 's/ *Copyright .*//'`
COMPILER_VERSION_NUMBER=`$ECHO $COMPILER_VERSION_OUTPUT | \
- $SED -e 's/^.* \(@<:@1-9@:>@\.@<:@0-9.@:>@*\) .*$/\1/'`
+ $SED -e 's/^.* \(@<:@1-9@:>@@<:@0-9@:>@*\.@<:@0-9.@:>@*\) .*$/\1/'`
elif test "x$TOOLCHAIN_TYPE" = xclang; then
# clang --version output typically looks like
# Apple LLVM version 5.0 (clang-500.2.79) (based on LLVM 3.3svn)
--
2.26.2

5 changes: 5 additions & 0 deletions dev-java/openjdk/openjdk-8.252_p09.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -80,6 +80,11 @@ PDEPEND="

S="${WORKDIR}/jdk${SLOT}u-jdk${MY_PV}"

# bug 721970, JDK-8244760
PATCHES=(
"${FILESDIR}/openjdk-8-detect-gcc10.patch"
)

# The space required to build varies wildly depending on USE flags,
# ranging from 2GB to 16GB. This function is certainly not exact but
# should be close enough to be useful.
Expand Down

0 comments on commit 9465512

Please sign in to comment.