forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
gnome-extra/gnome-color-manager: bump to 3.36.0
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <[email protected]>
- Loading branch information
Showing
2 changed files
with
44 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST gnome-color-manager-3.32.0.tar.xz 2602104 BLAKE2B 6219c3b7dd31ba49c671ef1f330d8ce561b7d8716a5cf5ef393dcf827c6bbc4e82b95c082e9297a27be7652d958a92c397fbafa8bd68f2c48b32533a3fe14483 SHA512 e5b0c6a39f9202fde79af1e966be65ef3d770fe4de777a281398ee68feef6c57dee95a1fcba496512f163bf561528ece840480b3c8612b5c3af2b7f550335f38 | ||
DIST gnome-color-manager-3.36.0.tar.xz 2175016 BLAKE2B 263bc58c2a4ebafabebeba958279e4ad607eeca986dda9093c3e9d1a0870f44eefec7248aab11e6b408b063c5d5a28a3cdb88c96a58e3a0a5064055c44989143 SHA512 217c00696d7d0e99ee4cc65ee343c09682387d909feabdd6e4a52f9fd0586dda553b4796fbcb11392b880aa5c5bbaebde27906afb4e3ffd692ee3187023bfaac |
43 changes: 43 additions & 0 deletions
43
gnome-extra/gnome-color-manager/gnome-color-manager-3.36.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,43 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
inherit gnome.org meson virtualx xdg | ||
|
||
DESCRIPTION="GNOME color profile tools" | ||
HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-color-manager/" | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86" | ||
IUSE="test" | ||
RESTRICT="!test? ( test )" | ||
|
||
# Need gtk+-3.3.8 for https://bugzilla.gnome.org/show_bug.cgi?id=673331 | ||
RDEPEND=" | ||
>=dev-libs/glib-2.31.10:2 | ||
>=x11-libs/gtk+-3.3.8:3 | ||
>=x11-misc/colord-1.3.1:0= | ||
>=media-libs/lcms-2.2:2 | ||
" | ||
DEPEND="${RDEPEND}" | ||
# docbook-sgml-{utils,dtd:4.1} needed to generate man pages | ||
BDEPEND=" | ||
app-text/docbook-sgml-dtd:4.1 | ||
app-text/docbook-sgml-utils | ||
dev-util/itstool | ||
>=sys-devel/gettext-0.19.8 | ||
virtual/pkgconfig | ||
" | ||
|
||
src_configure() { | ||
# Always enable tests since they are check_PROGRAMS anyway | ||
local emesonargs=( | ||
$(meson_use test tests) | ||
) | ||
meson_src_configure | ||
} | ||
|
||
src_test() { | ||
virtx meson_src_test | ||
} |