forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-python/sphinxcontrib-websupport: initial import
Package-Manager: Portage-2.3.6, Repoman-2.3.2
- Loading branch information
Showing
3 changed files
with
59 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
DIST sphinxcontrib-websupport-1.0.1.tar.gz 590480 SHA256 7a85961326aa3a400cd4ad3c816d70ed6f7c740acd7ce5d78cd0a67825072eb9 SHA512 67807b2505e063639163b020f0e62469b0c2838c303516cce9a8d90181cc7b8a10d76532adb1267556d40f95966efc20ec9f8ee1a6731056bda827a6f97f40ec WHIRLPOOL febeb18363cb8f7a0fafbaa0e318b935fdeb44e039454561e29548404bf95f5412ef49270f6957ed109265c95db8a236ac3b7cb981a400fb8d4e896f2f01731c |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,16 @@ | ||
<?xml version="1.0" encoding="UTF-8"?> | ||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd"> | ||
<pkgmetadata> | ||
<maintainer type="project"> | ||
<email>[email protected]</email> | ||
<name>Python</name> | ||
</maintainer> | ||
<longdescription lang="en"> | ||
sphinxcontrib-webuspport provides a Python API to easily integrate | ||
Sphinx documentation into your Web application. | ||
</longdescription> | ||
<upstream> | ||
<remote-id type="pypi">sphinxcontrib-websupport</remote-id> | ||
<remote-id type="github">sphinx-doc/sphinxcontrib-websupport</remote-id> | ||
</upstream> | ||
</pkgmetadata> |
42 changes: 42 additions & 0 deletions
42
dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.0.1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,42 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
PYTHON_COMPAT=( python2_7 python3_{4,5,6} ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Sphinx websupport extension" | ||
HOMEPAGE="http://www.sphinx-doc.org" | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" | ||
|
||
LICENSE="BSD-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux" | ||
IUSE="test" | ||
|
||
CDEPEND=" | ||
>=dev-python/sqlalchemy-0.9[${PYTHON_USEDEP}] | ||
>=dev-python/whoosh-2.0[${PYTHON_USEDEP}] | ||
>=dev-python/six-1.5[${PYTHON_USEDEP}] | ||
>=dev-python/sphinx-1.5.3[${PYTHON_USEDEP}] | ||
dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}] | ||
" | ||
DEPEND="${CDEPEND} | ||
dev-python/setuptools[${PYTHON_USEDEP}] | ||
test? ( | ||
dev-python/tox[${PYTHON_USEDEP}] | ||
dev-python/pytest[${PYTHON_USEDEP}] | ||
dev-python/mock[${PYTHON_USEDEP}] | ||
) | ||
" | ||
RDEPEND="${CDEPEND}" | ||
|
||
python_install_all() { | ||
distutils-r1_python_install_all | ||
find "${ED}" -name '*.pth' -delete || die | ||
} | ||
|
||
python_test(){ | ||
${EPYTHON} -m pytest tests/ | ||
} |